update to 1.1.2
changes: -improvements for audio output on MacOS and with PulseAudio -security fix for HTTP and RTSP server components (was patched in pkgsrc)
This commit is contained in:
parent
b03400a39e
commit
7f36c05234
7 changed files with 70 additions and 142 deletions
|
@ -1,14 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.118 2011/10/07 12:30:17 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.119 2011/10/07 19:13:19 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= vlc-${VLC_VERSION}
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=vlc/} \
|
||||
http://download.videolan.org/pub/videolan/vlc/${VLC_VERSION}/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
VLC_VERSION= 1.1.11
|
||||
VLC_VERSION= 1.1.12
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.videolan.org/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.43 2011/09/12 21:50:38 shattered Exp $
|
||||
@comment $NetBSD: PLIST,v 1.44 2011/10/07 19:13:19 drochner Exp $
|
||||
bin/cvlc
|
||||
${PLIST.x11}bin/qvlc
|
||||
bin/rvlc
|
||||
|
@ -317,7 +317,6 @@ lib/vlc/plugins/video_filter/libmosaic_plugin.la
|
|||
lib/vlc/plugins/video_filter/libmotionblur_plugin.la
|
||||
lib/vlc/plugins/video_filter/libmotiondetect_plugin.la
|
||||
lib/vlc/plugins/video_filter/libnoise_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/video_filter/libosdmenu_plugin.la
|
||||
${PLIST.x11}lib/vlc/plugins/video_filter/libpanoramix_plugin.la
|
||||
lib/vlc/plugins/video_filter/libpostproc_plugin.la
|
||||
lib/vlc/plugins/video_filter/libpsychedelic_plugin.la
|
||||
|
|
|
@ -1,14 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.50 2011/10/07 12:30:17 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.51 2011/10/07 19:13:19 drochner Exp $
|
||||
|
||||
SHA1 (vlc-1.1.11.tar.bz2) = 068e75bdbfe6e595a4db14ad49e05688c8b1d5ad
|
||||
RMD160 (vlc-1.1.11.tar.bz2) = fa8a32a8e81a5f707b3cace6fa9808d5d7cb9fe6
|
||||
Size (vlc-1.1.11.tar.bz2) = 26319862 bytes
|
||||
SHA1 (vlc-1.1.12.tar.bz2) = b39de66711a33746ce12f16a50e41d3def7b1452
|
||||
RMD160 (vlc-1.1.12.tar.bz2) = 117530abc8bd3f38d9233b7a7c91a3aaa17af87c
|
||||
Size (vlc-1.1.12.tar.bz2) = 26220996 bytes
|
||||
SHA1 (patch-aa) = 684f7ad6a20ed6b9b8a8be2fc61836e6b471b686
|
||||
SHA1 (patch-ab) = 7ed32dc2a2c092083dad3c902848ba44369eac38
|
||||
SHA1 (patch-ap) = 423b571ca8a1b740812aea021e331912ba34c868
|
||||
SHA1 (patch-ar) = 25d22167cef8b8fa2a07ef633de196726eb354d2
|
||||
SHA1 (patch-ar) = f2a8b586c4672bbb0f7ccd163531c3f27eadc949
|
||||
SHA1 (patch-as) = b53b074b2791d7bf69d5f09c7c32d873608f3086
|
||||
SHA1 (patch-at) = 5761ec0809d2b03511666ae81f7b4ae01b6f5930
|
||||
SHA1 (patch-au) = 7d2371e38e3c34f85f18b7ea5662633fa156c13c
|
||||
SHA1 (patch-configure) = 83f476cc71d795a69f787713a04471e078c0ec52
|
||||
SHA1 (patch-modules_audio__output_pulse.c) = 994389b214f3e2b7b8b7ccaf3bb535a94523f81b
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.7 2011/01/24 18:54:04 drochner Exp $
|
||||
|
||||
--- configure.ac.orig 2010-11-12 07:49:28.000000000 +0900
|
||||
+++ configure.ac 2011-01-04 22:47:39.000000000 +0900
|
||||
@@ -2688,13 +2688,13 @@
|
||||
AC_DEFINE(HAVE_AVCODEC_VAAPI, 1, [Define if avcodec has to be built with VAAPI support.])
|
||||
echo "VAAPI acceleration activated"
|
||||
],[
|
||||
- AS_IF([test "${enable_libva}" == "yes"],
|
||||
+ AS_IF([test "${enable_libva}" = "yes"],
|
||||
[AC_MSG_ERROR([libva is present but libavcodec/vaapi.h is missing])],
|
||||
[AC_MSG_WARN([libva is present but libavcodec/vaapi.h is missing ])])
|
||||
])
|
||||
VLC_RESTORE_FLAGS
|
||||
],[
|
||||
- AS_IF([test "${enable_libva}" == "yes"],
|
||||
+ AS_IF([test "${enable_libva}" = "yes"],
|
||||
[AC_MSG_ERROR([Could not find required libva.])],
|
||||
[AC_MSG_WARN([libva not found ])])
|
||||
])
|
||||
@@ -2721,12 +2721,12 @@
|
||||
AC_DEFINE(HAVE_AVCODEC_DXVA2, 1, [Define if avcodec has to be built with DxVA2 support.])
|
||||
echo "DxVA2 acceleration activated"
|
||||
],[
|
||||
- AS_IF([test "${enable_dxva2}" == "yes"],
|
||||
+ AS_IF([test "${enable_dxva2}" = "yes"],
|
||||
[AC_MSG_ERROR([dxva2 is present but libavcodec/dxva2.h is missing])],
|
||||
[AC_MSG_WARN([dxva2 is present but libavcodec/dxva2.h is missing ])])
|
||||
])
|
||||
],[
|
||||
- AS_IF([test "${enable_dxva2}" == "yes"],
|
||||
+ AS_IF([test "${enable_dxva2}" = "yes"],
|
||||
[AC_MSG_ERROR([Could not find required dxva2api.h])],
|
||||
[AC_MSG_WARN([dxva2api.h not found])])
|
||||
])
|
|
@ -1,11 +1,12 @@
|
|||
$NetBSD: patch-ar,v 1.1 2011/01/24 18:54:04 drochner Exp $
|
||||
$NetBSD: patch-ar,v 1.2 2011/10/07 19:13:20 drochner Exp $
|
||||
|
||||
--- modules/misc/inhibit/xdg.c.orig 2010-11-26 22:32:46.000000000 +0000
|
||||
--- modules/misc/inhibit/xdg.c.orig 2011-10-05 21:21:12.000000000 +0000
|
||||
+++ modules/misc/inhibit/xdg.c
|
||||
@@ -26,7 +26,11 @@
|
||||
@@ -26,7 +26,12 @@
|
||||
#include <vlc_plugin.h>
|
||||
#include <vlc_inhibit.h>
|
||||
#include <assert.h>
|
||||
+#include <signal.h>
|
||||
+#ifdef _POSIX_SPAWN
|
||||
+# if (_POSIX_SPAWN >= 0)
|
||||
#include <spawn.h>
|
||||
|
@ -14,16 +15,70 @@ $NetBSD: patch-ar,v 1.1 2011/01/24 18:54:04 drochner Exp $
|
|||
#include <sys/wait.h>
|
||||
|
||||
static int Open (vlc_object_t *);
|
||||
@@ -137,6 +141,8 @@ static void *Thread (void *data)
|
||||
@@ -46,7 +51,11 @@ struct vlc_inhibit_sys
|
||||
vlc_thread_t thread;
|
||||
vlc_cond_t update, inactive;
|
||||
vlc_mutex_t lock;
|
||||
+#ifdef _POSIX_SPAWN
|
||||
+# if (_POSIX_SPAWN >= 0)
|
||||
posix_spawnattr_t attr;
|
||||
+# endif
|
||||
+#endif
|
||||
bool suspend, suspended;
|
||||
};
|
||||
|
||||
@@ -66,17 +75,29 @@ static int Open (vlc_object_t *obj)
|
||||
vlc_mutex_init (&p_sys->lock);
|
||||
vlc_cond_init (&p_sys->update);
|
||||
vlc_cond_init (&p_sys->inactive);
|
||||
+#ifdef _POSIX_SPAWN
|
||||
+# if (_POSIX_SPAWN >= 0)
|
||||
posix_spawnattr_init (&p_sys->attr);
|
||||
+# endif
|
||||
+#endif
|
||||
/* Reset signal handlers to default and clear mask in the child process */
|
||||
{
|
||||
sigset_t set;
|
||||
|
||||
sigemptyset (&set);
|
||||
+#ifdef _POSIX_SPAWN
|
||||
+# if (_POSIX_SPAWN >= 0)
|
||||
posix_spawnattr_setsigmask (&p_sys->attr, &set);
|
||||
+# endif
|
||||
+#endif
|
||||
sigaddset (&set, SIGPIPE);
|
||||
+#ifdef _POSIX_SPAWN
|
||||
+# if (_POSIX_SPAWN >= 0)
|
||||
posix_spawnattr_setsigdefault (&p_sys->attr, &set);
|
||||
posix_spawnattr_setflags (&p_sys->attr, POSIX_SPAWN_SETSIGDEF
|
||||
| POSIX_SPAWN_SETSIGMASK);
|
||||
+# endif
|
||||
+#endif
|
||||
}
|
||||
p_sys->suspend = false;
|
||||
p_sys->suspended = false;
|
||||
@@ -105,7 +126,11 @@ static void Close (vlc_object_t *obj)
|
||||
|
||||
vlc_cancel (p_sys->thread);
|
||||
vlc_join (p_sys->thread, NULL);
|
||||
+#ifdef _POSIX_SPAWN
|
||||
+# if (_POSIX_SPAWN >= 0)
|
||||
posix_spawnattr_destroy (&p_sys->attr);
|
||||
+# endif
|
||||
+#endif
|
||||
vlc_cond_destroy (&p_sys->inactive);
|
||||
vlc_cond_destroy (&p_sys->update);
|
||||
vlc_mutex_destroy (&p_sys->lock);
|
||||
@@ -151,6 +176,8 @@ static void *Thread (void *data)
|
||||
pid_t pid;
|
||||
|
||||
vlc_mutex_unlock (&p_sys->lock);
|
||||
+#ifdef _POSIX_SPAWN
|
||||
+# if (_POSIX_SPAWN >= 0)
|
||||
if (!posix_spawnp (&pid, "xdg-screensaver", NULL, NULL, argv, environ))
|
||||
if (!posix_spawnp (&pid, "xdg-screensaver", NULL, &p_sys->attr,
|
||||
argv, environ))
|
||||
{
|
||||
int status;
|
||||
@@ -146,6 +152,8 @@ static void *Thread (void *data)
|
||||
@@ -161,6 +188,8 @@ static void *Thread (void *data)
|
||||
while (waitpid (pid, &status, 0) == -1);
|
||||
}
|
||||
else/* We don't handle the error, but busy looping would be worse :( */
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
$NetBSD: patch-au,v 1.9 2011/10/07 12:30:17 drochner Exp $
|
||||
|
||||
VideoLAN-SA-1107
|
||||
|
||||
--- src/network/httpd.c.orig 2010-12-23 13:26:53.000000000 +0000
|
||||
+++ src/network/httpd.c
|
||||
@@ -1755,16 +1755,27 @@ static void httpd_ClientRecv( httpd_clie
|
||||
*p2++ = '\0';
|
||||
}
|
||||
if( !strncasecmp( p, ( cl->query.i_proto
|
||||
- == HTTPD_PROTO_HTTP ) ? "http" : "rtsp", 4 )
|
||||
- && p[4 + !!strchr( "sS", p[4] )] == ':' )
|
||||
+ == HTTPD_PROTO_HTTP ) ? "http" : "rtsp", 5 ) )
|
||||
{ /* Skip hier-part of URL (if present) */
|
||||
- p = strchr( p, ':' ) + 1; /* skip URI scheme */
|
||||
+ p += 5;
|
||||
if( !strncmp( p, "//", 2 ) ) /* skip authority */
|
||||
{ /* see RFC3986 §3.2 */
|
||||
p += 2;
|
||||
- while( *p && !strchr( "/?#", *p ) ) p++;
|
||||
+ p += strcspn( p, "/?#" );
|
||||
}
|
||||
}
|
||||
+ else
|
||||
+ if( !strncasecmp( p, ( cl->query.i_proto
|
||||
+ == HTTPD_PROTO_HTTP ) ? "https:" : "rtsps:", 6 ) )
|
||||
+ { /* Skip hier-part of URL (if present) */
|
||||
+ p += 6;
|
||||
+ if( !strncmp( p, "//", 2 ) ) /* skip authority */
|
||||
+ { /* see RFC3986 ?3.2 */
|
||||
+ p += 2;
|
||||
+ p += strcspn( p, "/?#" );
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
cl->query.psz_url = strdup( p );
|
||||
if( ( p3 = strchr( cl->query.psz_url, '?' ) ) )
|
||||
{
|
|
@ -1,49 +0,0 @@
|
|||
$NetBSD: patch-configure,v 1.6 2011/01/24 18:54:04 drochner Exp $
|
||||
|
||||
--- configure.orig 2010-11-12 08:01:11.000000000 +0900
|
||||
+++ configure 2011-01-04 22:57:48.000000000 +0900
|
||||
@@ -32744,7 +32744,7 @@
|
||||
echo "$LIBVA_PKG_ERRORS" >&5
|
||||
|
||||
|
||||
- if test "${enable_libva}" == "yes"; then :
|
||||
+ if test "${enable_libva}" = "yes"; then :
|
||||
as_fn_error $? "Could not find required libva." "$LINENO" 5
|
||||
else
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: libva not found " >&5
|
||||
@@ -32755,7 +32755,7 @@
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
$as_echo "no" >&6; }
|
||||
|
||||
- if test "${enable_libva}" == "yes"; then :
|
||||
+ if test "${enable_libva}" = "yes"; then :
|
||||
as_fn_error $? "Could not find required libva." "$LINENO" 5
|
||||
else
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: libva not found " >&5
|
||||
@@ -32805,7 +32805,7 @@
|
||||
|
||||
else
|
||||
|
||||
- if test "${enable_libva}" == "yes"; then :
|
||||
+ if test "${enable_libva}" = "yes"; then :
|
||||
as_fn_error $? "libva is present but libavcodec/vaapi.h is missing" "$LINENO" 5
|
||||
else
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: libva is present but libavcodec/vaapi.h is missing " >&5
|
||||
@@ -32879,7 +32879,7 @@
|
||||
|
||||
else
|
||||
|
||||
- if test "${enable_dxva2}" == "yes"; then :
|
||||
+ if test "${enable_dxva2}" = "yes"; then :
|
||||
as_fn_error $? "dxva2 is present but libavcodec/dxva2.h is missing" "$LINENO" 5
|
||||
else
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: dxva2 is present but libavcodec/dxva2.h is missing " >&5
|
||||
@@ -32893,7 +32893,7 @@
|
||||
|
||||
else
|
||||
|
||||
- if test "${enable_dxva2}" == "yes"; then :
|
||||
+ if test "${enable_dxva2}" = "yes"; then :
|
||||
as_fn_error $? "Could not find required dxva2api.h" "$LINENO" 5
|
||||
else
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: dxva2api.h not found" >&5
|
Loading…
Reference in a new issue