Update "milter-greylist" package to version 4.4.1.
Major changes since 4.2.7: - Allow comparison of msgsize, rcptcount & spamd, against values from LDAP - localaddr option so that Postifix user can use spf self - Allow filtering header and body against LDAP or CURL gathered properties - Add format string to report last matching LDAP or CURL propery - Add a addfooter action clause in ACL, to add mail a footer - Allow per-dacl maxpeek setting, set by maxpeer action clause in racl - Add LDAP or CURL gathered property substitution in format strings - Add continue type ACL - p0f v3 support - Fix spamd hang if message contains NULL (Enrico Scholz) - Send the queueid to spamd (Petar Bogdanovic) - Ratelimit on SMTP sessions and data size - New tarpit feature (Kouhei Sutou) - Make SpamAssassin headers Sendmail-like (Petar Bogdanovic) - Merge autowhite and greylist databases (Rudy Eschauzier) - Make LDAP querries timeout configurable - Make MX sync timeout peer-configurable (Attila Bruncsak) This update is largely based on a patch submitted by Richard Palo in PR pkg/47369.
This commit is contained in:
parent
4fa81b9292
commit
7f41308412
4 changed files with 41 additions and 26 deletions
|
@ -1,14 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.56 2012/12/30 11:43:23 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.57 2013/01/03 09:50:44 tron Exp $
|
||||
|
||||
DISTNAME= milter-greylist-4.2.7
|
||||
PKGREVISION= 2
|
||||
DISTNAME= milter-greylist-4.4.1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.espci.fr/pub/milter-greylist/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
OWNER= tron@NetBSD.org
|
||||
HOMEPAGE= http://hcpnet.free.fr/milter-greylist/
|
||||
COMMENT= Easy-to-use greylist milter for sendmail
|
||||
COMMENT= Easy-to-use greylist milter for Sendmail and Postfix
|
||||
LICENSE= original-bsd
|
||||
|
||||
# yacc rule moving to y.tab.c and renaming
|
||||
|
@ -23,6 +22,8 @@ RCD_SCRIPTS= milter-greylist
|
|||
|
||||
.include "options.mk"
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q}
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE:Q}
|
||||
CONFIGURE_ARGS+= --with-user=${MILTER_USER}
|
||||
BUILD_DEFS+= MILTER_USER MILTER_GROUP VARBASE
|
||||
FILES_SUBST+= MILTER_USER=${MILTER_USER:Q}
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.33 2012/12/30 11:41:15 tron Exp $
|
||||
$NetBSD: distinfo,v 1.34 2013/01/03 09:50:44 tron Exp $
|
||||
|
||||
SHA1 (milter-greylist-4.2.7.tgz) = 560d823b0d4fd25fba6f100ca3073b8e6c89edc2
|
||||
RMD160 (milter-greylist-4.2.7.tgz) = a0f9b01bb625b1ab125a681822ec516b8adc627a
|
||||
Size (milter-greylist-4.2.7.tgz) = 213919 bytes
|
||||
SHA1 (milter-greylist-4.4.1.tgz) = 4ed61d7f76e88266ce21096d08191c23b281bf74
|
||||
RMD160 (milter-greylist-4.4.1.tgz) = 17daad46bd5f5e1e5f62cec74d293b2599d8c147
|
||||
Size (milter-greylist-4.4.1.tgz) = 229401 bytes
|
||||
SHA1 (patch-aa) = c42757814933001ddbcdfb77dd03e17a9c4c8283
|
||||
SHA1 (patch-p0f.c) = 9bda4dff42473466548ca649580ba603bc96d389
|
||||
SHA1 (patch-spamd.c) = 4cc2804c1177d79bd36b58e34a469fa3d7c92233
|
||||
SHA1 (patch-p0f.c) = 01a16304527cad8eb0d0ad8686c2be1e90426c74
|
||||
SHA1 (patch-spamd.c) = 7347c4bc4115df743e489ba4221d3d0c50e9d1ef
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: patch-p0f.c,v 1.1 2012/03/12 13:17:22 fhajny Exp $
|
||||
$NetBSD: patch-p0f.c,v 1.2 2013/01/03 09:50:44 tron Exp $
|
||||
|
||||
. More portable int types.
|
||||
. More portable strstr in place of strcasestr.
|
||||
. Use strstr(3) in place of strcasestr(3) under SunOS.
|
||||
. Rename 'sun' to 's_un' to avoid a conflict on SunOS.
|
||||
|
||||
--- p0f.c.orig 2011-03-20 09:17:09.000000000 +0000
|
||||
+++ p0f.c
|
||||
@@ -74,25 +74,25 @@ __RCSID("$Id: p0f.c,v 1.7.2.6 2011/03/20
|
||||
--- p0f.c.orig 2012-02-21 05:53:44.000000000 +0000
|
||||
+++ p0f.c 2012-12-30 13:40:25.000000000 +0000
|
||||
@@ -75,25 +75,25 @@
|
||||
#define RESP_NOMATCH 2
|
||||
|
||||
struct p0f_query {
|
||||
|
@ -47,25 +47,28 @@ $NetBSD: patch-p0f.c,v 1.1 2012/03/12 13:17:22 fhajny Exp $
|
|||
int32_t uptime;
|
||||
};
|
||||
/* End of stuff borrowed from p0f/p0f-query.h */
|
||||
@@ -113,7 +113,7 @@ p0f_cmp(ad, stage, ap, priv)
|
||||
@@ -159,7 +159,11 @@
|
||||
return 0;
|
||||
|
||||
data = (char *)ad->string;
|
||||
- if (strcasestr(priv->priv_p0f, data) != NULL)
|
||||
+#ifdef __sun__
|
||||
+ if (strstr(priv->priv_p0f, data) != NULL)
|
||||
+#else
|
||||
if (strcasestr(priv->priv_p0f, data) != NULL)
|
||||
+#endif
|
||||
return 1;
|
||||
return 0;
|
||||
}
|
||||
@@ -262,7 +262,7 @@ p0f_sock_set(sock)
|
||||
@@ -404,7 +408,7 @@
|
||||
static int
|
||||
p0f_connect(void)
|
||||
{
|
||||
- struct sockaddr_un sun;
|
||||
+ struct sockaddr_un s_un;
|
||||
int p0fsock;
|
||||
int p0fsock = -1;
|
||||
|
||||
if (!conf.c_p0fsock[0])
|
||||
@@ -280,11 +280,11 @@ p0f_connect(void)
|
||||
@@ -424,11 +428,11 @@
|
||||
|
||||
if (conf.c_debug)
|
||||
mg_log(LOG_DEBUG, "using p0f socket \"%s\"", conf.c_p0fsock);
|
||||
|
|
|
@ -1,10 +1,20 @@
|
|||
$NetBSD: patch-spamd.c,v 1.1 2012/03/12 13:17:22 fhajny Exp $
|
||||
$NetBSD: patch-spamd.c,v 1.2 2013/01/03 09:50:44 tron Exp $
|
||||
|
||||
Rename 'sun' to 's_un' to avoid a conflict on SunOS
|
||||
|
||||
--- spamd.c.orig 2010-06-22 02:13:41.000000000 +0000
|
||||
and include <strings.h> if present
|
||||
--- spamd.c.orig 2012-02-24 02:25:46.000000000 +0000
|
||||
+++ spamd.c
|
||||
@@ -422,19 +422,19 @@ static int
|
||||
@@ -44,6 +44,9 @@ __RCSID("$Id: spamd.c,v 1.22 2012/02/24
|
||||
#include <stdlib.h>
|
||||
#include <errno.h>
|
||||
#include <string.h>
|
||||
+#ifdef HAVE_STRINGS_H
|
||||
+#include <strings.h> /* bzero, ... */
|
||||
+#endif
|
||||
#include <unistd.h>
|
||||
#include <netdb.h>
|
||||
#include <sys/types.h>
|
||||
@@ -436,12 +439,12 @@ static int
|
||||
spamd_unix_socket(path)
|
||||
char *path;
|
||||
{
|
||||
|
@ -21,8 +31,9 @@ Rename 'sun' to 's_un' to avoid a conflict on SunOS
|
|||
|
||||
if ((sock = socket(AF_UNIX, SOCK_STREAM, 0)) == -1) {
|
||||
mg_log(LOG_ERR, "spamd socket failed: %s", strerror(errno));
|
||||
return -1;
|
||||
}
|
||||
@@ -450,7 +453,7 @@ spamd_unix_socket(path)
|
||||
|
||||
SET_CLOEXEC(sock);
|
||||
|
||||
- if (connect(sock, (struct sockaddr*) &sun, sizeof(sun))) {
|
||||
+ if (connect(sock, (struct sockaddr*) &s_un, sizeof(s_un))) {
|
||||
|
|
Loading…
Reference in a new issue