jemalloc: updated to 5.1.0
5.1.0: This release is primarily about fine-tuning, ranging from several new features to numerous notable performance and portability enhancements. The release and prior dev versions have been running in multiple large scale applications for months, and the cumulative improvements are substantial in many cases.
This commit is contained in:
parent
87f2787016
commit
7f728615e9
3 changed files with 60 additions and 8 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.10 2017/08/27 12:12:25 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2018/05/15 08:35:50 adam Exp $
|
||||
|
||||
DISTNAME= jemalloc-5.0.1
|
||||
DISTNAME= jemalloc-5.1.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=jemalloc/}
|
||||
GITHUB_RELEASE= ${PKGVERSION_NOREV}
|
||||
|
@ -19,7 +19,7 @@ USE_TOOLS+= autoconf automake aclocal gmake perl:run
|
|||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --enable-cc-silence
|
||||
CONFIGURE_ARGS+= --enable-xmalloc
|
||||
CONFIGURE_ARGS+= --with-xslroot=${PREFIX}/share/xsl/docbook/
|
||||
CONFIGURE_ARGS+= --with-xslroot=${PREFIX}/share/xsl/docbook/
|
||||
PKGCONFIG_OVERRIDE= jemalloc.pc.in
|
||||
|
||||
REPLACE_PERL= bin/jeprof.in
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.7 2017/08/27 12:12:25 adam Exp $
|
||||
$NetBSD: distinfo,v 1.8 2018/05/15 08:35:50 adam Exp $
|
||||
|
||||
SHA1 (jemalloc-5.0.1.tar.bz2) = 5c2c74b8bf773df6e813f0709f55d40a8256104d
|
||||
RMD160 (jemalloc-5.0.1.tar.bz2) = f3e6fdbd4b5a00fde7de6a2d77c716a085b09943
|
||||
SHA512 (jemalloc-5.0.1.tar.bz2) = 8cb5957a5724eb2bbad120cf0028ea8b2b14b4a416c1751b7c967351a7fd51135058ea0d3c4dc1d127c86f3aa7e9fd5ef101857110aabfdb7789427791c432c3
|
||||
Size (jemalloc-5.0.1.tar.bz2) = 499300 bytes
|
||||
SHA1 (jemalloc-5.1.0.tar.bz2) = 92fdc0b38680aaee1fa7ccd89cbf1af61224ff46
|
||||
RMD160 (jemalloc-5.1.0.tar.bz2) = 52b1340ca8cafd7414aa5e3a7a028cb1feba0b80
|
||||
SHA512 (jemalloc-5.1.0.tar.bz2) = d9abebe54d303ca931b8c31c1033f23ff5fb060f2377ec8386f4d79c352e65c78ed34f680c352dac14f7d7115d10245782d553d988bc13df2eb34a2f0942ef6f
|
||||
Size (jemalloc-5.1.0.tar.bz2) = 515622 bytes
|
||||
SHA1 (patch-Makefile.in) = 62e04375dec9aab678fed5bc32559deb942e799f
|
||||
SHA1 (patch-configure) = 5dec3fb5b2ece549e40743780db3057dd83cc17e
|
||||
SHA1 (patch-src_pages.c) = 7c9eea2409b283c5dd80e52349c4dda26ae5befa
|
||||
|
|
51
devel/jemalloc/patches/patch-configure
Normal file
51
devel/jemalloc/patches/patch-configure
Normal file
|
@ -0,0 +1,51 @@
|
|||
$NetBSD: patch-configure,v 1.3 2018/05/15 08:35:50 adam Exp $
|
||||
|
||||
Do not use -O3, -g3, nor -funroll-loops; prefer PkgSrc provided compiler flags.
|
||||
|
||||
--- configure.orig 2018-05-08 19:16:45.000000000 +0000
|
||||
+++ configure
|
||||
@@ -4024,7 +4024,7 @@ fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports -g3" >&5
|
||||
$as_echo_n "checking whether compiler supports -g3... " >&6; }
|
||||
T_CONFIGURE_CFLAGS="${CONFIGURE_CFLAGS}"
|
||||
-T_APPEND_V=-g3
|
||||
+T_APPEND_V=
|
||||
if test "x${CONFIGURE_CFLAGS}" = "x" -o "x${T_APPEND_V}" = "x" ; then
|
||||
CONFIGURE_CFLAGS="${CONFIGURE_CFLAGS}${T_APPEND_V}"
|
||||
else
|
||||
@@ -5936,7 +5936,7 @@ fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports -g3" >&5
|
||||
$as_echo_n "checking whether compiler supports -g3... " >&6; }
|
||||
T_CONFIGURE_CXXFLAGS="${CONFIGURE_CXXFLAGS}"
|
||||
-T_APPEND_V=-g3
|
||||
+T_APPEND_V=
|
||||
if test "x${CONFIGURE_CXXFLAGS}" = "x" -o "x${T_APPEND_V}" = "x" ; then
|
||||
CONFIGURE_CXXFLAGS="${CONFIGURE_CXXFLAGS}${T_APPEND_V}"
|
||||
else
|
||||
@@ -8961,7 +8961,7 @@ if test "x$enable_debug" = "x0" ; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports -O3" >&5
|
||||
$as_echo_n "checking whether compiler supports -O3... " >&6; }
|
||||
T_CONFIGURE_CFLAGS="${CONFIGURE_CFLAGS}"
|
||||
-T_APPEND_V=-O3
|
||||
+T_APPEND_V=
|
||||
if test "x${CONFIGURE_CFLAGS}" = "x" -o "x${T_APPEND_V}" = "x" ; then
|
||||
CONFIGURE_CFLAGS="${CONFIGURE_CFLAGS}${T_APPEND_V}"
|
||||
else
|
||||
@@ -9012,7 +9012,7 @@ fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports -O3" >&5
|
||||
$as_echo_n "checking whether compiler supports -O3... " >&6; }
|
||||
T_CONFIGURE_CXXFLAGS="${CONFIGURE_CXXFLAGS}"
|
||||
-T_APPEND_V=-O3
|
||||
+T_APPEND_V=
|
||||
if test "x${CONFIGURE_CXXFLAGS}" = "x" -o "x${T_APPEND_V}" = "x" ; then
|
||||
CONFIGURE_CXXFLAGS="${CONFIGURE_CXXFLAGS}${T_APPEND_V}"
|
||||
else
|
||||
@@ -9075,7 +9075,7 @@ fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports -funroll-loops" >&5
|
||||
$as_echo_n "checking whether compiler supports -funroll-loops... " >&6; }
|
||||
T_CONFIGURE_CFLAGS="${CONFIGURE_CFLAGS}"
|
||||
-T_APPEND_V=-funroll-loops
|
||||
+T_APPEND_V=
|
||||
if test "x${CONFIGURE_CFLAGS}" = "x" -o "x${T_APPEND_V}" = "x" ; then
|
||||
CONFIGURE_CFLAGS="${CONFIGURE_CFLAGS}${T_APPEND_V}"
|
||||
else
|
Loading…
Reference in a new issue