Update to 1.9.2
* buildlink to print/poppler-cpp Changelog: 1.9.2 - Added missing step to the README. 1.9.1 - Save As now preserves the aspect ratio. Bug reported by Rainer Krachten. 1.9.0 - Added Czech translation provided by Pavel Fric. - Will now use the default locale's language for standard dialogs (e.g., for the file dialog). - Dragging & dropping one or two files onto the filename line edits or onto the file viewer panels is now supported. Independently suggested by Liviu Andronic and Rory Gordon. - Show Zones checkbox is always visible (it was only visible with --debug in earlier versions). - DiffPDF now starts up with its initial comparison mode being whatever comparison mode was in force when it was shut down (or Words mode the first time it is run). - Improved About box with more version info + contributors. - Added --help command line option. 1.8.0 - Introduced zoning: this can be slow in Characters mode but can provide better accuracy in text modes. 1.7.1 - Improved Character mode to be as liberal about hyphens as Words mode. - Minor doc changes that I forgot for 1.7.0. - Minor GUI bug fixes and changes. - Minor under the hood efficiency improvements. 1.7.0 - Renamed Text mode to Words mode. This mode is best for alphabetic text (e.g., English). - Added Characters mode. This mode is best for logographic text (e.g., Chinese and Japanese). This was suggested by Paul Howarth. 1.6.3 - Very minor cosmetic changes. 1.6.2 - Save button is now only enabled if there are changes. - An improved help window with slightly more information. 1.6.1 - In rare cases the highlighting on the right hand page could be in the wrong (horizontal) position; this has now been fixed. 1.6.0 - In addition to Appearance comparisons using highlighting, some composition modes can now be used to help make subtle differences more visible. (This was inspired by feedback by Florian Heiderich.) - Can now control the square size for appearance comparisons. Using very small squares can help reveal tiny Appearance differences. - Can now control the fill opacity for highlighting. - Extended zoom range from 20% to 800% (was 25% to 400%). 1.5.1 Quite a few false-positives have now been eliminated: - All hyphens are treated the same now. - Some weirdly-encoded open/close double-quotes are treated as normal Unicode open/close double-quotes. - Improved whitespace ignoring.
This commit is contained in:
parent
8622d72089
commit
7f8cab90d4
3 changed files with 18 additions and 15 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.19 2012/03/03 00:13:49 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2012/04/11 17:20:45 ryoon Exp $
|
||||
#
|
||||
|
||||
DISTNAME= diffpdf-1.5.0
|
||||
PKGREVISION= 3
|
||||
DISTNAME= diffpdf-1.9.2
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://www.qtrac.eu/
|
||||
|
||||
|
@ -17,7 +16,8 @@ USE_LANGUAGES= c++
|
|||
INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QTDIR}/bin/qmake
|
||||
cd ${WRKSRC} && ${QTDIR}/bin/lrelease diffpdf.pro && \
|
||||
${SETENV} ${MAKE_ENV} ${QTDIR}/bin/qmake
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/diffpdf ${DESTDIR}${PREFIX}/bin
|
||||
|
@ -26,5 +26,6 @@ do-install:
|
|||
|
||||
.include "../../x11/qt4-libs/buildlink3.mk"
|
||||
.include "../../x11/qt4-tools/buildlink3.mk"
|
||||
.include "../../print/poppler-cpp/buildlink3.mk"
|
||||
.include "../../print/poppler-qt4/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.6 2011/11/22 19:46:09 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.7 2012/04/11 17:20:45 ryoon Exp $
|
||||
|
||||
SHA1 (diffpdf-1.5.0.tar.gz) = f576005578ee31b69e49129ed55967435ec7e7c8
|
||||
RMD160 (diffpdf-1.5.0.tar.gz) = 99f12205bc37b00338dbb1616f65a268baeb315d
|
||||
Size (diffpdf-1.5.0.tar.gz) = 31412 bytes
|
||||
SHA1 (patch-aa) = 21175f2fd8dbf6ee78354cf941543c8e11edab8f
|
||||
SHA1 (diffpdf-1.9.2.tar.gz) = f9c22c4b1b07c25e9a8973ad07a6b78a1270255f
|
||||
RMD160 (diffpdf-1.9.2.tar.gz) = 4041ba877eea5f1f62f96033d023a5f0ea68f04c
|
||||
Size (diffpdf-1.9.2.tar.gz) = 51045 bytes
|
||||
SHA1 (patch-aa) = 2f893d32bc18e72d0189addd89bacdff8287b4af
|
||||
|
|
|
@ -1,15 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.4 2011/07/15 02:41:30 ryoon Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2012/04/11 17:20:45 ryoon Exp $
|
||||
|
||||
--- diffpdf.pro.orig 2011-06-20 08:20:22.000000000 +0000
|
||||
--- diffpdf.pro.orig 2012-02-28 09:36:12.000000000 +0000
|
||||
+++ diffpdf.pro
|
||||
@@ -14,8 +14,8 @@ exists($(HOME)/opt/poppler016/) {
|
||||
INCLUDEPATH += $(HOME)/opt/poppler016/include/poppler/qt4
|
||||
LIBS += -Wl,-rpath -Wl,$(HOME)/opt/poppler016/lib -Wl,-L$(HOME)/opt/poppler016/lib
|
||||
@@ -33,9 +33,9 @@ exists($(HOME)/opt/poppler018/) {
|
||||
INCLUDEPATH += $(HOME)/opt/poppler018/include/poppler/qt4
|
||||
LIBS += -Wl,-rpath -Wl,$(HOME)/opt/poppler018/lib -Wl,-L$(HOME)/opt/poppler018/lib
|
||||
} else {
|
||||
- exists(/usr/include/poppler/qt4) {
|
||||
- INCLUDEPATH += /usr/include/poppler/cpp
|
||||
- INCLUDEPATH += /usr/include/poppler/qt4
|
||||
+ exists($(LOCALBASE)/include/poppler/qt4) {
|
||||
+ INCLUDEPATH += $(LOCALBASE)/include/poppler/cpp
|
||||
+ INCLUDEPATH += $(LOCALBASE)/include/poppler/qt4
|
||||
} else {
|
||||
INCLUDEPATH += /usr/local/include/poppler/cpp
|
||||
INCLUDEPATH += /usr/local/include/poppler/qt4
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue