Initial import of muse-0.9 from pkgsrc-wip.
MuSE is an application for the mixing, encoding, and network streaming of sound. MuSE can simultaniously mix up to 6 encoded audio bitstreams (from files or network) plus a soundcard input signal. The resulting stream can be played locally on the sound card and/or encoded as an mp3 bitstream sent to a broadcast server. MuSE offers an intuitive interface to be operated realtime and can run in "slick" mode from commandline.
This commit is contained in:
parent
302942d548
commit
7f9fd87797
8 changed files with 115 additions and 0 deletions
6
audio/muse/DESCR
Normal file
6
audio/muse/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
MuSE is an application for the mixing, encoding, and network streaming of
|
||||
sound. MuSE can simultaniously mix up to 6 encoded audio bitstreams (from
|
||||
files or network) plus a soundcard input signal. The resulting stream can
|
||||
be played locally on the sound card and/or encoded as an mp3 bitstream sent
|
||||
to a broadcast server. MuSE offers an intuitive interface to be operated
|
||||
realtime and can run in "slick" mode from commandline.
|
37
audio/muse/Makefile
Normal file
37
audio/muse/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/05/02 22:59:16 xtraeme Exp $
|
||||
#
|
||||
|
||||
DISTNAME= MuSE-0.9
|
||||
PKGNAME= ${DISTNAME:S/MuSE/muse/}
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ftp://ftp.dyne.org/muse/releases/ \
|
||||
http://www.ljudmila.org/~jaromil/muse/releases/ \
|
||||
ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/
|
||||
|
||||
MAINTAINER= xtraeme@NetBSD.org
|
||||
HOMEPAGE= http://muse.dyne.org/
|
||||
COMMENT= Multiple Streaming Engine
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BUILDLINK3= yes
|
||||
USE_GNU_TOOLS+= make
|
||||
USE_X11= yes
|
||||
|
||||
CONFIGURE_ARGS+= --disable-ncurses
|
||||
CONFIGURE_ARGS+= --enable-gtk2
|
||||
LIBS+= ${LIBOSSAUDIO}
|
||||
|
||||
SUBST_CLASSES= dsp
|
||||
SUBST_STAGE.dsp= post-patch
|
||||
SUBST_FILES.dsp= src/jmixer.cpp src/libmpeg/fileplayer.cc
|
||||
SUBST_SED.dsp= -e "s,/dev/dsp,${DEVOSSAUDIO},g"
|
||||
SUBST_MESSAGE.dsp= "Fixing harcoded audio device."
|
||||
|
||||
.include "../../audio/lame/buildlink3.mk"
|
||||
.include "../../audio/libvorbis/buildlink3.mk"
|
||||
.include "../../audio/libsndfile/buildlink3.mk"
|
||||
.include "../../devel/pkgconfig/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/ossaudio.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
13
audio/muse/PLIST
Normal file
13
audio/muse/PLIST
Normal file
|
@ -0,0 +1,13 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/05/02 22:59:16 xtraeme Exp $
|
||||
bin/muse
|
||||
doc/MuSE/AUTHORS
|
||||
doc/MuSE/COPYING
|
||||
doc/MuSE/ChangeLog
|
||||
doc/MuSE/KNOWN-BUGS
|
||||
doc/MuSE/NEWS
|
||||
doc/MuSE/README
|
||||
doc/MuSE/TODO
|
||||
doc/MuSE/USAGE
|
||||
man/man1/muse.1
|
||||
@dirrm doc/MuSE
|
||||
@dirrm doc
|
8
audio/muse/distinfo
Normal file
8
audio/muse/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/05/02 22:59:16 xtraeme Exp $
|
||||
|
||||
SHA1 (MuSE-0.9.tar.gz) = c73dfe6cf5a8da3430864a76d0bc8d9f2cb7d118
|
||||
Size (MuSE-0.9.tar.gz) = 1363091 bytes
|
||||
SHA1 (patch-aa) = a30a5f2a76081b188c2859d5b77185a26e95fc7e
|
||||
SHA1 (patch-ab) = fb6c26cd57534ebd82db21508a9cd9e98e0f6bc7
|
||||
SHA1 (patch-ac) = f66b7f258cc765323f4ac3041aa7e43c8f8b7b08
|
||||
SHA1 (patch-ad) = 5f2322a1c9c3c9ee4e4dbe3aa810c0f2c5d999fd
|
13
audio/muse/patches/patch-aa
Normal file
13
audio/muse/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/05/02 22:59:16 xtraeme Exp $
|
||||
|
||||
--- src/shout/sock.h.orig 2004-04-30 01:49:50.000000000 +0200
|
||||
+++ src/shout/sock.h 2004-04-30 01:50:10.000000000 +0200
|
||||
@@ -31,7 +31,7 @@
|
||||
#include <unistd.h>
|
||||
#endif
|
||||
|
||||
-#ifdef HAVE_SYS_UIO_H
|
||||
+#if defined(HAVE_SYS_UIO_H) || defined(__NetBSD__)
|
||||
#include <sys/uio.h>
|
||||
#else
|
||||
#ifndef _SYS_UIO_H
|
13
audio/muse/patches/patch-ab
Normal file
13
audio/muse/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2004/05/02 22:59:16 xtraeme Exp $
|
||||
|
||||
--- src/jmixer.cpp.orig 2004-05-03 00:53:39.000000000 +0200
|
||||
+++ src/jmixer.cpp 2004-05-03 00:53:50.000000000 +0200
|
||||
@@ -98,7 +98,7 @@
|
||||
error("error initializing POSIX thread mutex");
|
||||
if(pthread_cond_init (&_cond, NULL) == -1)
|
||||
error("error initializing POSIX thread condtition");
|
||||
- unlock();
|
||||
+ //unlock();
|
||||
}
|
||||
|
||||
Stream_mixer::~Stream_mixer() {
|
13
audio/muse/patches/patch-ac
Normal file
13
audio/muse/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2004/05/02 22:59:16 xtraeme Exp $
|
||||
|
||||
--- src/pipe.cpp.orig 2004-05-03 00:42:40.000000000 +0200
|
||||
+++ src/pipe.cpp 2004-05-03 00:43:56.000000000 +0200
|
||||
@@ -61,7 +61,7 @@
|
||||
end=start=buffer;
|
||||
blocking = true;
|
||||
_thread_init();
|
||||
- unlock();
|
||||
+ //unlock();
|
||||
}
|
||||
|
||||
Pipe::~Pipe() {
|
12
audio/muse/patches/patch-ad
Normal file
12
audio/muse/patches/patch-ad
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2004/05/02 22:59:16 xtraeme Exp $
|
||||
|
||||
--- src/gtkgui2/gtk2_gui.cpp.orig 2004-05-03 00:51:21.000000000 +0200
|
||||
+++ src/gtkgui2/gtk2_gui.cpp 2004-05-03 00:51:33.000000000 +0200
|
||||
@@ -47,6 +47,7 @@
|
||||
_mix->quit = true;
|
||||
} else {
|
||||
int i;
|
||||
+ lock();
|
||||
wait();
|
||||
|
||||
/* update channels */
|
Loading…
Reference in a new issue