update to version 0.9.8

Changes from 0.9.5 to 0.9.8
===========================

* Added support for aborting automatically pending commands
  that never receives the reply (to avoid memory leaks).
* Added support for removing explicitly added client connections
  in rehash and closing the client connections if they were
  unconfigured in the rehash.
* Rewrote WHOIS, WHOWAS and IDENTIFY commands in the server.
* If packet processing fails (like integrity check fails)
  the connection is closed now.
* Normal server now reconnects to backup router automatically
  if connection is lost to it.
* Added support for replying on behalf of the user to the
  Requested Attributes in WHOIS command in the server.
* Failed OPER and SILCOPER authentications are now logged.
* Added sort-of "Quality of Service" (QoS) support. Data
  reception can be controlled with rate limit per second
  and/or read data length limit.
* Added support for encrypted private key files. Now passphrase
  must be provided when new key pair is created , and prompted
  when loading the private key.

* Resumed client packet handling from server put the resumed
  client on wrong list on router and caused the client not be
  present on the network anymore.
* Various cleanup in error message output in config parsing code
  and in server init code.  Fixed error log files containing too
  many newlines in some situations.
* Assure that channel key is set before sending it.  May crash
  server otherwise.
* Don't swtich to become primary router if we are backup if
  decryption error has occurred.
* Fixed a bug in backup router IP address comparison
* Fixed a crashbug in incoming server accepting.
* Fixed packet decryption problem when backup router encrypted
  channel message with wrong key during backup resuming protocol.
* Fixed memory leaks in server.
* Fixed channel key packet processing bug on backup router
  during backup resuming protocol.
This commit is contained in:
salo 2002-11-21 15:42:45 +00:00
parent c41dd0cca9
commit 7fa14c31b7
4 changed files with 44 additions and 7 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.15 2002/09/19 09:04:04 jlam Exp $
# $NetBSD: Makefile,v 1.16 2002/11/21 15:42:45 salo Exp $
DISTNAME= silc-server-0.9.5
DISTNAME= silc-server-0.9.8
CATEGORIES= chat security
MASTER_SITES= http://www.silcnet.org/download/server/sources/ \
ftp://ftp.silcnet.org/silc/server/sources/ \
@ -11,7 +11,7 @@ MASTER_SITES= http://www.silcnet.org/download/server/sources/ \
http://www.at.silcnet.org/download/server/sources/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= salo@silcnet.org
MAINTAINER= salo@netbsd.org
HOMEPAGE= http://www.silcnet.org/
COMMENT= Server for the Secure Internet Live Conferencing (SILC) protocol
@ -50,6 +50,7 @@ RCD_SCRIPT_SRC.silcd= ${FILESDIR}/silcd.generic
OWN_DIRS_PERMS+= /var/log/silcd ${SILCD_USER} ${SILCD_GROUP} 0700
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/silcd
CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/silcd
CONFIGURE_ARGS+= --with-etcdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --with-silcd-config-file=${PKG_SYSCONFDIR}/silcd.conf
@ -70,6 +71,17 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --disable-asm
.endif
# Temporary hack which prevents installation of static libraries
#
post-build:
for file in \
${WRKSRC}/lib/libsilc.la \
${WRKSRC}/lib/.libs/libsilc.la ; \
do \
${CP} $$file $$file.orig ; \
${SED} "s|^old_library|#&|" $$file.orig > $$file ; \
done
post-install:
@${SED} ${FILES_SUBST_SED} ${FILESDIR}/motd.txt \
> ${PREFIX}/share/examples/silcd/motd.txt.default

View file

@ -1,5 +1,9 @@
@comment $NetBSD: PLIST,v 1.6 2002/09/20 23:45:44 jlam Exp $
@comment $NetBSD: PLIST,v 1.7 2002/11/21 15:42:45 salo Exp $
etc/rc.d/silcd
lib/silcd/libsilc.la
lib/silcd/libsilc.so
lib/silcd/libsilc.so.0
lib/silcd/libsilc.so.0.0
lib/silcd/modules/aes.sim.so
lib/silcd/modules/blowfish.sim.so
lib/silcd/modules/cast.sim.so

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.13 2002/09/14 02:59:26 hubertf Exp $
$NetBSD: distinfo,v 1.14 2002/11/21 15:42:45 salo Exp $
SHA1 (silc-server-0.9.5.tar.bz2) = b1c044184ddf1d905862d9266d059f5f613f9da4
Size (silc-server-0.9.5.tar.bz2) = 974855 bytes
SHA1 (silc-server-0.9.8.tar.bz2) = e552e8205954acd3dcc85a76785a555679ea26b1
Size (silc-server-0.9.8.tar.bz2) = 1110670 bytes
SHA1 (patch-aa) = 2bea3a68a7f7999709f851c3d97ab5249c7c2dba
SHA1 (patch-ab) = 17500e9fdf04e0691e4398c9aaf5e0d9274e87a7
SHA1 (patch-ac) = 1dd4137e639b5e2b4ba99e6ae65c5e583257a9ef

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ac,v 1.4 2002/11/21 15:42:45 salo Exp $
--- lib/Makefile.in.orig Thu Nov 21 07:34:37 2002
+++ lib/Makefile.in Thu Nov 21 07:43:54 2002
@@ -529,12 +529,9 @@
-rm -rf libsilc.a
-rm -rf libsilcclient.a
-@SILC_DIST_TOOLKIT_TRUE@install-exec-hook:
-@SILC_DIST_TOOLKIT_TRUE@ -mkdir -p $(libdir)
-@SILC_DIST_TOOLKIT_TRUE@ -$(LIBTOOL) $(INSTALL) libsilc.la $(libdir)/
-@SILC_DIST_TOOLKIT_TRUE@ -$(LIBTOOL) $(INSTALL) libsilcclient.la $(libdir)/
-@SILC_DIST_TOOLKIT_FALSE@install-exec-hook:
-@SILC_DIST_TOOLKIT_FALSE@ -cd
+install-exec-hook:
+ -mkdir -p $(libdir)
+ -$(LIBTOOL) $(INSTALL) libsilc.la $(libdir)/
# WIN32 DLL generation
@SILC_DIST_WIN32DLL_TRUE@silc.dll: libsilc.a