Additional patches resolve gcc3 issues in cpp code & conf macro.
Approved by jlam@netbsd.org
This commit is contained in:
parent
a47d583e8f
commit
7fb103ae79
3 changed files with 46 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.6 2003/03/02 08:39:18 jtb Exp $
|
||||
$NetBSD: distinfo,v 1.7 2003/10/26 14:05:59 rtr Exp $
|
||||
|
||||
SHA1 (netcdf-3.5.0.tar.Z) = e9c5a9847d8ff9b3e1b8a18f5e216f6a1508bce8
|
||||
Size (netcdf-3.5.0.tar.Z) = 1319419 bytes
|
||||
|
@ -10,3 +10,5 @@ SHA1 (patch-af) = 42a96275cc048d796452c20c7c6f24ac651e8877
|
|||
SHA1 (patch-ag) = 214b7c241bc71e5ebbef1e3f9f8a661acaf05228
|
||||
SHA1 (patch-ah) = 11083d7a775ca6199162fe3b14776ca24b5c009a
|
||||
SHA1 (patch-ai) = fb8386c47a2b0e2468bf31a424738979c472de94
|
||||
SHA1 (patch-aj) = beff85a29fa6407bde19bc2061b2082b4b5cb5d1
|
||||
SHA1 (patch-ak) = 7378c3ce65bb639051c385885e3a1d186514f697
|
||||
|
|
14
devel/netcdf/patches/patch-aj
Normal file
14
devel/netcdf/patches/patch-aj
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- configure.orig 2003-10-26 08:17:58.000000000 +1100
|
||||
+++ configure 2003-10-26 08:18:12.000000000 +1100
|
||||
@@ -1232,9 +1232,9 @@
|
||||
extern "C" void exit(int);
|
||||
#endif
|
||||
|
||||
- #include <iostream.h>
|
||||
+ #include <iostream>
|
||||
int main() {
|
||||
- cout << "";
|
||||
+ std::cout << "";
|
||||
return 0;
|
||||
}
|
||||
|
29
devel/netcdf/patches/patch-ak
Normal file
29
devel/netcdf/patches/patch-ak
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- cxx/netcdfcpp.h.orig 2003-10-26 08:25:59.000000000 +1100
|
||||
+++ cxx/netcdfcpp.h 2003-10-26 08:26:58.000000000 +1100
|
||||
@@ -154,7 +154,7 @@
|
||||
virtual ~NcDim( void );
|
||||
|
||||
// to construct dimensions, since constructor is private
|
||||
- friend NcFile;
|
||||
+ friend class NcFile;
|
||||
};
|
||||
|
||||
|
||||
@@ -357,7 +357,7 @@
|
||||
void init_cur( void );
|
||||
|
||||
// to make variables, since constructor is private
|
||||
- friend NcFile;
|
||||
+ friend class NcFile;
|
||||
};
|
||||
|
||||
|
||||
@@ -388,7 +388,7 @@
|
||||
NcAtt( NcFile*, NcToken); // global attribute
|
||||
|
||||
// To make attributes, since constructor is private
|
||||
- friend NcFile;
|
||||
+ friend class NcFile;
|
||||
friend NcAtt* NcVar::get_att( NcToken ) const;
|
||||
};
|
||||
|
Loading…
Reference in a new issue