Support for bison-1.34 needs a further directory to be patched.

Solves PR pkg/16137 together with the bison patches committed yesterday.
This commit is contained in:
mrauch 2002-03-31 12:21:08 +00:00
parent a7434090ff
commit 7fc8b78358
5 changed files with 63 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2002/03/29 21:00:10 mrauch Exp $
$NetBSD: distinfo,v 1.9 2002/03/31 12:21:08 mrauch Exp $
SHA1 (oo_641_src.tar.bz2) = ad4c7000cf317d7e9d694a6d519336bfaf1f8edd
Size (oo_641_src.tar.bz2) = 109167758 bytes
@ -115,3 +115,7 @@ SHA1 (patch-eb) = 5c92c48896b528c9ba160d605b08886420db9105
SHA1 (patch-ec) = 99203cfaae8432ae4b83a7e31eee23dd419e0ade
SHA1 (patch-ed) = 1e1483e78b42bf8489f871a745eb71e63b8b435a
SHA1 (patch-ee) = c7e9cf634734d0c280544ff509b3726a72600805
SHA1 (patch-ef) = 01a20c0760e672568ba081641fb02ded063eaab1
SHA1 (patch-eg) = a9401de191f9742be774ff5f9af4f5f7edc2d5dc
SHA1 (patch-eh) = d1e51e51968ce304acd1ebe81da7a5490e0b29eb
SHA1 (patch-ei) = 8fe556f807ccb8f3701564952f346cbfe9c3b1b6

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ef,v 1.1 2002/03/31 12:21:09 mrauch Exp $
--- ../connectivity/prj/d.lst.orig Fri Mar 2 22:30:57 2001
+++ ../connectivity/prj/d.lst
@@ -9,7 +9,7 @@
mkdir: %_DEST%\inc%_EXT%\connectivity\sdbcx
hedabu: ..\inc\connectivity\*.hxx %_DEST%\inc%_EXT%\connectivity\*.hxx
-hedabu: ..\%__SRC%\inc\connectivity\sqlbison.hxx %_DEST%\inc%_EXT%\connectivity\sqlbison.hxx
+hedabu: ..\%__SRC%\inc\sqlbison.hxx %_DEST%\inc%_EXT%\connectivity\sqlbison.hxx
hedabu: ..\inc\connectivity\sdbcx\*.hxx %_DEST%\inc%_EXT%\connectivity\sdbcx\*.hxx

View file

@ -0,0 +1,19 @@
$NetBSD: patch-eg,v 1.1 2002/03/31 12:21:09 mrauch Exp $
--- ../scptools/source/compiler/makefile.mk.orig Mon Sep 18 16:47:19 2000
+++ ../scptools/source/compiler/makefile.mk
@@ -70,13 +70,9 @@
# --- Settings -----------------------------------------------------
-.INCLUDE : svpre.mk
.INCLUDE : settings.mk
-.INCLUDE : sv.mk
-YACCOUT=$(INCCOM)
-
-YACCTARGET = $(YACCOUT)$/rscyacc.yxx
+YACCTARGET = $(INCCOM)$/yyrscyacc.cxx
YACCFILES = parser.y
CXXFILES = parser.cxx \

View file

@ -0,0 +1,13 @@
$NetBSD: patch-eh,v 1.1 2002/03/31 12:21:09 mrauch Exp $
--- ../scptools/source/compiler/lex.cxx.orig Mon Sep 18 16:47:19 2000
+++ ../scptools/source/compiler/lex.cxx
@@ -61,7 +61,7 @@
#include <string.h>
#include "parser.hxx"
-#include "rscyacc.yxx.h"
+#include "yyrscyacc.hxx"
int line;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ei,v 1.1 2002/03/31 12:21:09 mrauch Exp $
--- ../scptools/source/compiler/parser.cxx.orig Wed Nov 22 13:43:59 2000
+++ ../scptools/source/compiler/parser.cxx
@@ -260,7 +260,7 @@
///////////////////////////////////////////////////////////////////////////////
-#include "rscyacc.yxx"
+#include "yyrscyacc.cxx"
int __LOADONCALLAPI main( int argv, char** argc )
{