- update to v1.4.1
- grab maintainership - ok'ed wiz@, snj@, schmonz@ Lots of changes, please see http://www.akhphd.au.dk/~bertho/cvsgraph/#changes for full details. In brief: - Implement new option to generate proper maps for different levels of HTML. - Lots of bug fixes - Implemented folding of empty branches - Implemented logentry expansions using %l and %L - You can now instruct CvsGraph to ommit all revisions that are not tagged - Configuration no longer requires a configuration file
This commit is contained in:
parent
15bf86dbc5
commit
7fde6b3e6e
3 changed files with 19 additions and 18 deletions
|
@ -1,12 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.12 2004/07/24 02:53:53 grant Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2004/08/10 15:10:50 adrianp Exp $
|
||||
#
|
||||
|
||||
DISTNAME= cvsgraph-1.2.0
|
||||
PKGREVISION= 3
|
||||
DISTNAME= cvsgraph-1.4.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.akhphd.au.dk/~bertho/cvsgraph/release/
|
||||
|
||||
MAINTAINER= schmonz@NetBSD.org
|
||||
MAINTAINER= adrianp@NetBSD.org
|
||||
HOMEPAGE= http://www.akhphd.au.dk/~bertho/cvsgraph/
|
||||
COMMENT= Graphically represents CVS/RCS branches and file revisions
|
||||
|
||||
|
@ -20,16 +19,18 @@ DOCDIR= ${PREFIX}/share/doc/${PKGBASE}
|
|||
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
|
||||
CONF_FILES= ${EGDIR}/cvsgraph.conf ${PKG_SYSCONFDIR}/cvsgraph.conf
|
||||
PLIST_SUBST+= PKGBASE=${PKGBASE}
|
||||
FILES_SUBST= PKG_SYSCONFDIR=${PKG_SYSCONFDIR}
|
||||
|
||||
ALL_TARGET= cvsgraph
|
||||
|
||||
pre-install:
|
||||
cd ${WRKSRC}; ${SED} ${FILES_SUBST_SED} cvsgraph.1 > cvsgraph.1.nb
|
||||
SUBST_CLASSES= man
|
||||
SUBST_STAGE.man= pre-install
|
||||
SUBST_FILES.man= cvsgraph.1
|
||||
SUBST_SED.man= -e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g"
|
||||
SUBST_MESSAGE.man= "Fixing man page paths."
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/cvsgraph ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/cvsgraph.1.nb ${PREFIX}/man/man1/cvsgraph.1
|
||||
${INSTALL_MAN} ${WRKSRC}/cvsgraph.1 ${PREFIX}/man/man1/
|
||||
${INSTALL_MAN} ${WRKSRC}/cvsgraph.conf.5 ${PREFIX}/man/man5
|
||||
|
||||
${INSTALL_DATA_DIR} ${DOCDIR}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2002/03/01 12:24:43 martti Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/08/10 15:10:50 adrianp Exp $
|
||||
|
||||
SHA1 (cvsgraph-1.2.0.tar.gz) = d953bb3db4c183e1c71a76c18acb9fbcdfdce342
|
||||
Size (cvsgraph-1.2.0.tar.gz) = 60029 bytes
|
||||
SHA1 (patch-aa) = 2b42222cdf0fe979268500860c5d701f706cb8bd
|
||||
SHA1 (cvsgraph-1.4.1.tar.gz) = a32ff9d2d13ea1d485a190edfb1262d1182214e8
|
||||
Size (cvsgraph-1.4.1.tar.gz) = 91932 bytes
|
||||
SHA1 (patch-aa) = c2020ce2578856f20b47e81e996ce3020f6a4a1a
|
||||
SHA1 (patch-ab) = e77e34a2659287b21ec3c134e50cbd8b39877bbe
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/12/09 14:25:00 mjl Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2004/08/10 15:10:50 adrianp Exp $
|
||||
|
||||
--- Makefile.in.orig Tue Nov 20 10:25:41 2001
|
||||
+++ Makefile.in
|
||||
--- Makefile.in.orig Fri Aug 6 18:30:24 2004
|
||||
+++ Makefile.in Fri Aug 6 18:31:18 2004
|
||||
@@ -10,6 +10,7 @@
|
||||
|
||||
LIBS = @LIBS@
|
||||
CFLAGS = @CFLAGS@ -DETCDIR=\"$(ETCDIR)\"
|
||||
CFLAGS = @CFLAGS@ -DETCDIR=\"$(ETCDIR)\" -DINTTYPE="@INTTYPE@"
|
||||
+LDFLAGS = @LDFLAGS@
|
||||
YACCFLAGS= -t
|
||||
LEXFLAGS= @LEXFLAGS@ -d #-b
|
||||
|
||||
@@ -33,7 +34,7 @@
|
||||
$(CC) $(CFLAGS) -c -o $*.o $<
|
||||
@@ -34,7 +35,7 @@
|
||||
all: $(TARGET)
|
||||
|
||||
$(TARGET): $(COBJS) $(GENOBJS)
|
||||
- $(CC) $(CFLAGS) -o $(TARGET) $(COBJS) $(GENOBJS) $(LIBS)
|
||||
|
|
Loading…
Reference in a new issue