Fix build on DragonFly.
This commit is contained in:
parent
d8d0707e43
commit
8010a2fdef
2 changed files with 26 additions and 7 deletions
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.13 2007/01/04 11:29:07 rillig Exp $
|
||||
$NetBSD: distinfo,v 1.14 2007/02/02 17:05:58 joerg Exp $
|
||||
|
||||
SHA1 (anjuta-2.0.2.tar.gz) = 5f11f6b642c310b8838237da5965272ebbd27426
|
||||
RMD160 (anjuta-2.0.2.tar.gz) = 9931311e2f65f66d149e64a02e1996b2b972b925
|
||||
Size (anjuta-2.0.2.tar.gz) = 6844511 bytes
|
||||
SHA1 (patch-ba) = fc3a8036ff7886246fc21203b292be89585fa474
|
||||
SHA1 (patch-bb) = 475bd6829e33ea786c122828dbba20e030c252a1
|
||||
SHA1 (patch-bb) = 9d4a6f63c9ba72d15c034bc3752320e5492c9cb2
|
||||
SHA1 (patch-bc) = 0e81a73de07cf24a20bcf7c7c35f8f5c280e2311
|
||||
SHA1 (patch-bd) = ffd4a8d3e1b88114d9642930066dde859910d894
|
||||
SHA1 (patch-be) = 9b0b0340d611c2ae6710028efb8457e21aa7cf30
|
||||
|
|
|
@ -1,13 +1,32 @@
|
|||
$NetBSD: patch-bb,v 1.1 2007/01/04 11:29:07 rillig Exp $
|
||||
$NetBSD: patch-bb,v 1.2 2007/02/02 17:05:58 joerg Exp $
|
||||
|
||||
--- libanjuta/anjuta-launcher.c.orig 2006-02-26 11:15:28.000000000 +0100
|
||||
+++ libanjuta/anjuta-launcher.c 2007-01-04 04:12:41.000000000 +0100
|
||||
@@ -24,7 +24,7 @@
|
||||
--- libanjuta/anjuta-launcher.c.orig 2006-02-26 10:15:28.000000000 +0000
|
||||
+++ libanjuta/anjuta-launcher.c
|
||||
@@ -24,7 +24,9 @@
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <signal.h>
|
||||
-#ifndef sun
|
||||
+#if !defined(__sun) && !defined(__NetBSD__)
|
||||
+#if defined(__DragonFly__)
|
||||
+#include <libutil.h>
|
||||
+#elif !defined(__sun) && !defined(__NetBSD__)
|
||||
#include <pty.h>
|
||||
#endif
|
||||
#include <assert.h>
|
||||
@@ -48,7 +50,15 @@
|
||||
#define ANJUTA_PIXMAP_PASSWORD "password.png"
|
||||
#define FILE_BUFFER_SIZE 1024
|
||||
#ifndef __MAX_BAUD
|
||||
-#define __MAX_BAUD B460800
|
||||
+# ifdef B460800
|
||||
+# define __MAX_BAUD B460800
|
||||
+# else
|
||||
+# define __MAX_BAUD B230400
|
||||
+# endif
|
||||
+#endif
|
||||
+
|
||||
+#if defined(__DragonFly__) && !defined(O_SYNC)
|
||||
+#define O_SYNC O_FSYNC
|
||||
#endif
|
||||
|
||||
/*
|
||||
|
|
Loading…
Reference in a new issue