Update to version 20061217.
requested by <martin> Changes: 20061217: ========= - Portability fix: provide a replacement daemon(3) if necessary. 20061204: ========= - Fix buffer overflow in local version of glob(3). (already fixed in pkgsrc) - Implement -D to run as a stand-alone daemon. - Add ftpd.conf(5) options: hidesymlinks recvbufsize - Enforce account expiration, and support shadow password aging where appropriate. - Return 450 instead of 550 upon NLST error. - Portability fixes and improvements.
This commit is contained in:
parent
2ebb1632fc
commit
803c82f337
3 changed files with 6 additions and 23 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.16 2007/01/07 09:14:07 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2007/03/01 14:01:21 salo Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tnftpd-20040810
|
||||
PKGREVISION= 1
|
||||
DISTNAME= tnftpd-20061217
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.NetBSD.org/pub/NetBSD/misc/tnftp/
|
||||
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.7 2006/12/02 23:00:04 adrianp Exp $
|
||||
$NetBSD: distinfo,v 1.8 2007/03/01 14:01:21 salo Exp $
|
||||
|
||||
SHA1 (tnftpd-20040810.tar.gz) = 1f00770edf0ae031183f9a940d9b776f6610e4ea
|
||||
RMD160 (tnftpd-20040810.tar.gz) = 210736c475301c38896039c52287f01fb1b41636
|
||||
Size (tnftpd-20040810.tar.gz) = 178638 bytes
|
||||
SHA1 (patch-aa) = 17abae4bd5bf26213539cdd5f160272ac1a39942
|
||||
SHA1 (tnftpd-20061217.tar.gz) = a81e69c648397c15541683910495037683d87d2f
|
||||
RMD160 (tnftpd-20061217.tar.gz) = 9f098e35e549a202a7a392898095ee91f34e8604
|
||||
Size (tnftpd-20061217.tar.gz) = 187602 bytes
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2006/12/02 23:00:04 adrianp Exp $
|
||||
|
||||
--- libnetbsd/glob.c.orig 2003-12-15 12:18:43.000000000 +0000
|
||||
+++ libnetbsd/glob.c
|
||||
@@ -497,7 +497,9 @@ glob1(Char *pattern, glob_t *pglob, size
|
||||
* we save one character so that we can use ptr >= limit,
|
||||
* in the general case when we are appending non nul chars only.
|
||||
*/
|
||||
- return(glob2(pathbuf, pathbuf, pathbuf + sizeof(pathbuf) - 1, pattern,
|
||||
+ return(glob2(pathbuf, pathbuf,
|
||||
+ pathbuf + (sizeof(pathbuf) / sizeof(*pathbuf)) - 1,
|
||||
+ pattern,
|
||||
pglob, limit));
|
||||
}
|
||||
|
Loading…
Reference in a new issue