Changes 20050830:
- A lot more theming support. - Many improvements to the various crypto dlls. - More LDAP support. - Beginnings of an MSXML implementation. - Better MSHTML support. - Emulated version now set to Windows 2000 by default. - Direct3D fixes and improvements. - Lots of bug fixes.
This commit is contained in:
parent
b15fa5bf78
commit
807c876753
7 changed files with 73 additions and 86 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.89 2005/08/12 13:57:44 salo Exp $
|
||||
# $NetBSD: Makefile,v 1.90 2005/09/07 14:28:38 adam Exp $
|
||||
|
||||
DISTNAME= Wine-20050725
|
||||
DISTNAME= Wine-20050830
|
||||
PKGNAME= ${DISTNAME:S/W/w/}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=wine/} \
|
||||
http://www.ibiblio.org/pub/Linux/ALPHA/wine/development/ \
|
||||
|
@ -21,9 +20,11 @@ ONLY_FOR_PLATFORM+= FreeBSD*-i386 Linux*-i386 SunOS*-i386 Darwin*-i386
|
|||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/W/w/}
|
||||
USE_LIBTOOL= yes
|
||||
USE_NCURSES= yes
|
||||
USE_TOOLS+= bison gmake mktemp
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --without-curses --disable-trace --disable-debug
|
||||
CONFIGURE_ARGS+= --disable-debug
|
||||
CONFIGURE_ARGS+= --disable-trace
|
||||
CONFIGURE_ENV+= ac_cv_path_ARTSCCONFIG=${TRUE}
|
||||
CONFIGURE_ENV+= ac_cv_prog_sane_devel=no
|
||||
UNLIMIT_RESOURCES= datasize
|
||||
|
@ -40,7 +41,9 @@ LIBS+= ${LDFLAGS}
|
|||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../audio/esound/buildlink3.mk"
|
||||
.include "../../databases/openldap/buildlink3.mk"
|
||||
.include "../../devel/ncurses/buildlink3.mk"
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../graphics/glu/buildlink3.mk"
|
||||
.include "../../graphics/glut/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.32 2005/07/26 13:24:36 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.33 2005/09/07 14:28:38 adam Exp $
|
||||
bin/function_grep.pl
|
||||
bin/msiexec
|
||||
bin/notepad
|
||||
|
@ -32,6 +32,8 @@ bin/wmc
|
|||
bin/wrc
|
||||
include/wine/debug.h
|
||||
include/wine/exception.h
|
||||
include/wine/itss.h
|
||||
include/wine/itss.idl
|
||||
include/wine/library.h
|
||||
include/wine/msvcrt/conio.h
|
||||
include/wine/msvcrt/crtdbg.h
|
||||
|
@ -120,6 +122,7 @@ include/wine/windows/dciddi.h
|
|||
include/wine/windows/dciman.h
|
||||
include/wine/windows/dde.h
|
||||
include/wine/windows/ddeml.h
|
||||
include/wine/windows/ddk/winsplp.h
|
||||
include/wine/windows/ddraw.h
|
||||
include/wine/windows/ddrawi.h
|
||||
include/wine/windows/ddstream.h
|
||||
|
@ -171,6 +174,8 @@ include/wine/windows/exdispid.h
|
|||
include/wine/windows/fci.h
|
||||
include/wine/windows/fdi.h
|
||||
include/wine/windows/guiddef.h
|
||||
include/wine/windows/hlink.h
|
||||
include/wine/windows/hlink.idl
|
||||
include/wine/windows/htmlhelp.h
|
||||
include/wine/windows/icm.h
|
||||
include/wine/windows/icmpapi.h
|
||||
|
@ -254,6 +259,7 @@ include/wine/windows/oaidl.idl
|
|||
include/wine/windows/objbase.h
|
||||
include/wine/windows/objidl.h
|
||||
include/wine/windows/objidl.idl
|
||||
include/wine/windows/objsel.h
|
||||
include/wine/windows/ocidl.h
|
||||
include/wine/windows/ocidl.idl
|
||||
include/wine/windows/odbcinst.h
|
||||
|
@ -467,7 +473,6 @@ lib/wine/krnl386.exe.so
|
|||
lib/wine/libactiveds.def
|
||||
lib/wine/libadvapi32.def
|
||||
lib/wine/libadvpack.def
|
||||
lib/wine/libamstream.def
|
||||
lib/wine/libatl.def
|
||||
lib/wine/libavicap32.def
|
||||
lib/wine/libavifil32.def
|
||||
|
@ -475,7 +480,6 @@ lib/wine/libcabinet.def
|
|||
lib/wine/libcapi2032.def
|
||||
lib/wine/libcards.def
|
||||
lib/wine/libcfgmgr32.def
|
||||
lib/wine/libcomcat.def
|
||||
lib/wine/libcomctl32.def
|
||||
lib/wine/libcomdlg32.def
|
||||
lib/wine/libcrtdll.def
|
||||
|
@ -491,35 +495,24 @@ lib/wine/libd3dxof.def
|
|||
lib/wine/libdbghelp.def
|
||||
lib/wine/libdciman32.def
|
||||
lib/wine/libddraw.def
|
||||
lib/wine/libdevenum.def
|
||||
lib/wine/libdinput.def
|
||||
lib/wine/libdinput.def.a
|
||||
lib/wine/libdinput8.def
|
||||
lib/wine/libdmband.def
|
||||
lib/wine/libdmcompos.def
|
||||
lib/wine/libdmime.def
|
||||
lib/wine/libdmloader.def
|
||||
lib/wine/libdmscript.def
|
||||
lib/wine/libdmstyle.def
|
||||
lib/wine/libdmsynth.def
|
||||
lib/wine/libdmusic.def
|
||||
lib/wine/libdmusic32.def
|
||||
lib/wine/libdplay.def
|
||||
lib/wine/libdplayx.def
|
||||
lib/wine/libdpnet.def
|
||||
lib/wine/libdpnhpast.def
|
||||
lib/wine/libdsound.def
|
||||
lib/wine/libdswave.def
|
||||
lib/wine/libdxdiagn.def
|
||||
lib/wine/libdxerr8.a
|
||||
lib/wine/libdxerr9.a
|
||||
lib/wine/libdxguid.a
|
||||
lib/wine/libgdi32.def
|
||||
lib/wine/libglu32.def
|
||||
lib/wine/libglut32.def
|
||||
lib/wine/libiccvid.def
|
||||
lib/wine/libicmp.def
|
||||
lib/wine/libimagehlp.def
|
||||
lib/wine/libimm32.def
|
||||
lib/wine/libiphlpapi.def
|
||||
lib/wine/libitss.def
|
||||
lib/wine/libkernel32.def
|
||||
lib/wine/liblz32.def
|
||||
lib/wine/libmapi32.def
|
||||
|
@ -531,14 +524,11 @@ lib/wine/libmsdmo.def
|
|||
lib/wine/libmshtml.def
|
||||
lib/wine/libmsi.def
|
||||
lib/wine/libmsimg32.def
|
||||
lib/wine/libmsnet32.def
|
||||
lib/wine/libmsrle32.def
|
||||
lib/wine/libmsvcrt.def
|
||||
lib/wine/libmsvcrt20.def
|
||||
lib/wine/libmsvcrt40.def
|
||||
lib/wine/libmsvcrtd.def
|
||||
lib/wine/libmsvfw32.def
|
||||
lib/wine/libmsvidc32.def
|
||||
lib/wine/libmswsock.def
|
||||
lib/wine/libnetapi32.def
|
||||
lib/wine/libnewdev.def
|
||||
|
@ -555,11 +545,9 @@ lib/wine/libolesvr32.def
|
|||
lib/wine/libopengl32.def
|
||||
lib/wine/libpowrprof.def
|
||||
lib/wine/libpsapi.def
|
||||
lib/wine/libqcap.def
|
||||
lib/wine/libquartz.def
|
||||
lib/wine/librasapi32.def
|
||||
lib/wine/libriched20.def
|
||||
lib/wine/libriched32.def
|
||||
lib/wine/librpcrt4.def
|
||||
lib/wine/librsabase.def
|
||||
lib/wine/librsaenh.def
|
||||
|
@ -573,16 +561,19 @@ lib/wine/libshfolder.def
|
|||
lib/wine/libshlwapi.def
|
||||
lib/wine/libsnmpapi.def
|
||||
lib/wine/libsti.def
|
||||
lib/wine/libstrmiids.a
|
||||
lib/wine/libtapi32.def
|
||||
lib/wine/libtwain_32.def
|
||||
lib/wine/libunicows.def
|
||||
lib/wine/liburl.def
|
||||
lib/wine/liburlmon.def
|
||||
lib/wine/libuser32.def
|
||||
lib/wine/libusp10.def
|
||||
lib/wine/libuuid.a
|
||||
lib/wine/libuxtheme.def
|
||||
lib/wine/libvdmdbg.def
|
||||
lib/wine/libversion.def
|
||||
lib/wine/libw32skrnl.def
|
||||
lib/wine/libwinecrt0.a
|
||||
lib/wine/libwined3d.def
|
||||
lib/wine/libwinedos.def
|
||||
lib/wine/libwininet.def
|
||||
|
@ -600,10 +591,9 @@ lib/wine/libwtsapi32.def
|
|||
lib/wine/lz32.dll.so
|
||||
lib/wine/lzexpand.dll.so
|
||||
lib/wine/mapi32.dll.so
|
||||
lib/wine/mcianim.drv.so
|
||||
lib/wine/mciavi.drv.so
|
||||
lib/wine/mcicda.drv.so
|
||||
lib/wine/mciseq.drv.so
|
||||
lib/wine/mciavi32.dll.so
|
||||
lib/wine/mcicda.dll.so
|
||||
lib/wine/mciseq.dll.so
|
||||
lib/wine/mciwave.drv.so
|
||||
lib/wine/midimap.dll.so
|
||||
lib/wine/mlang.dll.so
|
||||
|
@ -634,10 +624,12 @@ lib/wine/msvfw32.dll.so
|
|||
lib/wine/msvidc32.dll.so
|
||||
lib/wine/msvideo.dll.so
|
||||
lib/wine/mswsock.dll.so
|
||||
lib/wine/msxml3.dll.so
|
||||
lib/wine/netapi32.dll.so
|
||||
lib/wine/newdev.dll.so
|
||||
lib/wine/notepad.exe.so
|
||||
lib/wine/ntdll.dll.so
|
||||
lib/wine/objsel.dll.so
|
||||
lib/wine/odbc32.dll.so
|
||||
lib/wine/odbccp32.dll.so
|
||||
lib/wine/ole2.dll.so
|
||||
|
@ -703,6 +695,7 @@ lib/wine/url.dll.so
|
|||
lib/wine/urlmon.dll.so
|
||||
lib/wine/user.exe.so
|
||||
lib/wine/user32.dll.so
|
||||
lib/wine/usp10.dll.so
|
||||
lib/wine/uxtheme.dll.so
|
||||
lib/wine/vdhcp.vxd.so
|
||||
lib/wine/vdmdbg.dll.so
|
||||
|
@ -730,6 +723,7 @@ lib/wine/wineconsole.exe.so
|
|||
lib/wine/wined3d.dll.so
|
||||
lib/wine/winedbg.exe.so
|
||||
lib/wine/winedos.dll.so
|
||||
lib/wine/wineesd.drv.so
|
||||
lib/wine/winefile.exe.so
|
||||
lib/wine/winejack.drv.so
|
||||
lib/wine/winemenubuilder.exe.so
|
||||
|
@ -778,10 +772,12 @@ share/applications/wine.desktop
|
|||
share/fonts/wine/wine_coure.fon
|
||||
share/fonts/wine/wine_couree.fon
|
||||
share/fonts/wine/wine_courer.fon
|
||||
share/fonts/wine/wine_cvgasys.fon
|
||||
share/fonts/wine/wine_marlett.ttf
|
||||
share/fonts/wine/wine_sserife.fon
|
||||
share/fonts/wine/wine_sserifee.fon
|
||||
share/fonts/wine/wine_sserifer.fon
|
||||
share/fonts/wine/wine_svgasys.fon
|
||||
share/fonts/wine/wine_vgasys.fon
|
||||
share/fonts/wine/wine_vgasyse.fon
|
||||
share/fonts/wine/wine_vgasysr.fon
|
||||
|
@ -790,6 +786,7 @@ share/wine/wine.inf
|
|||
@dirrm share/wine
|
||||
@dirrm share/fonts/wine
|
||||
@dirrm lib/wine
|
||||
@dirrm include/wine/windows/ddk
|
||||
@dirrm include/wine/windows
|
||||
@dirrm include/wine/msvcrt/sys
|
||||
@dirrm include/wine/msvcrt
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$NetBSD: distinfo,v 1.35 2005/08/12 13:57:44 salo Exp $
|
||||
$NetBSD: distinfo,v 1.36 2005/09/07 14:28:38 adam Exp $
|
||||
|
||||
SHA1 (Wine-20050725.tar.gz) = dfda93cc903b9ad9eeab076e9fbdbbb09ca59c49
|
||||
RMD160 (Wine-20050725.tar.gz) = a86fda53cf9c3a36ab3bf42ecb66740bdcbe3174
|
||||
Size (Wine-20050725.tar.gz) = 12205994 bytes
|
||||
SHA1 (patch-aa) = 51116310baa1e00d6eeb444e0dd3a9639c02505a
|
||||
SHA1 (Wine-20050830.tar.gz) = 6e2c5b51efc4563c7a5f032160414bf110fb1e08
|
||||
RMD160 (Wine-20050830.tar.gz) = 95b68d68706310cf52406f6528d9dabb0f407da4
|
||||
Size (Wine-20050830.tar.gz) = 12433457 bytes
|
||||
SHA1 (patch-aa) = fdbe7d0faffa7f0837482f18cb5f96d520d7a538
|
||||
SHA1 (patch-ab) = 66c1f1ec98674d15c7a72e8ac16105c28aa25e91
|
||||
SHA1 (patch-ac) = c9098a31acfa7b5f22024f1437b813f2dac53e95
|
||||
SHA1 (patch-ac) = 61b05ff6fddc71af03168971a9e01c575efb8266
|
||||
SHA1 (patch-ad) = 92abc177dc37ed983ec6079cd08ad7a1472e178a
|
||||
SHA1 (patch-ae) = dbd40183fb8e1f1d7af9ab4e51910a2227524e3c
|
||||
SHA1 (patch-af) = a8eb0a12b990ce5431498bff51bd2ad6a0b9d7b8
|
||||
SHA1 (patch-ag) = 656f9667da542489595d1db65c84579b3dfce279
|
||||
SHA1 (patch-ah) = 9be209efc28693b98354624af96e81b64d2fbc6c
|
||||
SHA1 (patch-ai) = 3d154e96464192cc3c8c0f428d0fe518ec7e1d8c
|
||||
SHA1 (patch-ah) = 077f4a49280cb120fbd9a6f3a84a278377e90e05
|
||||
SHA1 (patch-ai) = 6980c8ba0a17d003e9b5d9e5d512a141a11508cb
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.16 2005/07/26 13:24:36 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.17 2005/09/07 14:28:38 adam Exp $
|
||||
|
||||
--- Make.rules.in.orig 2005-07-20 17:48:26.000000000 +0000
|
||||
--- Make.rules.in.orig 2005-08-11 17:12:19.000000000 +0000
|
||||
+++ Make.rules.in
|
||||
@@ -107,7 +107,7 @@ conf_manext = 5
|
||||
@@ -109,7 +109,7 @@ conf_manext = 5
|
||||
CLEAN_FILES = *.o *.a *.so *.ln *.$(LIBEXT) \\\#*\\\# *~ *% .\\\#* *.bak *.orig *.rej \
|
||||
*.flc *.spec.c *.dbg.c *.tab.c *.tab.h @LEX_OUTPUT_ROOT@.c core
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.19 2005/07/26 13:24:36 adam Exp $
|
||||
$NetBSD: patch-ac,v 1.20 2005/09/07 14:28:38 adam Exp $
|
||||
|
||||
--- configure.orig 2005-07-25 12:22:05.000000000 +0000
|
||||
--- configure.orig 2005-08-30 10:58:42.000000000 +0000
|
||||
+++ configure
|
||||
@@ -17692,7 +17692,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_l
|
||||
@@ -15831,7 +15831,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_l
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-ac,v 1.19 2005/07/26 13:24:36 adam Exp $
|
|||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
sed 's/^/| /' conftest.$ac_ext >&5
|
||||
@@ -19594,7 +19594,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_c
|
||||
@@ -17733,7 +17733,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_c
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
|
|
|
@ -1,25 +1,25 @@
|
|||
$NetBSD: patch-ah,v 1.5 2005/07/26 13:24:36 adam Exp $
|
||||
$NetBSD: patch-ah,v 1.6 2005/09/07 14:28:38 adam Exp $
|
||||
|
||||
--- tools/Makefile.in.orig 2005-07-26 12:12:26.000000000 +0000
|
||||
--- tools/Makefile.in.orig 2005-08-08 15:02:29.000000000 +0000
|
||||
+++ tools/Makefile.in
|
||||
@@ -49,16 +49,16 @@ make_ctests: make_ctests.o
|
||||
$(CC) $(CFLAGS) -o make_ctests make_ctests.o
|
||||
@@ -50,16 +50,16 @@ make_ctests$(EXEEXT): make_ctests.o
|
||||
$(CC) $(CFLAGS) -o $@ make_ctests.o
|
||||
|
||||
fnt2bdf: fnt2bdf.o
|
||||
- $(CC) $(CFLAGS) -o fnt2bdf fnt2bdf.o $(LIBPORT)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o fnt2bdf fnt2bdf.o $(LIBPORT)
|
||||
fnt2bdf$(EXEEXT): fnt2bdf.o
|
||||
- $(CC) $(CFLAGS) -o $@ fnt2bdf.o $(LIBPORT)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ fnt2bdf.o $(LIBPORT)
|
||||
|
||||
fnt2fon: fnt2fon.o
|
||||
- $(CC) $(CFLAGS) -o fnt2fon fnt2fon.o $(LIBPORT)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o fnt2fon fnt2fon.o $(LIBPORT)
|
||||
fnt2fon$(EXEEXT): fnt2fon.o
|
||||
- $(CC) $(CFLAGS) -o $@ fnt2fon.o $(LIBPORT)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ fnt2fon.o $(LIBPORT)
|
||||
|
||||
sfnt2fnt: sfnt2fnt.o
|
||||
- $(CC) $(CFLAGS) -o sfnt2fnt sfnt2fnt.o $(LIBUNICODE) $(LIBPORT) $(FREETYPELIBS)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o sfnt2fnt sfnt2fnt.o $(LIBUNICODE) $(LIBPORT) $(FREETYPELIBS)
|
||||
sfnt2fnt$(EXEEXT): sfnt2fnt.o
|
||||
- $(CC) $(CFLAGS) -o $@ sfnt2fnt.o $(LIBUNICODE) $(LIBPORT) $(FREETYPELIBS)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ sfnt2fnt.o $(LIBUNICODE) $(LIBPORT) $(FREETYPELIBS)
|
||||
|
||||
bin2res: bin2res.o
|
||||
- $(CC) $(CFLAGS) -o bin2res bin2res.o $(LIBPORT)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o bin2res bin2res.o $(LIBPORT)
|
||||
bin2res$(EXEEXT): bin2res.o
|
||||
- $(CC) $(CFLAGS) -o $@ bin2res.o $(LIBPORT)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ bin2res.o $(LIBPORT)
|
||||
|
||||
wineprefixcreate: wineprefixcreate.in
|
||||
sed -e 's,@dlldir\@,$(dlldir),g' -e 's,@datadir\@,$(datadir),g' $(SRCDIR)/wineprefixcreate.in >$@ || ($(RM) $@ && false)
|
||||
|
|
|
@ -1,25 +1,12 @@
|
|||
$NetBSD: patch-ai,v 1.5 2005/08/12 13:57:44 salo Exp $
|
||||
$NetBSD: patch-ai,v 1.6 2005/09/07 14:28:39 adam Exp $
|
||||
|
||||
Fix for SA16352, from Wine CVS.
|
||||
|
||||
--- programs/winelauncher.in.orig 2004-06-22 01:56:15.000000000 +0200
|
||||
+++ programs/winelauncher.in 2005-08-12 15:11:18.000000000 +0200
|
||||
@@ -59,8 +59,8 @@
|
||||
if [ $? -ne 0 ] ; then
|
||||
# xmessage not found; make sure the user notices this error
|
||||
# (GUI users wouldn't even notice if we printed the text on console !)
|
||||
- MSGFILE=/tmp/WINE_CANNOT_FIND_XMESSAGE
|
||||
- cat > $MSGFILE << EOF
|
||||
+ MSGFILE=`mktemp "/tmp/wine.xmessage.XXXXXX"`
|
||||
+ cat > $MSGFILE <<EOF
|
||||
Warning:
|
||||
The Wine launcher is unable to find the xmessage program,
|
||||
which it needs to properly notify you of Wine execution status
|
||||
@@ -87,6 +87,7 @@
|
||||
--- dlls/winmm/wineesd/audio.c.orig 2005-09-02 11:44:39.000000000 +0000
|
||||
+++ dlls/winmm/wineesd/audio.c
|
||||
@@ -34,6 +34,7 @@
|
||||
|
||||
# ok, we really give up now, this system is hosed ;-)
|
||||
cat $MSGFILE
|
||||
+ rm $MSGFILE
|
||||
else
|
||||
XMESSAGE="xmessage $COLOR"
|
||||
fi
|
||||
#include "config.h"
|
||||
|
||||
+#include <errno.h>
|
||||
#include <math.h>
|
||||
#include <stdlib.h>
|
||||
#include <stdarg.h>
|
||||
|
|
Loading…
Reference in a new issue