Updating textproc/p5-XML-Twig from 3.32nb1 to 3.34
pkgsrc changes: - Add license definition - Change patches against PERL_MM_USE_DEFAULT environment variable for EU::MM Upstream changes: CHANGES version: 3.34 date: 2010-01-18 # minor maintenance release, test suite fixes fixed: tests failed when XML::XPath was used as the XPath engine
This commit is contained in:
parent
adf9e81fa6
commit
8080477716
4 changed files with 9 additions and 72 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.16 2008/10/19 19:19:00 he Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2010/02/22 16:24:04 sno Exp $
|
||||
#
|
||||
|
||||
DISTNAME= XML-Twig-3.32
|
||||
DISTNAME= XML-Twig-3.34
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
#PKGREVISION= 1
|
||||
SVR4_PKGNAME= p5xtw
|
||||
CATEGORIES= textproc perl5
|
||||
MASTER_SITES= http://www.xmltwig.com/xmltwig/ \
|
||||
|
@ -12,6 +12,7 @@ MASTER_SITES= http://www.xmltwig.com/xmltwig/ \
|
|||
MAINTAINER= rhaen@NetBSD.org
|
||||
HOMEPAGE= http://www.xmltwig.com/
|
||||
COMMENT= Efficient XML document interface
|
||||
LICENSE= ${PERL5_LICENSE}
|
||||
|
||||
DEPENDS+= p5-XML-Parser>=2.23:../../textproc/p5-XML-Parser
|
||||
|
||||
|
@ -37,6 +38,7 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
|
|||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
PERL5_PACKLIST= auto/XML/Twig/.packlist
|
||||
MAKE_ENV+= PERL_MM_USE_DEFAULT=1
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.8 2008/07/16 12:06:07 rhaen Exp $
|
||||
$NetBSD: distinfo,v 1.9 2010/02/22 16:24:04 sno Exp $
|
||||
|
||||
SHA1 (XML-Twig-3.32.tar.gz) = f8fb38e0e088f2c56c7eb4d804d943872e6ddf98
|
||||
RMD160 (XML-Twig-3.32.tar.gz) = 922374f2e8907a13629569e8fdd9c2f86c32f412
|
||||
Size (XML-Twig-3.32.tar.gz) = 345665 bytes
|
||||
SHA1 (patch-aa) = 350c2a1529de24171bdd7772d97e87d5f156a061
|
||||
SHA1 (patch-ab) = 1f7703b0cb1218b01f5187d86c98c6266f66d8ef
|
||||
SHA1 (XML-Twig-3.34.tar.gz) = 53df9e973590c9e02a8c228a2531ac0a17fc889d
|
||||
RMD160 (XML-Twig-3.34.tar.gz) = f65324b68b8a701700694a8e7f717787578ca713
|
||||
Size (XML-Twig-3.34.tar.gz) = 354184 bytes
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.4 2008/07/16 12:06:07 rhaen Exp $
|
||||
|
||||
--- Makefile.PL.orig 2008-07-16 12:11:33.000000000 +0200
|
||||
+++ Makefile.PL 2008-07-16 12:13:14.000000000 +0200
|
||||
@@ -12,22 +12,7 @@
|
||||
);
|
||||
|
||||
my @programs;
|
||||
-
|
||||
-if( $ARGV[0] eq "-n")
|
||||
- { @programs=(); }
|
||||
-elsif( $ARGV[0] eq "-y")
|
||||
- { @programs= map { $_->[0] } @prompts; }
|
||||
-elsif( $ARGV[0] eq "-d")
|
||||
- { @programs= map { $_->[0] if( $_->[1] eq 'y') } @prompts; }
|
||||
-else
|
||||
- { print "run 'perl Makefile.PL -y' to install all tools,\n",
|
||||
- " 'perl Makefile.PL -n' to skip installation\n";
|
||||
- foreach my $prompt (@prompts)
|
||||
- { my ($program, $default, $description) = @$prompt;
|
||||
- if( prompt("Do you want to install '$program' ($description)?", $default) =~ /^y/)
|
||||
- { push(@programs, $program); }
|
||||
- }
|
||||
- }
|
||||
+@programs= map { $_->[0] } @prompts;
|
||||
|
||||
WriteMakefile(
|
||||
NAME => 'XML::Twig',
|
|
@ -1,35 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2005/02/19 19:32:21 wiz Exp $
|
||||
|
||||
--- check_optional_modules.orig 2005-01-27 16:56:10.000000000 +0100
|
||||
+++ check_optional_modules
|
||||
@@ -17,17 +17,17 @@ if( $] >= 5.0060)
|
||||
{ warn "weaken is available\n"; }
|
||||
}
|
||||
|
||||
-unless( eval 'require Text::Iconv')
|
||||
- { my $version= `iconv -V` || '';
|
||||
- if($version)
|
||||
- { warn "The iconv library was found on your system ",
|
||||
- "but the Text::Iconv module is not installed. ",
|
||||
- "Installing Text::Iconv would make character ",
|
||||
- "encoding translations fast and efficient.\n";
|
||||
- }
|
||||
- else
|
||||
- { warn "Did not find iconv\n"; }
|
||||
- }
|
||||
-else
|
||||
- { warn "Text::Iconv is installed\n"; }
|
||||
+#unless( eval 'require Text::Iconv')
|
||||
+# { my $version= `iconv -V` || '';
|
||||
+# if($version)
|
||||
+# { warn "The iconv library was found on your system ",
|
||||
+# "but the Text::Iconv module is not installed. ",
|
||||
+# "Installing Text::Iconv would make character ",
|
||||
+# "encoding translations fast and efficient.\n";
|
||||
+# }
|
||||
+# else
|
||||
+# { warn "Did not find iconv\n"; }
|
||||
+# }
|
||||
+#else
|
||||
+# { warn "Text::Iconv is installed\n"; }
|
||||
|
Loading…
Reference in a new issue