Update net/dnstop to dnstop-20140915, based on patches from Benedek Gergely

via pkgsrc-users@.

ok by wiz@.

Changes:
2014/09/12 Duane Wessels

    Added 'new-gtlds' filter, which includes only queries for names
    ending with one of the new (2013/2014) generic TLDs.  This may
    be useful to find hosts/servers using internal names which may
    collide with new gTLDs once they become active.  If you use
    short (not fully qualified) names internally you may be uknownlying
    relying on root (or other) name servers to return NXDOMAIN for
    them.  If so, "you're gonna have a bad time."

    Along with this new feature, TLD lists are now hashed in the
    code for faster lookups.

2012/11/30 Duane Wessels

    Added more entries to the table of known query type names (HINFO,
    AFSDB, PX, SSHFP, NSEC3, NSEC3PARAM, TLSA, DLV).

2012/10/15 Duane Wessels

    The 'refused' filter only works on responses, which are not
    processed by default.  Now, if the 'refused' filter is specified,
    dnstop will automatically process responses and ignore queries.

2012/06/11 Duane Wessels

    Added "qtype-any" filter for displaying ANY queries which are
    now fashionable in DNS based attacks.

2011/05/02 Duane Wessels

    Anand Buddhev pointed out that LDFLAGS= is missing from Makefile.in.
    Also updated known_tlds.h.

2011/01/27 Duane Wessels

    Fixed some portability bugs (OpenBSD, gmake 3.82) and other
    minor bugs.

    Added a feature (-n option) to restrict counting to a given
    query name.

2011/01/05 Duane Wessels

    Found a fixed a few problems after spending some quality time
    looking at the code.

    1) Hash table performance was terrible and has been improved.
       The hash table size is now configurable via command line
       option.

    2) Some things were double-counted when both -Q and -R were
       given.

    3) Added cumulative percentage totals to the tables

    4) Added -X option to disable the source+queryname tables, which
       could consume a lot of memory.

    5) Imported "inX_addr" mini-library for storing IPv4/IPv6
       addresses.

2010/12/27 Duane Wessels

    Fixed a bug where if stdout was a TTY but stdin was not a TTY,
    then dnstop would enter a loop on keyboard input and consume
    100% CPU.  Now it checks that stdin is a TTY as well.
This commit is contained in:
leot 2015-08-14 21:21:24 +00:00
parent fcacc9a6d5
commit 808eb21bd0
3 changed files with 26 additions and 7 deletions

View file

@ -1,14 +1,14 @@
# $NetBSD: Makefile,v 1.22 2013/02/06 19:30:56 jperkin Exp $
# $NetBSD: Makefile,v 1.23 2015/08/14 21:21:24 leot Exp $
#
DISTNAME= dnstop-20090128
PKGREVISION= 1
DISTNAME= dnstop-20140915
CATEGORIES= net
MASTER_SITES= http://dns.measurement-factory.com/tools/dnstop/src/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://dns.measurement-factory.com/tools/dnstop/
COMMENT= Diagnose tcpdump trace for DNS queries/replies
LICENSE= modified-bsd
GNU_CONFIGURE= yes

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.13 2009/07/25 10:26:17 obache Exp $
$NetBSD: distinfo,v 1.14 2015/08/14 21:21:24 leot Exp $
SHA1 (dnstop-20090128.tar.gz) = 17eac98a9065e8b25ea13aa65b647c2b090850f1
RMD160 (dnstop-20090128.tar.gz) = aa995e7163dcc8575e59065bcc4d6d92812aace5
Size (dnstop-20090128.tar.gz) = 68132 bytes
SHA1 (dnstop-20140915.tar.gz) = af1567d6b53e8be697b884508a2a3a0edbea5e01
RMD160 (dnstop-20140915.tar.gz) = cf21ac48c0d16c4656f0ffc4f28ff9187cf200bc
Size (dnstop-20140915.tar.gz) = 77917 bytes
SHA1 (patch-dnstop.c) = 25fd8afa7e9d7ea8d4ee07b8515cbad8efc5283b

View file

@ -0,0 +1,18 @@
$NetBSD: patch-dnstop.c,v 1.1 2015/08/14 21:21:24 leot Exp $
Avoid incompatible types assignments.
--- dnstop.c.orig 2014-09-15 17:54:51.000000000 +0000
+++ dnstop.c
@@ -188,11 +188,7 @@ hashtbl *DomSrcs[10];
hashtbl *KnownTLDs = NULL;
hashtbl *NewGTLDs = NULL;
-#ifdef HAVE_STRUCT_BPF_TIMEVAL
-struct bpf_timeval last_ts;
-#else
struct timeval last_ts;
-#endif
time_t report_interval = 1;
/*