Remove old version of gtl (newer version living in devel/gtl) that does

not build with gcc3.
This commit is contained in:
wiz 2005-04-22 19:00:33 +00:00
parent 2e5af34b49
commit 80da43e636
8 changed files with 1 additions and 215 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.633 2005/04/19 17:40:23 drochner Exp $
# $NetBSD: Makefile,v 1.634 2005/04/22 19:00:33 wiz Exp $
#
COMMENT= Development utilities
@ -175,7 +175,6 @@ SUBDIR+= gscope
SUBDIR+= gtexinfo
SUBDIR+= gtkdiff
SUBDIR+= gtl
SUBDIR+= gtl0
SUBDIR+= gtoolkit-examples
SUBDIR+= guile-fcgi
SUBDIR+= guile-gtk

View file

@ -1,7 +0,0 @@
GTL is a graph library based on STL. For the design of GTL's API the
API of LEDA has served as a basis. GTL contains the classes needed to
work with graphs, nodes and edges and some basic algorithms (DFS, BFS,
topsort ...) as building blocks for more complex graph algorithms.
This package contains an older version of the library, for a newer
version use the gtl package.

View file

@ -1,41 +0,0 @@
# $NetBSD: Makefile,v 1.2 2005/04/11 21:45:25 tv Exp $
DISTNAME= GTL-0.3.3
PKGNAME= gtl0-0.3.3
PKGREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://infosun.fmi.uni-passau.de/GTL/archive/
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://www.fmi.uni-passau.de/Graphlet/GTL/
COMMENT= C++ graph data structure library based on the STL (older version)
USE_LIBTOOL= # defined
USE_LANGUAGES= c c++
LICENSE= no-commercial-use
# newer version of the same
CONFLICTS= gtl-[0-9]*
.include "../../mk/bsd.prefs.mk"
GNU_CONFIGURE= # defined
.if defined(CXXFLAGS)
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
.endif
GTL_VERS= 0:3
MAKE_ENV+= GTL_VERS="${GTL_VERS}"
HTMLDOCDIR= ${PREFIX}/share/doc/html/GTL
post-install:
${INSTALL_DATA_DIR} ${HTMLDOCDIR}
${INSTALL_DATA_DIR} ${HTMLDOCDIR}/icons
cd ${WRKSRC}/doc/html; \
${INSTALL_DATA} *.html ${HTMLDOCDIR}
cd ${WRKSRC}/doc/html/icons; \
${INSTALL_DATA} *.gif *.jpeg ${HTMLDOCDIR}/icons
.include "../../mk/bsd.pkg.mk"

View file

@ -1,107 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/11/02 20:32:37 wiz Exp $
include/GTL/GTL.h
include/GTL/algorithm.h
include/GTL/bfs.h
include/GTL/biconnectivity.h
include/GTL/components.h
include/GTL/debug.h
include/GTL/dfs.h
include/GTL/edge.h
include/GTL/edge_data.h
include/GTL/edge_map.h
include/GTL/embedding.h
include/GTL/fm_partition.h
include/GTL/gml_parser.h
include/GTL/gml_scanner.h
include/GTL/graph.h
include/GTL/maxflow_ff.h
include/GTL/maxflow_pp.h
include/GTL/ne_map.h
include/GTL/node.h
include/GTL/node_data.h
include/GTL/node_map.h
include/GTL/planarity.h
include/GTL/pq_node.h
include/GTL/pq_tree.h
include/GTL/ratio_cut_partition.h
include/GTL/st_number.h
include/GTL/symlist.h
include/GTL/topsort.h
include/GTL/version.h
lib/libGTL.la
share/doc/html/GTL/GML_error.html
share/doc/html/GTL/GTL-GTL-h.html
share/doc/html/GTL/GTL-algorithm-h.html
share/doc/html/GTL/GTL-bfs-h.html
share/doc/html/GTL/GTL-biconnectivity-h.html
share/doc/html/GTL/GTL-components-h.html
share/doc/html/GTL/GTL-debug-h.html
share/doc/html/GTL/GTL-dfs-h.html
share/doc/html/GTL/GTL-edge-h.html
share/doc/html/GTL/GTL-edge_data-h.html
share/doc/html/GTL/GTL-edge_map-h.html
share/doc/html/GTL/GTL-embedding-h.html
share/doc/html/GTL/GTL-fm_partition-h.html
share/doc/html/GTL/GTL-gml_parser-h.html
share/doc/html/GTL/GTL-gml_scanner-h.html
share/doc/html/GTL/GTL-graph-h.html
share/doc/html/GTL/GTL-maxflow_ff-h.html
share/doc/html/GTL/GTL-maxflow_pp-h.html
share/doc/html/GTL/GTL-ne_map-h.html
share/doc/html/GTL/GTL-node-h.html
share/doc/html/GTL/GTL-node_data-h.html
share/doc/html/GTL/GTL-node_map-h.html
share/doc/html/GTL/GTL-planarity-h.html
share/doc/html/GTL/GTL-pq_node-h.html
share/doc/html/GTL/GTL-pq_tree-h.html
share/doc/html/GTL/GTL-ratio_cut_partition-h.html
share/doc/html/GTL/GTL-st_number-h.html
share/doc/html/GTL/GTL-symlist-h.html
share/doc/html/GTL/GTL-topsort-h.html
share/doc/html/GTL/GTL-version-h.html
share/doc/html/GTL/algorithm.html
share/doc/html/GTL/bfs.html
share/doc/html/GTL/biconnectivity.html
share/doc/html/GTL/classes.html
share/doc/html/GTL/components.html
share/doc/html/GTL/dfs.html
share/doc/html/GTL/doc000.html
share/doc/html/GTL/doc001.html
share/doc/html/GTL/doc002.html
share/doc/html/GTL/doc003.html
share/doc/html/GTL/doc004.html
share/doc/html/GTL/doc005.html
share/doc/html/GTL/doc006.html
share/doc/html/GTL/doc007.html
share/doc/html/GTL/edge.html
share/doc/html/GTL/edge_map.html
share/doc/html/GTL/fm_partition.html
share/doc/html/GTL/graph.html
share/doc/html/GTL/header-list.html
share/doc/html/GTL/hier.html
share/doc/html/GTL/icons/GTL-small.gif
share/doc/html/GTL/icons/GTL.jpeg
share/doc/html/GTL/icons/contents.gif
share/doc/html/GTL/icons/next.gif
share/doc/html/GTL/icons/next_gr.gif
share/doc/html/GTL/icons/previous.gif
share/doc/html/GTL/icons/previous_gr.gif
share/doc/html/GTL/icons/up.gif
share/doc/html/GTL/icons/up_gr.gif
share/doc/html/GTL/index.html
share/doc/html/GTL/maxflow_ff.html
share/doc/html/GTL/maxflow_pp.html
share/doc/html/GTL/ne_map.html
share/doc/html/GTL/node.html
share/doc/html/GTL/node_map.html
share/doc/html/GTL/planar_embedding.html
share/doc/html/GTL/planarity.html
share/doc/html/GTL/pq_tree.html
share/doc/html/GTL/ratio_cut_partition.html
share/doc/html/GTL/refer.html
share/doc/html/GTL/st_number.html
share/doc/html/GTL/symlist.html
share/doc/html/GTL/topsort.html
@dirrm share/doc/html/GTL/icons
@dirrm share/doc/html/GTL
@dirrm include/GTL

View file

@ -1,18 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2004/11/02 20:32:38 wiz Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
GTL0_BUILDLINK3_MK:= ${GTL0_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= gtl0
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Ngtl0}
BUILDLINK_PACKAGES+= gtl0
.if !empty(GTL0_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.gtl0+= gtl0>=0.3.3nb1
BUILDLINK_PKGSRCDIR.gtl0?= ../../devel/gtl0
.endif # GTL0_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.2 2005/02/23 22:24:16 agc Exp $
SHA1 (GTL-0.3.3.tar.gz) = 5cf7baab5ec299045fc9f8df455cb32be39cb736
RMD160 (GTL-0.3.3.tar.gz) = dbfa6b83cb975331db37a75caedd096a080c40df
Size (GTL-0.3.3.tar.gz) = 469283 bytes
SHA1 (patch-aa) = 131765fe15c7486260db302b69c8a2b5923ff6d4
SHA1 (patch-ab) = db8612a600166c9962b3d6c219de54b9f9c16636

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/11/02 20:32:38 wiz Exp $
--- src/Makefile.in.orig Tue Mar 7 04:14:07 2000
+++ src/Makefile.in Tue May 9 11:46:57 2000
@@ -92,7 +92,7 @@
libGTL_la_SOURCES = gml_scanner.cpp gml_parser.cpp edge.cpp graph.cpp node.cpp dfs.cpp biconnectivity.cpp bfs.cpp topsort.cpp st_number.cpp embedding.cpp pq_node.cpp pq_tree.cpp planarity.cpp maxflow_ff.cpp maxflow_pp.cpp debug.cpp components.cpp fm_partition.cpp ratio_cut_partition.cpp
-libGTL_la_LDFLAGS = -version-info $(MINOR_VERSION):$(MINI_VERSION):0
+libGTL_la_LDFLAGS = -version-info $(GTL_VERS)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_CLEAN_FILES =
LTLIBRARIES = $(lib_LTLIBRARIES)

View file

@ -1,20 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/11/02 20:32:38 wiz Exp $
--- include/GTL/GTL.h.orig Thu Feb 3 07:50:16 2000
+++ include/GTL/GTL.h Mon Jul 31 00:30:39 2000
@@ -133,6 +133,7 @@
#include <map>
#include <memory>
+#ifndef __STL_USE_STD_ALLOCATORS
/**
* @internal
*/
@@ -141,6 +142,7 @@
{
};
+#endif
#endif
//--------------------------------------------------------------------------