Binary operations on enums imply int casts, so cast back to the original

type.
This commit is contained in:
joerg 2013-10-14 14:34:25 +00:00
parent 40254e7ea4
commit 80da59f1bf
2 changed files with 15 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.5 2012/11/23 20:37:13 markd Exp $
$NetBSD: distinfo,v 1.6 2013/10/14 14:34:25 joerg Exp $
SHA1 (kdevplatform-1.4.1.tar.bz2) = 48f2b40256e96aa015fa40978d5a9a93056fba75
RMD160 (kdevplatform-1.4.1.tar.bz2) = 2726503031278ee0da8357cfa3796edb4625c398
Size (kdevplatform-1.4.1.tar.bz2) = 2029442 bytes
SHA1 (patch-sublime_aggregatemodel.cpp) = 29954a7e4a58dc567377fc03ffca010549c4dbfc

View file

@ -0,0 +1,13 @@
$NetBSD: patch-sublime_aggregatemodel.cpp,v 1.1 2013/10/14 14:34:25 joerg Exp $
--- sublime/aggregatemodel.cpp.orig 2013-10-14 11:07:07.000000000 +0000
+++ sublime/aggregatemodel.cpp
@@ -81,7 +81,7 @@ Qt::ItemFlags AggregateModel::flags(cons
{
if (!index.isValid())
return 0;
- return Qt::ItemIsEnabled & Qt::ItemIsSelectable;
+ return Qt::ItemFlags(Qt::ItemIsEnabled & Qt::ItemIsSelectable);
}
QVariant AggregateModel::headerData(int section, Qt::Orientation orientation, int role) const