Update to SBCL 1.3.12

New in version 1.3.12

 * enhancement: on x86-64, compiled functions loaded from fasl
   files can not be moved, but can be freed, by GC.
   Additionally, COMPILE will produce immobile code
   if SB-C::*COMPILE-TO-MEMORY-SPACE* is set to :IMMOBILE.
   (Caution: the flag is experimental and subject to change.)
   The benefits are better physical separation of code from
   data, and potentially easier examination of live images by
   external tools.
 * enhancement: the docstring for SAVE-LISP-AND-DIE has been
   amended to say that the :ROOT-STRUCTURES parameter is not
   meaningless on gencgc, depending on the platform.
 * bug fix: calling a named function (e.g. a DEFUN) concurrently
   with redefining that same function could lead to execution of
   random bytes.
 * bug fix: yes-or-no-p accepts formatter functions (#1639490)
 * bug fix: better handling of exceptions on macOS.


New in version 1.3.11

 * minor incompatible change: SB-EXT:*INTEXP-MAXIMUM-EXPONENT*
   is removed.
 * enhancement: TRACE ... :REPORT {TRACE,NIL} now work as
   advertised in the documentation string (based on patch by
   Patrick Stein)
 * enhancement: support unboxed signed-word structure slots on
   x86, x86-64 and ARM64. (#377616)
 * optimization: faster logical bit-array operations on
   multidimensional arrays.
 * optimization: better GC performance in the presence of many
   threads. (patch by Ilya Perminov, #1339924)
 * optimization: multiple-value-call is optimized with multiple
   argument forms, not just one. (#753803)
 * bug fix: MAKE-ALIEN-STRING returns the number of allocated
   bytes as a second value as advertised (reported by Johann
   'Myrkraverk' Oskarsson)
 * bug fix: when TO-READTABLE is supplied to COPY-READTABLE, it
   will contain only the macros in FROM-READTABLE and no others.
   (#1631506)
 * enhancement: gencgc has been modified for x86-64 on Linux and
   macOS to a support mark-and-sweep as well as the traditional
   copying strategy. It is conceivable that some applications
   might be adversely affected. Please see ':immobile-space' in
   'base-target-features.lisp-expr' for further details, and
   possible reasons to disable this feature.
 * enhancement: x86-64 supports shrinking the fixed overhead in
   a structure from 2 words to 1 word, reducing memory
   consumption in applications which create many small
   structures.
This commit is contained in:
asau 2016-12-05 20:03:29 +00:00
parent 0702d1616d
commit 80fb331f44
3 changed files with 13 additions and 13 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.69 2016/10/21 07:10:54 asau Exp $
# $NetBSD: Makefile,v 1.70 2016/12/05 20:03:29 asau Exp $
DISTNAME= ${PKGNAME_NOREV}-source
PKGNAME= sbcl-1.3.10
PKGNAME= sbcl-1.3.12
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=sbcl/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.50 2016/10/21 07:10:54 asau Exp $
$NetBSD: distinfo,v 1.51 2016/12/05 20:03:29 asau Exp $
SHA1 (sbcl-1.3.10-source.tar.bz2) = cc211935359f66761c31dc8f4daddec0b696db58
RMD160 (sbcl-1.3.10-source.tar.bz2) = bf453e2e4241436f811dcd567828640f13092b31
SHA512 (sbcl-1.3.10-source.tar.bz2) = 2644a7455352752c2a0028936a9acaf09558f9de0235c334c96f7163fb90bec5843d2591fc6f6a385388da2b0862c2532e67d456b413d379930508aaf09adb4c
Size (sbcl-1.3.10-source.tar.bz2) = 5763563 bytes
SHA1 (sbcl-1.3.12-source.tar.bz2) = 59b22de5815528fbe96d3b965d18c7dd594139ed
RMD160 (sbcl-1.3.12-source.tar.bz2) = 2aa69851a57a71c32b2638fc4241eed38e10829f
SHA512 (sbcl-1.3.12-source.tar.bz2) = 2a2969b826dcf9d568204a01546c47af777d5866baa8da809c49ace1655b54cd4c8db1872e322a1d08a4983b0962cc0e2e346816488212709b28867c53233275
Size (sbcl-1.3.12-source.tar.bz2) = 5795516 bytes
SHA1 (patch-ab) = b087921f7317523fd78396518dfd2cb1c8e6d5f9
SHA1 (patch-src_runtime_backtrace.c) = ba3d7d152b279652d7074ebc9ba615c9d899f35c
SHA1 (patch-src_runtime_breakpoint.c) = 019d98692411b5701ce14c023ed3afab71033323
@ -11,7 +11,7 @@ SHA1 (patch-src_runtime_bsd-os.c) = 1c2bb3ce517aea03bbc4f09708e8300085253286
SHA1 (patch-src_runtime_bsd-os.h) = df48abd32b3b89b9d8a0ba4068c6723bea6617d6
SHA1 (patch-src_runtime_coreparse.c) = 46f8b5ebea5ba3db7baaed124aaf15f2686f7202
SHA1 (patch-src_runtime_dynbind.c) = 44b96758392c8d71834e665dfd62bc7464a033c9
SHA1 (patch-src_runtime_gc-common.c) = bc91e093e00ee9b2da902b6a3bc07f3d56302287
SHA1 (patch-src_runtime_gc-common.c) = 7b513de0058c33bd5673754a225bddf9196fd8f3
SHA1 (patch-src_runtime_gencgc.c) = 6862366d1998205f6bcf9cfded9acda1d03a2f52
SHA1 (patch-src_runtime_globals.c) = ad8aedc43460892edb96e55276f1343abda2b7f5
SHA1 (patch-src_runtime_interr.c) = a12a0a6826d7dd506d6012f10f69862f2a551174

View file

@ -1,10 +1,10 @@
$NetBSD: patch-src_runtime_gc-common.c,v 1.1 2016/10/12 11:35:48 asau Exp $
$NetBSD: patch-src_runtime_gc-common.c,v 1.2 2016/12/05 20:03:29 asau Exp $
--- src/runtime/gc-common.c.orig 2016-09-30 16:41:12.000000000 +0000
--- src/runtime/gc-common.c.orig 2016-11-29 21:07:36.000000000 +0000
+++ src/runtime/gc-common.c
@@ -25,6 +25,10 @@
* <ftp://ftp.cs.utexas.edu/pub/garbage/bigsurv.ps>.
*/
@@ -27,6 +27,10 @@
#define _GNU_SOURCE /* for ffsl(3) from string.h */
+#if defined(__NetBSD__)
+#define _KERNTYPES