update to Enlightenment-0.16.7.1

Based upon PR 26768 by Peter Bex (update to 0.16.7) with fixes/clean-up
by me.

--- 0.16.7.1 1 ---
Remove empty epp/config.h causing trouble on some platforms.
Add basic _NET_WM_WINDOW_OPACITY handling.

--- 0.16.7.1 0.05 ---
Fix button grabs not being released.
- Thanks again to Onur Kucuk <onur@delipenguen.net> for finding a way to
  reproduce this.
Fix normal border when fullscreen at startup.

--- 0.16.7.1 0.04 ---
Fix window placement at (re)start (don't follow transients to leader).
- Many thanks to Onur Kucuk <onur@delipenguen.net> for help to track this one
  down.
Use png (not ppm) for image chaching, avoid some code duplication.
Debian build updates by Julien Portalier <trash@portalier.com>.
Hide menus when switching desktop.


0.16.7
-------------------------------------------------------------------------------
Bye bye Imlib1 and Fnlib.
Remove unused clone stuff.
Tidy up a bit (removed ancient ChangeLog's and other obsolete stuff).
Fix incorrect menu placement (still not ok if deskslide is active).
Valgrindings.
Fix nastiness when there are more than 16 windows on one desk at startup.
Fix desktop background thumbnail caching.
Fix some initial desktop setup.
Fix random killing when closing iconbox.
Attempt to do something about the Restart Placement Bug.
Enable showing some grab info.
Fix segv in "Advanced Settings" dialog when dialog headers are enabled.
Enable showing some menu info for debug (+tidy up some menu state stuff).
Debug for tracking area and desktop changes.
Debug commands to set/unset pointer grabs.
This commit is contained in:
recht 2004-08-26 20:22:18 +00:00
parent be347301e2
commit 8101fc9189
6 changed files with 508 additions and 2549 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.21 2004/03/10 14:12:51 xtraeme Exp $
# $NetBSD: Makefile,v 1.22 2004/08/26 20:22:18 recht Exp $
#
DISTNAME= enlightenment-0.16.6
PKGREVISION= 1
DISTNAME= enlightenment-0.16.7.1
CATEGORIES= x11 gnome wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=enlightenment/}
@ -12,13 +11,31 @@ COMMENT= Highly themeable and configurable window manager
USE_BUILDLINK3= YES
USE_X11= YES
USE_PERL5= YES
USE_PKGLOCALEDIR= YES
GNU_CONFIGURE= YES
USE_GNU_TOOLS+= yacc
CONFIGURE_ARGS+= --enable-fsstd
CONFIGURE_ARGS+= --enable-xrandr
CONFIGURE_ARGS+= --without-included-gettext
CONFIGURE_ARGS+= --disable-hints-gnome
CONFIGURE_ARGS+= --disable-hints-kde
CONFIGURE_ARGS+= --with-imlib-prefix=${BUILDLINK_PREFIX.imlib2}
MAKE_ENV+= USER=${SHAREOWN}:${SHAREGRP}
REPLACE_PERL= scripts/*.pl scripts/e_gen_menu
REPLACE_PERL= sample-scripts/bouncingball.pl
REPLACE_PERL+= sample-scripts/testroller.pl
REPLACE_PERL+= sample-scripts/shade-pagers.pl
REPLACE_PERL+= scripts/e_gen_menu
SUBST_CLASSES+= paths
SUBST_STAGE.paths= pre-configure
SUBST_FILES.paths= scripts/e_gen_menu
SUBST_SED.paths= -e 's,@LOCALBASE@,${LOCALBASE},g'
SUBST_SED.paths+= -e 's,@PREFIX@,${PREFIX},g'
SUBST_SED.paths+= -e 's,@X11BASE@,${X11BASE},g'
post-install:
for FILE in `${GREP} "\.directory$$" ${PKGDIR}/PLIST`; do \
@ -30,9 +47,9 @@ post-install:
${XARGS} ${CHMOD} ${SHAREMODE}
.include "../../audio/esound/buildlink3.mk"
.include "../../graphics/fnlib/buildlink3.mk"
.include "../../graphics/freetype-lib/buildlink3.mk"
.include "../../lang/perl5/buildlink3.mk"
.include "../../www/libghttp/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/imlib2/buildlink3.mk"
.include "../../x11/Xrandr/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.6 2003/12/20 05:29:55 xtraeme Exp $
$NetBSD: distinfo,v 1.7 2004/08/26 20:22:18 recht Exp $
SHA1 (enlightenment-0.16.6.tar.gz) = 971cbed022b5162c1f7034758c91549fa1a9227f
Size (enlightenment-0.16.6.tar.gz) = 11924484 bytes
SHA1 (patch-aa) = c64318bba6fbdfb616a32a5952207599ce46ffa0
SHA1 (enlightenment-0.16.7.1.tar.gz) = df5fe1527ac1aa5273b8a39aafec06a67673d9ee
Size (enlightenment-0.16.7.1.tar.gz) = 1791137 bytes
SHA1 (patch-aa) = 21772995ff370c81073b4c0dfd7f3182bab93768
SHA1 (patch-ab) = ccc73e4dfa8f0624f285a66e9246355642120cf4
SHA1 (patch-ac) = a7dc0765aefe409643d765d97236098f8a8ca88b

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.4 2003/12/20 05:29:55 xtraeme Exp $
$NetBSD: patch-aa,v 1.5 2004/08/26 20:22:18 recht Exp $
--- dox/file.c.orig Wed Nov 5 08:42:17 2003
+++ dox/file.c Fri Dec 19 20:56:04 2003
--- dox/file.c.orig 2004-07-01 20:51:46.000000000 +0200
+++ dox/file.c
@@ -26,6 +26,11 @@
# include <wctype.h>
#endif
@ -11,48 +11,23 @@ $NetBSD: patch-aa,v 1.4 2003/12/20 05:29:55 xtraeme Exp $
+typedef unsigned int wctype_t;
+#endif
+
#ifdef __EMX__
#define chdir _chdir2
#define getcwd _getcwd2
@@ -618,7 +623,7 @@
int cnt, i;
char *start, *finish, *ss, *w;
- int wcflg, mbflg;
+ int mbflg;
struct char_class {
char *name;
wctype_t wt;
@@ -654,6 +659,7 @@
static int
exists(char *s)
{
@@ -175,6 +180,7 @@ word_mb(char *s, int num, char *wd, int
}
/* Check multibyte character class is available or not */
+/*
wcflg = 0;
for ( cc = char_class_tbl; cc->name != NULL; cc++ )
for (cc = char_class_tbl; cc->name != NULL; cc++)
{
@@ -661,7 +667,7 @@
if ( cc->wt != (wctype_t)0 )
wcflg = 1;
@@ -182,7 +188,7 @@ word_mb(char *s, int num, char *wd, int
if (cc->wt != (wctype_t) 0)
wcflg = 1;
}
-
+*/
cnt = 0;
i = 0;
start = NULL;
@@ -679,6 +685,7 @@
if ( len < 0 ) { i++; continue; }
/* Check multibyte character class */
+/*
if ( wcflg )
{
wchar_t wc;
@@ -700,6 +707,7 @@
}
}
else
+*/
mbflg = len;
if ((cnt == num) && (

View file

@ -0,0 +1,37 @@
--- configure.orig 2004-08-18 01:29:31.000000000 +0200
+++ configure 2004-08-26 21:20:44.000000000 +0200
@@ -13500,14 +13500,20 @@
{ (exit 1); exit 1; }; }
fi
-
-echo "$as_me:$LINENO: checking for dlopen in -ldl" >&5
-echo $ECHO_N "checking for dlopen in -ldl... $ECHO_C" >&6
+if test "$host_os" = "freebsd" -o "$host_os" = "netbsdelf"; then
+ echo "$as_me:$LINENO: checking for dlopen in -lc" >&5
+ echo $ECHO_N "checking for dlopen in -lc... $ECHO_C" >&6
+else
+ echo "$as_me:$LINENO: checking for dlopen in -ldl" >&5
+ echo $ECHO_N "checking for dlopen in -ldl... $ECHO_C" >&6
+fi
if test "${ac_cv_lib_dl_dlopen+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-ldl -lm $LIBS"
+if test "$host_os" != "freebsd" -a "$host_os" != "netbsdelf"; then
+ LIBS="-ldl -lm $LIBS"
+fi
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -13566,7 +13572,9 @@
echo "$as_me:$LINENO: result: $ac_cv_lib_dl_dlopen" >&5
echo "${ECHO_T}$ac_cv_lib_dl_dlopen" >&6
if test $ac_cv_lib_dl_dlopen = yes; then
+ if test "$host_os" != "freebsd" -a "$host_os" != "netbsdelf"; then
DL_LIBS=-ldl
+ fi
else
echo "Warning: Enlightenment requires the dl (dynamic loader) library"

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ac,v 1.3 2004/08/26 20:22:18 recht Exp $
--- scripts/e_gen_menu.orig 2004-06-13 22:44:03.000000000 +0200
+++ scripts/e_gen_menu 2004-08-26 21:48:46.000000000 +0200
@@ -25,7 +25,7 @@
##############################################################################
# Likely prefixes
-$Prefixes = "/usr/local:/usr:/opt";
+$Prefixes = "@LOCALBASE@:@X11BASE@:/usr";
# Where to look for GNOME2/KDE2,3 stuff
$AppDirs = MkDirList($Prefixes, "/share/applications");
@@ -51,7 +51,7 @@
$loc1 = "" if ($loc1 eq $loc2);
$EdirUser = "$ENV{'HOME'}/.enlightenment" unless $EdirUser;
-$EdirRoot = "/usr/share/enlightenment" unless $EdirRoot;
+$EdirRoot = "@PREFIX@/share/enlightenment" unless $EdirRoot;
$EdirBin = "/usr/bin" unless $EdirBin;
$dbg = "$ENV{'E_MENUGEN_DBG'}";