Update to 1.7.1, provided by Tim Larson in PR 47230.
Changes: Eina 1.7.1 Changes since Eina 1.7.0: ------------------------- Fixes: * Fix return value of eina_mmap_safety_enabled_set() and future eina_mmap_safety_enabled_get() returns after success * Fix eina_stringshare_add_length() to return NULL when wrong. * Add EINA_SAFETY checks are wrong. Changes since Eina 1.2.0: ------------------------- Additions: * Add backtrace support to Eina_Log, use EINA_LOG_BACKTRACE to enable it. * Add an helper to iterate over line in a mapped file. * Add EINA_SENTINEL to protect variadic functions * Add EINA_SAFETY checks for proper function arguments. * Add check if given arguments (distance and coordinates) in eina_tiler and eina_rectangle are not below zero Fixes: * Add missing files in the tarball. * Rounding issue with eina_f32p32_cos and eina_f32p32_sin when getting close to 1.0. * Portability issue with Eina_Value when char are not signed by default (case on ARM and PPC). * Portability issue with Eina_Value test suite when unsigned where not promoted to unsigned long (case on Itanium). * Fix issue in the XML parser when a tag was in a comment or a CDATA. * Implement eina_file_map_lines() on Windows. * Handle NULL in all eina_*_free function. * eina_log_console_color_set() * Documentation for eina list specified and eina stringshare fixed. * eina_convert_atofp wrong return value if fp is NULL. Removal: * configure options: --disable-posix-threads, --disable-win32-threads, --enable-coverage Eina 1.2.0 Changes since Eina 1.1.0: ------------------------- Additions: * eina_mempool_calloc. * Eina_Semaphore abstraction API. * eina_xattr_fd_ls. * Eina_Xattr iterator : eina_xattr_value_fd_ls and eina_xattr_value_ls. * eina_file_map_faulted. * Xattr iterator for Eina_File : eina_file_xattr_get/value_get. * deprecated eina_array_count_get(), use eina_array_count() instead. * eina_inarray data type. * eina_value data type (generic value storage). * eina_file_stat. * eina_log*level_check. * eina_*buf_manage_new_length. * EINA_C_ARRAY_LENGTH macro. * Eina_Stringshare typedef. * add eina_file_map_faulted() for windows port (was missing). Fixes: * compilation errors in Eina_RWLock when building on Windows newer than XP. * stop leaking Eina_File. * remove dead lock in Eina_File. * bug on eina_shutdown when using eina_error. * NONNULL argument for eina_hash_find. * compilation of eina_semaphore_lock on Windows. * forgotten initialization of eina list count during eina_list_split_list. * leak in Eina_File. * deadlock in Eina_File. * make it possible to force the number of detected CPU on a system. Improvements: * faster implementation of Eina_Rbtree. * let eina_hash_free behave like free.
This commit is contained in:
parent
c84c494c88
commit
811d7cdf4d
9 changed files with 11 additions and 2251 deletions
|
@ -1,7 +1,7 @@
|
||||||
# $NetBSD: Makefile,v 1.6 2012/10/31 11:16:55 asau Exp $
|
# $NetBSD: Makefile,v 1.7 2012/12/12 11:39:02 wiz Exp $
|
||||||
#
|
#
|
||||||
|
|
||||||
DISTNAME= eina-1.1.0
|
DISTNAME= eina-1.7.1
|
||||||
CATEGORIES= devel
|
CATEGORIES= devel
|
||||||
MASTER_SITES= http://download.enlightenment.org/releases/
|
MASTER_SITES= http://download.enlightenment.org/releases/
|
||||||
EXTRACT_SUFX= .tar.bz2
|
EXTRACT_SUFX= .tar.bz2
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
@comment $NetBSD: PLIST,v 1.5 2011/12/05 17:14:52 joerg Exp $
|
@comment $NetBSD: PLIST,v 1.6 2012/12/12 11:39:02 wiz Exp $
|
||||||
include/eina-1/Eina.h
|
include/eina-1/Eina.h
|
||||||
include/eina-1/eina/eina_accessor.h
|
include/eina-1/eina/eina_accessor.h
|
||||||
include/eina-1/eina/eina_array.h
|
include/eina-1/eina/eina_array.h
|
||||||
|
@ -14,7 +14,9 @@ include/eina-1/eina/eina_file.h
|
||||||
include/eina-1/eina/eina_fp.h
|
include/eina-1/eina/eina_fp.h
|
||||||
include/eina-1/eina/eina_hamster.h
|
include/eina-1/eina/eina_hamster.h
|
||||||
include/eina-1/eina/eina_hash.h
|
include/eina-1/eina/eina_hash.h
|
||||||
|
include/eina-1/eina/eina_inarray.h
|
||||||
include/eina-1/eina/eina_inline_array.x
|
include/eina-1/eina/eina_inline_array.x
|
||||||
|
include/eina-1/eina/eina_inline_clist.x
|
||||||
include/eina-1/eina/eina_inline_f16p16.x
|
include/eina-1/eina/eina_inline_f16p16.x
|
||||||
include/eina-1/eina/eina_inline_f32p32.x
|
include/eina-1/eina/eina_inline_f32p32.x
|
||||||
include/eina-1/eina/eina_inline_f8p24.x
|
include/eina-1/eina/eina_inline_f8p24.x
|
||||||
|
@ -31,6 +33,7 @@ include/eina-1/eina/eina_inline_stringshare.x
|
||||||
include/eina-1/eina/eina_inline_tiler.x
|
include/eina-1/eina/eina_inline_tiler.x
|
||||||
include/eina-1/eina/eina_inline_trash.x
|
include/eina-1/eina/eina_inline_trash.x
|
||||||
include/eina-1/eina/eina_inline_ustringshare.x
|
include/eina-1/eina/eina_inline_ustringshare.x
|
||||||
|
include/eina-1/eina/eina_inline_value.x
|
||||||
include/eina-1/eina/eina_inlist.h
|
include/eina-1/eina/eina_inlist.h
|
||||||
include/eina-1/eina/eina_iterator.h
|
include/eina-1/eina/eina_iterator.h
|
||||||
include/eina-1/eina/eina_lalloc.h
|
include/eina-1/eina/eina_lalloc.h
|
||||||
|
@ -60,6 +63,7 @@ include/eina-1/eina/eina_types.h
|
||||||
include/eina-1/eina/eina_unicode.h
|
include/eina-1/eina/eina_unicode.h
|
||||||
include/eina-1/eina/eina_ustrbuf.h
|
include/eina-1/eina/eina_ustrbuf.h
|
||||||
include/eina-1/eina/eina_ustringshare.h
|
include/eina-1/eina/eina_ustringshare.h
|
||||||
|
include/eina-1/eina/eina_value.h
|
||||||
include/eina-1/eina/eina_xattr.h
|
include/eina-1/eina/eina_xattr.h
|
||||||
include/eina-1/eina_config.h
|
include/eina-1/eina_config.h
|
||||||
lib/libeina.la
|
lib/libeina.la
|
||||||
|
|
|
@ -1,11 +1,5 @@
|
||||||
$NetBSD: distinfo,v 1.8 2012/09/26 07:37:26 jperkin Exp $
|
$NetBSD: distinfo,v 1.9 2012/12/12 11:39:02 wiz Exp $
|
||||||
|
|
||||||
SHA1 (eina-1.1.0.tar.bz2) = 49e21e455a6a9fb52b1956527ee68de474f43ae4
|
SHA1 (eina-1.7.1.tar.bz2) = 972b94a0abdbaa1e61ebbfd5ea530ebdceacee02
|
||||||
RMD160 (eina-1.1.0.tar.bz2) = 14a565f6084a9cd1dcd1cff7327016a77d4aeeae
|
RMD160 (eina-1.7.1.tar.bz2) = 9ceb645b20a67dedf2a23f58d664323d5f1ea35f
|
||||||
Size (eina-1.1.0.tar.bz2) = 9983287 bytes
|
Size (eina-1.7.1.tar.bz2) = 9749033 bytes
|
||||||
SHA1 (patch-aa) = 3d93bfef1b09007a80875dfbf8cb37c13e2eb2c4
|
|
||||||
SHA1 (patch-configure) = a4ae3348716b41bb5e92a3e211dae751e10f5a29
|
|
||||||
SHA1 (patch-configure.ac) = adf38da81845df07f4a28d04a8acc7b8fb0ab7ef
|
|
||||||
SHA1 (patch-src_lib_eina__magic.c) = 3a11a343c16e38ea0bfb9adc7cb91dfbbdc4ebb7
|
|
||||||
SHA1 (patch-src_lib_eina__simple__xml__parser.c) = 69417e74773ccfb552f92d938fcba114de4ae155
|
|
||||||
SHA1 (patch-src_lib_eina__strbuf.c) = 9d0d535a727fe75ac21a6b8d240c15c14be78976
|
|
||||||
|
|
|
@ -1,22 +0,0 @@
|
||||||
$NetBSD: patch-aa,v 1.4 2011/12/05 17:14:52 joerg Exp $
|
|
||||||
|
|
||||||
--- src/lib/eina_cpu.c.orig 2011-04-05 08:41:54.000000000 +0000
|
|
||||||
+++ src/lib/eina_cpu.c
|
|
||||||
@@ -24,7 +24,7 @@
|
|
||||||
# ifdef _WIN32
|
|
||||||
# define WIN32_LEAN_AND_MEAN
|
|
||||||
# include <windows.h>
|
|
||||||
-# elif defined (__SUNPRO_C) || defined(__GNU__)
|
|
||||||
+# elif defined (__sun) || defined(__GNU__)
|
|
||||||
# include <unistd.h>
|
|
||||||
# elif defined (__FreeBSD__) || defined (__OpenBSD__) || \
|
|
||||||
defined (__NetBSD__) || defined (__DragonFly__) || defined (__MacOSX__) || \
|
|
||||||
@@ -140,7 +140,7 @@ EAPI int eina_cpu_count(void)
|
|
||||||
GetSystemInfo(&sysinfo);
|
|
||||||
return sysinfo.dwNumberOfProcessors;
|
|
||||||
|
|
||||||
-# elif defined (__SUNPRO_C) || defined(__GNU__)
|
|
||||||
+# elif defined (__sun) || defined(__GNU__)
|
|
||||||
/*
|
|
||||||
* _SC_NPROCESSORS_ONLN: number of processors that are online, that
|
|
||||||
is available when sysconf is called. The number
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,31 +0,0 @@
|
||||||
$NetBSD: patch-configure.ac,v 1.1 2011/12/05 17:14:52 joerg Exp $
|
|
||||||
|
|
||||||
--- configure.ac.orig 2011-11-26 11:33:53.000000000 +0000
|
|
||||||
+++ configure.ac
|
|
||||||
@@ -469,7 +469,25 @@ EFL_LINKER_FLAG([-fno-strict-aliasing])
|
|
||||||
### Checks for library functions
|
|
||||||
AC_ISC_POSIX
|
|
||||||
AC_FUNC_ALLOCA
|
|
||||||
-AC_CHECK_FUNCS([strlcpy dirfd openat fstatat fpathconf execvp])
|
|
||||||
+AC_CHECK_FUNCS([strlcpy openat fstatat fpathconf execvp])
|
|
||||||
+
|
|
||||||
+AC_MSG_CHECKING([dirfd])
|
|
||||||
+AC_LINK_IFELSE([
|
|
||||||
+
|
|
||||||
+#include <dirent.h>
|
|
||||||
+
|
|
||||||
+DIR *dirp;
|
|
||||||
+
|
|
||||||
+int
|
|
||||||
+main(void)
|
|
||||||
+{
|
|
||||||
+ return dirfd(dirp);
|
|
||||||
+}
|
|
||||||
+], [ AC_MSG_RESULT([yes])
|
|
||||||
+ AC_DEFINE([HAVE_DIRFD], 1, [ Define to 1 if you have the `dirfd' function or macro. ])
|
|
||||||
+ ],
|
|
||||||
+ [ AC_MSG_RESULT([no])]
|
|
||||||
+)
|
|
||||||
|
|
||||||
# dlopen and dladdr
|
|
||||||
dlopen_libs=""
|
|
|
@ -1,22 +0,0 @@
|
||||||
$NetBSD: patch-src_lib_eina__magic.c,v 1.1 2011/12/05 17:14:52 joerg Exp $
|
|
||||||
|
|
||||||
--- src/lib/eina_magic.c.orig 2011-06-22 16:11:17.000000000 +0000
|
|
||||||
+++ src/lib/eina_magic.c
|
|
||||||
@@ -79,7 +79,7 @@ _eina_magic_strings_sort_cmp(const void
|
|
||||||
static int
|
|
||||||
_eina_magic_strings_find_cmp(const void *p1, const void *p2)
|
|
||||||
{
|
|
||||||
- Eina_Magic a = (Eina_Magic)p1;
|
|
||||||
+ Eina_Magic a = (Eina_Magic)(size_t)p1;
|
|
||||||
const Eina_Magic_String *b = p2;
|
|
||||||
return a - b->magic;
|
|
||||||
}
|
|
||||||
@@ -206,7 +206,7 @@ eina_magic_string_get(Eina_Magic magic)
|
|
||||||
_eina_magic_strings_dirty = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
- ems = bsearch((void *)magic, _eina_magic_strings,
|
|
||||||
+ ems = bsearch((void *)(size_t)magic, _eina_magic_strings,
|
|
||||||
_eina_magic_strings_count, sizeof(Eina_Magic_String),
|
|
||||||
_eina_magic_strings_find_cmp);
|
|
||||||
if (ems)
|
|
|
@ -1,67 +0,0 @@
|
||||||
$NetBSD: patch-src_lib_eina__simple__xml__parser.c,v 1.1 2011/12/05 17:14:52 joerg Exp $
|
|
||||||
|
|
||||||
--- src/lib/eina_simple_xml_parser.c.orig 2011-11-09 07:12:35.000000000 +0000
|
|
||||||
+++ src/lib/eina_simple_xml_parser.c
|
|
||||||
@@ -121,7 +121,7 @@ static inline const char *
|
|
||||||
_eina_simple_xml_whitespace_find(const char *itr, const char *itr_end)
|
|
||||||
{
|
|
||||||
for (; itr < itr_end; itr++)
|
|
||||||
- if (isspace(*itr)) break;
|
|
||||||
+ if (isspace((unsigned char)*itr)) break;
|
|
||||||
return itr;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -129,7 +129,7 @@ static inline const char *
|
|
||||||
_eina_simple_xml_whitespace_skip(const char *itr, const char *itr_end)
|
|
||||||
{
|
|
||||||
for (; itr < itr_end; itr++)
|
|
||||||
- if (!isspace(*itr)) break;
|
|
||||||
+ if (!isspace((unsigned char)*itr)) break;
|
|
||||||
return itr;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -137,7 +137,7 @@ static inline const char *
|
|
||||||
_eina_simple_xml_whitespace_unskip(const char *itr, const char *itr_start)
|
|
||||||
{
|
|
||||||
for (itr--; itr > itr_start; itr--)
|
|
||||||
- if (!isspace(*itr)) break;
|
|
||||||
+ if (!isspace((unsigned char)*itr)) break;
|
|
||||||
return itr + 1;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -309,7 +309,7 @@ eina_simple_xml_parse(const char *buf, u
|
|
||||||
(!memcmp(itr + 2, "DOCTYPE",
|
|
||||||
sizeof("DOCTYPE") - 1)) &&
|
|
||||||
((itr[2 + sizeof("DOCTYPE") - 1] == '>') ||
|
|
||||||
- (isspace(itr[2 + sizeof("DOCTYPE") - 1]))))
|
|
||||||
+ (isspace((unsigned char)itr[2 + sizeof("DOCTYPE") - 1]))))
|
|
||||||
{
|
|
||||||
type = EINA_SIMPLE_XML_DOCTYPE;
|
|
||||||
toff = sizeof("!DOCTYPE") - 1;
|
|
||||||
@@ -455,7 +455,7 @@ eina_simple_xml_tag_attributes_find(cons
|
|
||||||
|
|
||||||
for (; itr < itr_end; itr++)
|
|
||||||
{
|
|
||||||
- if (!isspace(*itr))
|
|
||||||
+ if (!isspace((unsigned char)*itr))
|
|
||||||
{
|
|
||||||
/* user skip tagname and already gave it the attributes */
|
|
||||||
if (*itr == '=')
|
|
||||||
@@ -492,7 +492,7 @@ eina_simple_xml_attributes_parse(const c
|
|
||||||
|
|
||||||
key = p;
|
|
||||||
for (key_end = key; key_end < itr_end; key_end++)
|
|
||||||
- if ((*key_end == '=') || (isspace(*key_end))) break;
|
|
||||||
+ if ((*key_end == '=') || (isspace((unsigned char)*key_end))) break;
|
|
||||||
if (key_end == itr_end) return EINA_FALSE;
|
|
||||||
if (key_end == key) continue;
|
|
||||||
|
|
||||||
@@ -504,7 +504,7 @@ eina_simple_xml_attributes_parse(const c
|
|
||||||
value++;
|
|
||||||
}
|
|
||||||
for (; value < itr_end; value++)
|
|
||||||
- if (!isspace(*value)) break;
|
|
||||||
+ if (!isspace((unsigned char)*value)) break;
|
|
||||||
if (value == itr_end) return EINA_FALSE;
|
|
||||||
|
|
||||||
if ((*value == '"') || (*value == '\''))
|
|
|
@ -1,25 +0,0 @@
|
||||||
$NetBSD: patch-src_lib_eina__strbuf.c,v 1.1 2011/12/05 17:14:52 joerg Exp $
|
|
||||||
|
|
||||||
--- src/lib/eina_strbuf.c.orig 2011-10-16 12:46:24.000000000 +0000
|
|
||||||
+++ src/lib/eina_strbuf.c
|
|
||||||
@@ -162,9 +162,9 @@ eina_strbuf_insert_vprintf(Eina_Strbuf *
|
|
||||||
EAPI void
|
|
||||||
eina_strbuf_trim(Eina_Strbuf *buf)
|
|
||||||
{
|
|
||||||
- char *c = buf->buf;
|
|
||||||
+ unsigned char *c = buf->buf;
|
|
||||||
|
|
||||||
- while (buf->len > 0 && isspace(((unsigned char*)(buf->buf))[buf->len - 1]))
|
|
||||||
+ while (buf->len > 0 && isspace(c[buf->len - 1]))
|
|
||||||
buf->len--;
|
|
||||||
while (buf->len > 0 && isspace(*c))
|
|
||||||
{
|
|
||||||
@@ -178,7 +178,7 @@ eina_strbuf_trim(Eina_Strbuf *buf)
|
|
||||||
EAPI void
|
|
||||||
eina_strbuf_ltrim(Eina_Strbuf *buf)
|
|
||||||
{
|
|
||||||
- char *c = buf->buf;
|
|
||||||
+ unsigned char *c = buf->buf;
|
|
||||||
|
|
||||||
while (buf->len > 0 && isspace(*c))
|
|
||||||
{
|
|
Loading…
Reference in a new issue