Fix build with ocaml >= 3.09.0

Depends on ocaml >= 3.09.0
use _loc instead of loc in camlp4 files

bump PKGREVISION
This commit is contained in:
tonio 2006-03-09 10:35:49 +00:00
parent 1d8e51428b
commit 8127d1c0c6
3 changed files with 41 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.28 2006/02/05 23:08:30 joerg Exp $
# $NetBSD: Makefile,v 1.29 2006/03/09 10:35:49 tonio Exp $
#
DISTNAME= geneweb-4.10
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= databases
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/cristal/geneweb/Src/
@ -21,6 +21,10 @@ BUILD_TARGET= out
.include "../../mk/bsd.prefs.mk"
# needed for patch-ab to work:
# since 3.09.0, camlp4 uses _loc instead of loc
BUILDLINK_DEPENDS.ocaml+= ocaml>=3.09.0
# sysutils/coreutils a 'gwc' program, so conflict with it if
# ${GNU_PROGRAM_PREFIX} == "g"
.if ${GNU_PROGRAM_PREFIX} == "g"

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.11 2006/02/10 23:32:00 rillig Exp $
$NetBSD: distinfo,v 1.12 2006/03/09 10:35:49 tonio Exp $
SHA1 (geneweb-4.10nb1/geneweb-4.10.tar.gz) = 0ab12497a3ffc3541228d9dc899c095b18e7fba1
RMD160 (geneweb-4.10nb1/geneweb-4.10.tar.gz) = 5d5c9d08d76bbc08a288e7ae56aa335b9cfc0fb8
Size (geneweb-4.10nb1/geneweb-4.10.tar.gz) = 998314 bytes
SHA1 (patch-aa) = 5f90d1c0a8545b670587ee5d7bbd39829073671f
SHA1 (patch-ab) = 36e0ed9d8034ea546400cdc685a43fce4bac1d30

View file

@ -0,0 +1,33 @@
$NetBSD: patch-ab,v 1.1 2006/03/09 10:35:49 tonio Exp $
--- src/pa_html.ml.orig 2004-12-14 10:30:14.000000000 +0100
+++ src/pa_html.ml
@@ -10,7 +10,7 @@ value rec unfold_apply list =
| e -> (e, list) ]
;
-value tag_encloser loc tag newl a el =
+value tag_encloser _loc tag newl a el =
let s = if newl then "\n" else "" in
let e =
let (frm, al) =
@@ -37,13 +37,13 @@ EXTEND
GLOBAL: expr;
expr: LEVEL "top"
[ [ "tag"; (tn, al, el) = tag_body ->
- let el = tag_encloser loc tn True al el in
- ifndef NEWSEQ then MLast.ExSeq loc el (MLast.ExUid loc "()")
- else MLast.ExSeq loc el
+ let el = tag_encloser _loc tn True al el in
+ ifndef NEWSEQ then MLast.ExSeq _loc el (MLast.ExUid _loc "()")
+ else MLast.ExSeq _loc el
| "stag"; (tn, al, el) = tag_body ->
- let el = tag_encloser loc tn False al el in
- ifndef NEWSEQ then MLast.ExSeq loc el (MLast.ExUid loc "()")
- else MLast.ExSeq loc el ] ]
+ let el = tag_encloser _loc tn False al el in
+ ifndef NEWSEQ then MLast.ExSeq _loc el (MLast.ExUid _loc "()")
+ else MLast.ExSeq _loc el ] ]
;
tag_body:
[ [ tn = STRING; a = OPT expr; "begin"; el = LIST0 expr_semi; "end" ->