VR series of the Washington University ftp daemon.
Includes several enhancements and bug fixes over the original wu-ftpd version
This commit is contained in:
parent
22bda05336
commit
8167dd0257
18 changed files with 319 additions and 0 deletions
24
net/wu-ftpd-vr/Makefile
Normal file
24
net/wu-ftpd-vr/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/02/21 12:37:20 rh Exp $
|
||||
#
|
||||
|
||||
DISTNAME= wu-ftpd-2.4.2-beta-18-vr14
|
||||
PKGNAME= wu-ftpd-2.4.2b18.14
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.vr.net/pub/wu-ftpd/ \
|
||||
ftp://ftp.crc.ca/pub/packages/ftp/servers/wuarchive-ftpd-vr/ \
|
||||
ftp://ftp.ahol.com/pub/mirrors/wu-ftpd/ \
|
||||
ftp://ftp.sunet.se/pub/nir/ftp/servers/wuarchive-ftpd-vr/ \
|
||||
ftp://ftp.gtn.com/pub/server/wuftpd/
|
||||
|
||||
MAINTAINER= rh@netbsd.org
|
||||
HOMEPAGE= http://www.landfield.com/wu-ftpd/
|
||||
|
||||
MAKE_ENV+= INSTALL="${INSTALL}"
|
||||
MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}"
|
||||
MAKE_ENV+= INSTALL_DATA="${INSTALL_DATA}"
|
||||
MAKE_ENV+= INSTALL_MAN="${INSTALL_MAN}"
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ./build nbs PREFIX=${PREFIX}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
net/wu-ftpd-vr/files/md5
Normal file
3
net/wu-ftpd-vr/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/02/21 12:37:20 rh Exp $
|
||||
|
||||
MD5 (wu-ftpd-2.4.2-beta-18-vr14.tar.gz) = db4403de07667babbadbbd1ae72f0799
|
64
net/wu-ftpd-vr/patches/patch-aa
Normal file
64
net/wu-ftpd-vr/patches/patch-aa
Normal file
|
@ -0,0 +1,64 @@
|
|||
$NetBSD$
|
||||
|
||||
--- makefiles/Makefile.nbs.orig Fri Jul 3 19:03:20 1998
|
||||
+++ makefiles/Makefile.nbs Sat Feb 13 08:31:28 1999
|
||||
@@ -2,32 +2,42 @@
|
||||
# Makefile for NetBSD 1.2
|
||||
# $Id: Makefile.nbs,v 1.3 1998/07/03 17:03:02 sob Beta-17 sob $
|
||||
#
|
||||
-BINDIR= /usr/local/bin
|
||||
-ETCDIR= /usr/local/libexec
|
||||
-MANDIR= /usr/local/man
|
||||
+PREFIX?= /usr/pkg
|
||||
+BINDIR= ${PREFIX}/bin
|
||||
+ETCDIR= ${PREFIX}/etc
|
||||
+MANDIR= ${PREFIX}/man
|
||||
+LIBEXECDIR= ${PREFIX}/libexec
|
||||
MANEXT= 8
|
||||
-INSTALL= install
|
||||
+INSTALL?= install
|
||||
+INSTALL_PROGRAM?= ${INSTALL} -c -o bin -g bin -m 555
|
||||
+INSTALL_DATA?= ${INSTALL} -c -o root -g wheel -m 444
|
||||
+INSTALL_MAN?= ${INSTALL} -c -o root -g wheel -m 444
|
||||
|
||||
all:
|
||||
@ echo 'Use the "build" command (shell script) to make ftpd.'
|
||||
@ echo 'You can say "build help" for details on how it works.'
|
||||
|
||||
install: bin/ftpd bin/ftpcount bin/ftpshut
|
||||
- -mv -f ${ETCDIR}/ftpd ${ETCDIR}/ftpd-old
|
||||
+ -mv -f ${LIBEXECDIR}/ftpd ${LIBEXECDIR}/ftpd-old
|
||||
@echo installing binaries.
|
||||
- ${INSTALL} -c -o bin -g bin -m 755 bin/ftpd ${ETCDIR}/ftpd
|
||||
- ${INSTALL} -c -o bin -g bin -m 755 bin/ftpshut ${BINDIR}/ftpshut
|
||||
- ${INSTALL} -c -o bin -g bin -m 755 bin/ftpcount ${BINDIR}/ftpcount
|
||||
- ${INSTALL} -c -o bin -g bin -m 755 bin/ftpwho ${BINDIR}/ftpwho
|
||||
+ ${INSTALL_PROGRAM} bin/ftpd ${LIBEXECDIR}/ftpd
|
||||
+ ${INSTALL_PROGRAM} bin/ftpshut ${BINDIR}/ftpshut
|
||||
+ ${INSTALL_PROGRAM} bin/ftpcount ${BINDIR}/ftpcount
|
||||
+ ${INSTALL_PROGRAM} bin/ftpwho ${BINDIR}/ftpwho
|
||||
+ ${INSTALL_PROGRAM} bin/ckconfig ${BINDIR}/ftpckconfig
|
||||
+ @echo Installing basic configuration
|
||||
+ ${INSTALL_DATA} doc/examples/ftpaccess ${ETCDIR}/ftpaccess.example
|
||||
+ ${INSTALL_DATA} doc/examples/ftpusers ${ETCDIR}/ftpusers.example
|
||||
+ ${INSTALL_DATA} doc/examples/ftpconversions ${ETCDIR}/ftpconversions.example
|
||||
@echo installing manpages.
|
||||
- ${INSTALL} -c -o bin -g bin -m 644 doc/ftpd.8 ${MANDIR}/man8/ftpd.8
|
||||
- ${INSTALL} -c -o bin -g bin -m 644 doc/ftpcount.1 ${MANDIR}/man1/ftpcount.1
|
||||
- ${INSTALL} -c -o bin -g bin -m 644 doc/ftpwho.1 ${MANDIR}/man1/ftpwho.1
|
||||
- ${INSTALL} -c -o bin -g bin -m 644 doc/ftpshut.8 ${MANDIR}/man8/ftpshut.8
|
||||
- ${INSTALL} -c -o bin -g bin -m 644 doc/ftpaccess.5 ${MANDIR}/man5/ftpaccess.5
|
||||
- ${INSTALL} -c -o bin -g bin -m 644 doc/ftphosts.5 ${MANDIR}/man5/ftphosts.5
|
||||
- ${INSTALL} -c -o bin -g bin -m 644 doc/ftpconversions.5 ${MANDIR}/man5/ftpconversions.5
|
||||
- ${INSTALL} -c -o bin -g bin -m 644 doc/xferlog.5 ${MANDIR}/man5/xferlog.5
|
||||
+ ${INSTALL_MAN} doc/ftpd.8 ${MANDIR}/man8/ftpd.8
|
||||
+ ${INSTALL_MAN} doc/ftpcount.1 ${MANDIR}/man1/ftpcount.1
|
||||
+ ${INSTALL_MAN} doc/ftpwho.1 ${MANDIR}/man1/ftpwho.1
|
||||
+ ${INSTALL_MAN} doc/ftpshut.8 ${MANDIR}/man8/ftpshut.8
|
||||
+ ${INSTALL_MAN} doc/ftpaccess.5 ${MANDIR}/man5/ftpaccess.5
|
||||
+ ${INSTALL_MAN} doc/ftphosts.5 ${MANDIR}/man5/ftphosts.5
|
||||
+ ${INSTALL_MAN} doc/ftpconversions.5 ${MANDIR}/man5/ftpconversions.5
|
||||
+ ${INSTALL_MAN} doc/xferlog.5 ${MANDIR}/man5/xferlog.5
|
||||
|
||||
|
||||
|
19
net/wu-ftpd-vr/patches/patch-ab
Normal file
19
net/wu-ftpd-vr/patches/patch-ab
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- src/pathnames.h.orig Sat Oct 31 16:58:16 1998
|
||||
+++ src/pathnames.h Sat Feb 20 21:23:53 1999
|
||||
@@ -45,10 +45,10 @@
|
||||
#define _PATH_EXECPATH "/bin/ftp-exec"
|
||||
|
||||
#ifdef USE_ETC
|
||||
-#define _PATH_FTPUSERS "/etc/ftpusers"
|
||||
-#define _PATH_FTPACCESS "/etc/ftpaccess"
|
||||
-#define _PATH_CVT "/etc/ftpconversions"
|
||||
-#define _PATH_PRIVATE "/etc/ftpgroups"
|
||||
+#define _PATH_FTPUSERS PREFIX "/etc/ftpusers"
|
||||
+#define _PATH_FTPACCESS PREFIX "/etc/ftpaccess"
|
||||
+#define _PATH_CVT PREFIX "/etc/ftpconversions"
|
||||
+#define _PATH_PRIVATE PREFIX "/etc/ftpgroups"
|
||||
#else
|
||||
#ifdef USE_ETC_FTPD
|
||||
#define _PATH_FTPUSERS "/etc/ftpd/ftpusers"
|
21
net/wu-ftpd-vr/patches/patch-ac
Normal file
21
net/wu-ftpd-vr/patches/patch-ac
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- doc/examples/ftpconversions.orig Mon Sep 28 20:21:32 1998
|
||||
+++ doc/examples/ftpconversions Sat Feb 20 21:28:41 1999
|
||||
@@ -1,9 +1,9 @@
|
||||
- :.Z: : :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
|
||||
- : : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
|
||||
- :.gz: : :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
|
||||
- : : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
|
||||
- : : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
|
||||
- : : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
|
||||
- : : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP
|
||||
+ :.Z: : :/usr/bin/gzip -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
|
||||
+ : : :.Z:/usr/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
|
||||
+ :.gz: : :/usr/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
|
||||
+ : : :.gz:/usr/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
|
||||
+ : : :.tar:/usr/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
|
||||
+ : : :.tar.Z:/usr/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
|
||||
+ : : :.tar.gz:/usr/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP
|
||||
: : :.crc:/bin/cksum %s:T_REG::CKSUM
|
||||
: : :.md5:/bin/md5sum %s:T_REG::MD5SUM
|
27
net/wu-ftpd-vr/patches/patch-ad
Normal file
27
net/wu-ftpd-vr/patches/patch-ad
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- doc/examples/ftpusers.orig Fri Apr 1 21:03:23 1994
|
||||
+++ doc/examples/ftpusers Sat Feb 13 00:18:05 1999
|
||||
@@ -1,14 +1,12 @@
|
||||
root
|
||||
-bin
|
||||
-boot
|
||||
+toor
|
||||
daemon
|
||||
-digital
|
||||
-field
|
||||
-gateway
|
||||
-guest
|
||||
-nobody
|
||||
operator
|
||||
-ris
|
||||
-sccs
|
||||
-sys
|
||||
+bin
|
||||
+games
|
||||
+news
|
||||
+man
|
||||
uucp
|
||||
+xten
|
||||
+ingres
|
||||
+nobody
|
13
net/wu-ftpd-vr/patches/patch-ae
Normal file
13
net/wu-ftpd-vr/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- config.h.orig Sat Feb 13 23:41:57 1999
|
||||
+++ config.h Sat Feb 20 21:28:41 1999
|
||||
@@ -72,7 +72,7 @@
|
||||
* See FIXES-2.4-HOBBIT for more information on this option.
|
||||
*/
|
||||
|
||||
-#undef SKEY
|
||||
+/* #undef SKEY */
|
||||
|
||||
/*
|
||||
* OPIE
|
13
net/wu-ftpd-vr/patches/patch-af
Normal file
13
net/wu-ftpd-vr/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- support/makefiles/Makefile.nbs.orig Mon Jul 6 10:57:39 1998
|
||||
+++ support/makefiles/Makefile.nbs Sat Feb 13 00:43:35 1999
|
||||
@@ -8,7 +8,7 @@
|
||||
LIBC = /usr/lib/libc.a
|
||||
IFLAGS =
|
||||
LFLAGS =
|
||||
-CFLAGS = -O ${IFLAGS} ${LFLAGS} -DNO_MALLOC_PROTO
|
||||
+CFLAGS+= ${IFLAGS} ${LFLAGS} -DNO_MALLOC_PROTO
|
||||
|
||||
SRCS = strcasestr.c authuser.c ftw.c
|
||||
OBJS = strcasestr.o authuser.o ftw.o
|
13
net/wu-ftpd-vr/patches/patch-ag
Normal file
13
net/wu-ftpd-vr/patches/patch-ag
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ag,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- src/makefiles/Makefile.nbs.orig Sat Oct 31 16:58:15 1998
|
||||
+++ src/makefiles/Makefile.nbs Sat Feb 20 21:27:50 1999
|
||||
@@ -5,7 +5,7 @@
|
||||
CC = cc -g
|
||||
IFLAGS = -I.. -I../support
|
||||
LFLAGS = -L../support
|
||||
-CFLAGS = -O ${IFLAGS} ${LFLAGS}
|
||||
+CFLAGS += ${IFLAGS} ${LFLAGS} -DPREFIX=\"${PREFIX}\"
|
||||
XOBJS =
|
||||
LIBES = ${LSKEY} -lsupport -lcrypt
|
||||
LIBC = /usr/lib/libc.a
|
12
net/wu-ftpd-vr/patches/patch-ah
Normal file
12
net/wu-ftpd-vr/patches/patch-ah
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ah,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- support/authuser.c.orig Mon Jul 6 11:14:52 1998
|
||||
+++ support/authuser.c Sat Feb 13 00:43:35 1999
|
||||
@@ -9,6 +9,7 @@
|
||||
#else
|
||||
#include <sys/types.h>
|
||||
#endif
|
||||
+#include <string.h>
|
||||
#include <stdio.h>
|
||||
#include <ctype.h>
|
||||
#include <errno.h>
|
14
net/wu-ftpd-vr/patches/patch-ai
Normal file
14
net/wu-ftpd-vr/patches/patch-ai
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ai,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- src/ftpd.c.orig Sat Feb 13 23:41:58 1999
|
||||
+++ src/ftpd.c Sat Feb 20 21:28:42 1999
|
||||
@@ -4336,7 +4336,9 @@
|
||||
*p = '\0';
|
||||
|
||||
/* send a line...(note that this overrides dolreplies!) */
|
||||
+ VA_START(fmt);
|
||||
vreply(USE_REPLY_LONG | USE_REPLY_NOTFMT, n, ptr, ap);
|
||||
+ VA_END; /* *NEVER* send a 0 as an ap, some machines use a *struct* for a va_list! */
|
||||
|
||||
if (p)
|
||||
ptr = p + 1; /* set to the next line... (\0 is handled in the while) */
|
12
net/wu-ftpd-vr/patches/patch-aj
Normal file
12
net/wu-ftpd-vr/patches/patch-aj
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-aj,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- support/ftw.c.orig Mon Jul 6 10:56:21 1998
|
||||
+++ support/ftw.c Sat Feb 13 00:54:09 1999
|
||||
@@ -30,6 +30,7 @@
|
||||
|
||||
#include <errno.h>
|
||||
|
||||
+#include <string.h>
|
||||
#include <sys/param.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/stat.h>
|
13
net/wu-ftpd-vr/patches/patch-ak
Normal file
13
net/wu-ftpd-vr/patches/patch-ak
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ak,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- src/ckconfig.c.orig Mon Jul 6 11:14:14 1998
|
||||
+++ src/ckconfig.c Sat Feb 13 00:54:09 1999
|
||||
@@ -33,6 +33,8 @@
|
||||
#ifndef HOST_ACCESS
|
||||
#define HOST_ACCESS 1
|
||||
#endif
|
||||
+
|
||||
+#include <string.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
23
net/wu-ftpd-vr/patches/patch-an
Normal file
23
net/wu-ftpd-vr/patches/patch-an
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-an,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- src/ftpcmd.y.orig Sat Feb 13 23:41:57 1999
|
||||
+++ src/ftpcmd.y Sat Feb 20 21:30:43 1999
|
||||
@@ -750,16 +750,16 @@
|
||||
= {
|
||||
if (log_commands) syslog(LOG_INFO, "SYST");
|
||||
if ($2)
|
||||
-#if defined (unix) || defined (__unix__)
|
||||
#ifdef BSD
|
||||
reply(215, "UNIX Type: L%d Version: BSD-%d",
|
||||
NBBY, BSD);
|
||||
#else /* BSD */
|
||||
+#if defined (unix) || defined (__unix__)
|
||||
reply(215, "UNIX Type: L%d", NBBY);
|
||||
-#endif /* BSD */
|
||||
#else /* unix */
|
||||
reply(215, "UNKNOWN Type: L%d", NBBY);
|
||||
#endif /* unix */
|
||||
+#endif /* BSD */
|
||||
}
|
||||
|
||||
/*
|
11
net/wu-ftpd-vr/patches/patch-ao
Normal file
11
net/wu-ftpd-vr/patches/patch-ao
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-ao,v 1.1.1.1 1999/02/21 12:37:21 rh Exp $
|
||||
|
||||
--- src/config/config.nbs.orig Mon Dec 28 18:42:02 1998
|
||||
+++ src/config/config.nbs Sat Feb 20 21:44:48 1999
|
||||
@@ -62,4 +62,6 @@
|
||||
*/
|
||||
#define SKEY
|
||||
|
||||
+#ifndef unix
|
||||
#define unix
|
||||
+#endif
|
1
net/wu-ftpd-vr/pkg/COMMENT
Normal file
1
net/wu-ftpd-vr/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
An enhanced ftp server for Un*x systems
|
19
net/wu-ftpd-vr/pkg/DESCR
Normal file
19
net/wu-ftpd-vr/pkg/DESCR
Normal file
|
@ -0,0 +1,19 @@
|
|||
VR release of the WASHINGTON UNIVERSITY FTP SERVER, RELEASE 2.4
|
||||
wu-ftpd-vr is a replacement ftp server for Un*x systems. Besides
|
||||
supporting the ftp protocol defined in RFC 959, it adds the following
|
||||
features:
|
||||
|
||||
o logging of transfers
|
||||
o logging of commands
|
||||
o on the fly compression and archiving
|
||||
o classification of users on type and location
|
||||
o per class limits
|
||||
o per directory upload permissions
|
||||
o restricted guest accounts
|
||||
o system wide and per directory messages.
|
||||
o directory alias
|
||||
o cdpath
|
||||
o filename filter
|
||||
|
||||
The VR series offers a number of enhancements and bug fixes not
|
||||
available in the base beta-18 version.
|
17
net/wu-ftpd-vr/pkg/PLIST
Normal file
17
net/wu-ftpd-vr/pkg/PLIST
Normal file
|
@ -0,0 +1,17 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/02/21 12:37:20 rh Exp $
|
||||
etc/ftpaccess.example
|
||||
etc/ftpconversions.example
|
||||
etc/ftpusers.example
|
||||
libexec/ftpd
|
||||
man/man1/ftpcount.1
|
||||
man/man1/ftpwho.1
|
||||
man/man5/ftpaccess.5
|
||||
man/man5/ftphosts.5
|
||||
man/man5/ftpconversions.5
|
||||
man/man5/xferlog.5
|
||||
man/man8/ftpd.8
|
||||
man/man8/ftpshut.8
|
||||
bin/ftpshut
|
||||
bin/ftpcount
|
||||
bin/ftpwho
|
||||
bin/ftpckconfig
|
Loading…
Reference in a new issue