Re-import eukleides-1.0.3 as math/eukleides10.

A Euclidean drawing language compiler which allows one to typeset
geometry figures within a (La)TeX document. This program is also useful
to convert such figures into EPS format or into various other vector
graphic formats.
This package is legacy version.
This commit is contained in:
ryoon 2013-06-10 12:25:59 +00:00
parent 36ec98fb93
commit 8177449b5f
5 changed files with 59 additions and 0 deletions

5
math/eukleides10/DESCR Normal file
View file

@ -0,0 +1,5 @@
A Euclidean drawing language compiler which allows one to typeset
geometry figures within a (La)TeX document. This program is also useful
to convert such figures into EPS format or into various other vector
graphic formats.
This package is legacy version.

28
math/eukleides10/Makefile Normal file
View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1 2013/06/10 12:25:59 ryoon Exp $
DISTNAME= eukleides.1.0.3
PKGNAME= eukleides-1.0.3
CATEGORIES= math
MASTER_SITES= http://www.eukleides.org/download/
MAINTAINER= tsadowski@gmx.net
HOMEPAGE= http://www.eukleides.org/
COMMENT= Euclidean geometry drawing language
MAKE_JOBS_SAFE= no
DEPENDS+= pstoedit>=3.31:../../graphics/pstoedit
BUILD_TARGET= eukleides
USE_TOOLS+= bash:run bison gmake makeinfo lex
INFO_FILES= yes
REPLACE_BASH= euk2edit euk2eps
INSTALL_MAKE_FLAGS= ${MAKE_FLAGS} \
PREFIX=${DESTDIR}${PREFIX} \
BINPATH=${DESTDIR}${PREFIX}/bin \
INFODIR=${DESTDIR}${PREFIX}/${PKGINFODIR} \
MANDIR=${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
.include "../../mk/bsd.pkg.mk"

8
math/eukleides10/PLIST Normal file
View file

@ -0,0 +1,8 @@
@comment $NetBSD: PLIST,v 1.1 2013/06/10 12:25:59 ryoon Exp $
bin/euk2edit
bin/euk2eps
bin/eukleides
info/eukleides.info
man/man1/euk2edit.1
man/man1/euk2eps.1
man/man1/eukleides.1

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2013/06/10 12:25:59 ryoon Exp $
SHA1 (eukleides.1.0.3.tar.gz) = c3fd66c133a11d4b3ee2680c565f50e0a9b8b0c3
RMD160 (eukleides.1.0.3.tar.gz) = 72988952e526b44eae5ac5d1d0543ccb896881b0
Size (eukleides.1.0.3.tar.gz) = 50923 bytes
SHA1 (patch-aa) = a41d01866d8dd1d200bedacc82644d6009581227

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1 2013/06/10 12:25:59 ryoon Exp $
--- parser.y.orig 2008-12-19 14:31:22.000000000 +0100
+++ parser.y
@@ -24,6 +24,7 @@
#include "types.h"
#include "geometry.h"
#include "drawing.h"
+#include "parser.tab.h"
int yylex(void);
int warning(char *);