Update to 1.6.1:
1.6.1 New versions of OpenEXR and CTL are now available. This release fixes a buffer overrun in OpenEXR and a Windows build problem in CTL, and it removes a few unnecessary files from the .tar.gz packages. 1.6.0 * Reduced generational loss in B44- and B44A-compressed images. * Added B44A compression. This is a variation of B44, but with a better compression ratio for images with large uniform areas, such as in an alpha channel. * Bug fixes. 1.5.0 * OpenEXR supports a new image compression method, called B44. It has a fixed compression rate of 2.28:1, or 4.57:1 if used in combination with luminance/chroma encoding. B44-compressed images can be uncompressed fast enough to support real-time playback of image sequences. * The new playexr program plays back moving image sequences. Playexr is multi-threaded and utilizes the threading capabilities of the IlmImf library that were introduced in OpenEXR 1.3.0. The program plays back B44-compressed images with fairly high-resolution in real time on commodity hardware. * The playexr program and a new version of the existing exrdisplay image viewer both support color rendering via color transforms written in the new Color Transformation Language or CTL. CTL is not part of OpenEXR; it will be released separately. CTL support in playexr and exrdisplay is optional; the programs can be built and will run without CTL. * In preparation for the release of CTL, OpenEXR has been split into three separate packages: o IlmBase 0.9.0 includes the Half, Iex, Imath and IlmThread libraries o OpenEXR 1.5.0 includes the IlmImf library, programming examples and utility programs such as exrheader or exrenvmap o OpenEXRViewers 0.9.0 includes the playexr and exrdisplay programs * The "Technical Introduction to OpenEXR" document now includes a recommendation for storing CIE XYZ pixel data in OpenEXR files. * A new "OpenEXR Image Viewing Software" document describes the playexr and exrdisplay programs. It briefly explains real-time playback and color rendering, and includes recommendations for testing if other image viewing software displays OpenEXR images correctly. * The OpenEXR sample image set now includes B44-compressed files and files with CIE XYZ pixel data.
This commit is contained in:
parent
fd4fd7046a
commit
8187843103
6 changed files with 34 additions and 109 deletions
|
@ -1,8 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.18 2007/10/16 06:52:43 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2007/11/30 21:52:17 wiz Exp $
|
||||
|
||||
DISTNAME= openexr-1.4.0a
|
||||
PKGNAME= openexr-1.4.0
|
||||
PKGREVISION= 3
|
||||
DISTNAME= openexr-1.6.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://savannah.nongnu.org/download/openexr/
|
||||
|
||||
|
@ -10,17 +8,18 @@ MAINTAINER= adam@NetBSD.org
|
|||
HOMEPAGE= http://www.openexr.com/
|
||||
COMMENT= High dynamic-range (HDR) image file format library and tools
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
|
||||
USE_TOOLS+= gmake
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
PKGCONFIG_OVERRIDE= OpenEXR.pc.in
|
||||
TEST_TARGET= check
|
||||
|
||||
PTHREAD_OPTS+= require
|
||||
LIBS.IRIX+= -lmx
|
||||
LIBS.SunOS+= -lm
|
||||
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/ilmbase/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,49 +1,12 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2007/01/11 19:03:05 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2007/11/30 21:52:17 wiz Exp $
|
||||
bin/exrenvmap
|
||||
bin/exrheader
|
||||
bin/exrmakepreview
|
||||
bin/exrmaketiled
|
||||
bin/exrstdattr
|
||||
include/OpenEXR/Iex.h
|
||||
include/OpenEXR/IexBaseExc.h
|
||||
include/OpenEXR/IexErrnoExc.h
|
||||
include/OpenEXR/IexMacros.h
|
||||
include/OpenEXR/IexMathExc.h
|
||||
include/OpenEXR/IexThrowErrnoExc.h
|
||||
include/OpenEXR/IlmThread.h
|
||||
include/OpenEXR/IlmThreadMutex.h
|
||||
include/OpenEXR/IlmThreadPool.h
|
||||
include/OpenEXR/IlmThreadSemaphore.h
|
||||
include/OpenEXR/ImathBox.h
|
||||
include/OpenEXR/ImathBoxAlgo.h
|
||||
include/OpenEXR/ImathColor.h
|
||||
include/OpenEXR/ImathColorAlgo.h
|
||||
include/OpenEXR/ImathEuler.h
|
||||
include/OpenEXR/ImathExc.h
|
||||
include/OpenEXR/ImathFrame.h
|
||||
include/OpenEXR/ImathFrustum.h
|
||||
include/OpenEXR/ImathFun.h
|
||||
include/OpenEXR/ImathGL.h
|
||||
include/OpenEXR/ImathGLU.h
|
||||
include/OpenEXR/ImathHalfLimits.h
|
||||
include/OpenEXR/ImathInterval.h
|
||||
include/OpenEXR/ImathLimits.h
|
||||
include/OpenEXR/ImathLine.h
|
||||
include/OpenEXR/ImathLineAlgo.h
|
||||
include/OpenEXR/ImathMath.h
|
||||
include/OpenEXR/ImathMatrix.h
|
||||
include/OpenEXR/ImathMatrixAlgo.h
|
||||
include/OpenEXR/ImathPlane.h
|
||||
include/OpenEXR/ImathPlatform.h
|
||||
include/OpenEXR/ImathQuat.h
|
||||
include/OpenEXR/ImathRandom.h
|
||||
include/OpenEXR/ImathRoots.h
|
||||
include/OpenEXR/ImathShear.h
|
||||
include/OpenEXR/ImathSphere.h
|
||||
include/OpenEXR/ImathVec.h
|
||||
include/OpenEXR/ImathVecAlgo.h
|
||||
include/OpenEXR/ImfArray.h
|
||||
include/OpenEXR/ImfAttribute.h
|
||||
include/OpenEXR/ImfB44Compressor.h
|
||||
include/OpenEXR/ImfBoxAttribute.h
|
||||
include/OpenEXR/ImfCRgbaFile.h
|
||||
include/OpenEXR/ImfChannelList.h
|
||||
|
@ -58,6 +21,7 @@ include/OpenEXR/ImfEnvmap.h
|
|||
include/OpenEXR/ImfEnvmapAttribute.h
|
||||
include/OpenEXR/ImfFloatAttribute.h
|
||||
include/OpenEXR/ImfFrameBuffer.h
|
||||
include/OpenEXR/ImfFramesPerSecond.h
|
||||
include/OpenEXR/ImfHeader.h
|
||||
include/OpenEXR/ImfHuf.h
|
||||
include/OpenEXR/ImfIO.h
|
||||
|
@ -76,6 +40,8 @@ include/OpenEXR/ImfOutputFile.h
|
|||
include/OpenEXR/ImfPixelType.h
|
||||
include/OpenEXR/ImfPreviewImage.h
|
||||
include/OpenEXR/ImfPreviewImageAttribute.h
|
||||
include/OpenEXR/ImfRational.h
|
||||
include/OpenEXR/ImfRationalAttribute.h
|
||||
include/OpenEXR/ImfRgba.h
|
||||
include/OpenEXR/ImfRgbaFile.h
|
||||
include/OpenEXR/ImfRgbaYca.h
|
||||
|
@ -95,16 +61,12 @@ include/OpenEXR/ImfVersion.h
|
|||
include/OpenEXR/ImfWav.h
|
||||
include/OpenEXR/ImfXdr.h
|
||||
include/OpenEXR/OpenEXRConfig.h
|
||||
include/OpenEXR/half.h
|
||||
include/OpenEXR/halfFunction.h
|
||||
include/OpenEXR/halfLimits.h
|
||||
lib/libHalf.la
|
||||
lib/libIex.la
|
||||
lib/libIlmImf.la
|
||||
lib/libIlmThread.la
|
||||
lib/libImath.la
|
||||
lib/pkgconfig/OpenEXR.pc
|
||||
share/aclocal/openexr.m4
|
||||
share/doc/OpenEXR-${PKGVERSION}/OpenEXRFileLayout.pdf
|
||||
share/doc/OpenEXR-${PKGVERSION}/ReadingAndWritingImageFiles.pdf
|
||||
share/doc/OpenEXR-${PKGVERSION}/TechnicalIntroduction.pdf
|
||||
share/doc/OpenEXR-${PKGVERSION}/examples/drawImage.cpp
|
||||
share/doc/OpenEXR-${PKGVERSION}/examples/drawImage.h
|
||||
share/doc/OpenEXR-${PKGVERSION}/examples/generalInterfaceExamples.cpp
|
||||
|
@ -122,4 +84,3 @@ share/doc/OpenEXR-${PKGVERSION}/examples/rgbaInterfaceTiledExamples.cpp
|
|||
share/doc/OpenEXR-${PKGVERSION}/examples/rgbaInterfaceTiledExamples.h
|
||||
@dirrm share/doc/OpenEXR-${PKGVERSION}/examples
|
||||
@dirrm share/doc/OpenEXR-${PKGVERSION}
|
||||
@dirrm include/OpenEXR
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.8 2006/10/29 13:51:18 dsainty Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.9 2007/11/30 21:52:17 wiz Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
OPENEXR_BUILDLINK3_MK:= ${OPENEXR_BUILDLINK3_MK}+
|
||||
|
@ -12,13 +12,13 @@ BUILDLINK_PACKAGES+= openexr
|
|||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}openexr
|
||||
|
||||
.if !empty(OPENEXR_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_API_DEPENDS.openexr+= openexr>=1.2.1
|
||||
BUILDLINK_ABI_DEPENDS.openexr+= openexr>=1.2.2nb1
|
||||
BUILDLINK_API_DEPENDS.openexr+= openexr>=1.6.1
|
||||
BUILDLINK_PKGSRCDIR.openexr?= ../../graphics/openexr
|
||||
|
||||
PTHREAD_OPTS+= require
|
||||
.endif # OPENEXR_BUILDLINK3_MK
|
||||
|
||||
.include "../../graphics/ilmbase/buildlink3.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.8 2007/01/11 19:03:05 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.9 2007/11/30 21:52:18 wiz Exp $
|
||||
|
||||
SHA1 (openexr-1.4.0a.tar.gz) = d7f2188b677ea28cafb104f2ace6c0f50b5aadee
|
||||
RMD160 (openexr-1.4.0a.tar.gz) = 74e43977c88fc9a3d7c74bcd808a477489dad8c2
|
||||
Size (openexr-1.4.0a.tar.gz) = 9673041 bytes
|
||||
SHA1 (openexr-1.6.1.tar.gz) = b3650e6542f0e09daadb2d467425530bc8eec333
|
||||
RMD160 (openexr-1.6.1.tar.gz) = 3670633be841628e9d4c11981661e9d94a9b2711
|
||||
Size (openexr-1.6.1.tar.gz) = 13632660 bytes
|
||||
SHA1 (patch-aa) = 5c4a5ae3440e49a774dd7056f3b93d78e1f6528a
|
||||
SHA1 (patch-ab) = af6a9601b68e8cab51de75f6d1a05476fdfa3b87
|
||||
SHA1 (patch-ac) = 8fb11127c0449fd1a7748768eda560d1d02056a8
|
||||
|
|
13
graphics/openexr/patches/patch-aa
Normal file
13
graphics/openexr/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.4 2007/11/30 21:52:20 wiz Exp $
|
||||
|
||||
--- configure.orig 2007-11-30 19:18:05.000000000 +0000
|
||||
+++ configure
|
||||
@@ -19595,7 +19595,7 @@ else
|
||||
multithread=yes
|
||||
fi;
|
||||
|
||||
-if test x$PKG_CONFIG == xno && test "x${multithread}" != xno ; then
|
||||
+if test x$PKG_CONFIG = xno && test "x${multithread}" != xno ; then
|
||||
|
||||
|
||||
|
|
@ -1,48 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2007/01/11 19:03:05 drochner Exp $
|
||||
|
||||
--- exrdisplay/Makefile.in.orig 2006-08-09 07:45:52.000000000 +0200
|
||||
+++ exrdisplay/Makefile.in
|
||||
@@ -60,12 +60,12 @@ am_exrdisplay_OBJECTS = main.$(OBJEXT) I
|
||||
$(am__objects_1) loadImage.$(OBJEXT) scaleImage.$(OBJEXT)
|
||||
exrdisplay_OBJECTS = $(am_exrdisplay_OBJECTS)
|
||||
exrdisplay_LDADD = $(LDADD)
|
||||
-@HAVE_FLTK_TRUE@exrdisplay_DEPENDENCIES = \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/Iex/libIex.la \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/Half/libHalf.la \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/Imath/libImath.la \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/IlmImf/libIlmImf.la \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/IlmThread/libIlmThread.la
|
||||
+#@HAVE_FLTK_TRUE@exrdisplay_DEPENDENCIES = \
|
||||
+#@HAVE_FLTK_TRUE@ $(top_builddir)/Iex/libIex.la \
|
||||
+#@HAVE_FLTK_TRUE@ $(top_builddir)/Half/libHalf.la \
|
||||
+#@HAVE_FLTK_TRUE@ $(top_builddir)/Imath/libImath.la \
|
||||
+#@HAVE_FLTK_TRUE@ $(top_builddir)/IlmImf/libIlmImf.la \
|
||||
+#@HAVE_FLTK_TRUE@ $(top_builddir)/IlmThread/libIlmThread.la
|
||||
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/config
|
||||
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
||||
am__depfiles_maybe = depfiles
|
||||
@@ -210,16 +210,16 @@ sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-@HAVE_FLTK_TRUE@INCLUDES = @GL_CXXFLAGS@ @CG_CXXFLAGS@ @FLTK_CXXFLAGS@ -I$(top_builddir) \
|
||||
-@HAVE_FLTK_TRUE@ -I$(top_srcdir)/Iex -I$(top_srcdir)/Half -I$(top_srcdir)/Imath \
|
||||
-@HAVE_FLTK_TRUE@ -I$(top_srcdir)/IlmImf -I$(top_srcdir)/config
|
||||
+@HAVE_FLTK_TRUE@INCLUDES = @GL_CXXFLAGS@ @CG_CXXFLAGS@ @FLTK_CXXFLAGS@ -I$(top_builddir) -I$(prefix)/include/OpenEXR
|
||||
+#@HAVE_FLTK_TRUE@ -I$(top_srcdir)/Iex -I$(top_srcdir)/Half -I$(top_srcdir)/Imath \
|
||||
+#@HAVE_FLTK_TRUE@ -I$(top_srcdir)/IlmImf -I$(top_srcdir)/config
|
||||
|
||||
@HAVE_FLTK_TRUE@LDADD = @CG_LDFLAGS@ @FLTK_LDFLAGS@ \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/Iex/libIex.la \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/Half/libHalf.la \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/Imath/libImath.la \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/IlmImf/libIlmImf.la \
|
||||
-@HAVE_FLTK_TRUE@ $(top_builddir)/IlmThread/libIlmThread.la \
|
||||
+@HAVE_FLTK_TRUE@ -lIex \
|
||||
+@HAVE_FLTK_TRUE@ -lHalf \
|
||||
+@HAVE_FLTK_TRUE@ -lImath \
|
||||
+@HAVE_FLTK_TRUE@ -lIlmImf \
|
||||
+@HAVE_FLTK_TRUE@ -lIlmThread \
|
||||
@HAVE_FLTK_TRUE@ -lz
|
||||
|
||||
@HAVE_CG_FALSE@fragshader_sources =
|
Loading…
Reference in a new issue