games/sdlpop: update to sdlpop-1.22
Changelog: 2021 July 5 ================= (version 1.22) FIXED: The prince can now grab a ledge at the bottom right corner of a room with no room below. Details: https://forum.princed.org/viewtopic.php?p=30410#p30410 Testcase: doc/replays-testcases/SNES-PC-set level 11.p1r See FIX_CORNER_GRAB in config.h . FIXED: Don't allow killing a skeleton in cheat mode. FIXED: Ctrl+S didn't mute music (except death music). FIXED: A falling tile on the left side of a pillar could cause the blue stripe to be drawn over the pillar. FIXED: The top of moving gates became glitched on levels using non-default palettes. FIXED: The right edge of pressed drop buttons was black if a big pillar was next to them. FIXED: Guards appeared in the current room when they fell into spikes in an adjacent room. (Example: original level 11, room 22.) FIXED: Show an error message if a data file is missing. FIXED: "Remember guard hp" for non-standard guards. FIXED: Colored torches were not restored on quickload if you (quit and) restarted the game after quicksave. DONE: Added command-line parameter "mute": Start the game with sound off. FIXED: Fixed compiling with some features #undefined. (USE_TEXT, USE_LIGHTING, USE_MENU) DONE: Hide references to various features if the game was compiled without them. DONE: A scrollbar appears in the pause menu if scrolling is possible. It's not clickable yet, it just shows where you are in the list. DONE: Added command-line parameter "playdemo": Make the demo level playable. FIXED: Fixed the detection of Ctrl+L during the demo level. FIXED: Create the screenshots directory in SDLPoP's directory, even if the current directory is something else. This is to match how the replay folder works. FIXED: On Windows, use Unicode/UTF-8 for mkdir(). So the replay and screenshots directories can be created within non-ASCII paths. FIXED: After quickload, show the room where the prince is, even if the player moved the view away from it (with the H,J,U,N keys). FIXED: After quickload, don't draw guard HP if a previously viewed room (with the H,J,U,N keys) had a guard but the current room doesn't have one. DONE: Speed up music, sounds, and transitions during fast forwarding. FIXED: Prevent the modifier remapping from accessing out-of-range rooms. FIXED: Don't show the mirror image if the prince is not in the currently shown room. DONE: Added a new cheat key: Ctrl+B: Go back to the room where the prince is. (Undo H,J,U,N.) FIXED: Fixed the length of feather fall in fast-forward mode. FIXED: Prevent torches from being randomly colored when an older replay is loaded. FIXED: If the prince is fighting a guard, and the player does a quickload to a state where the prince is near the mouse, the prince would draw the sword. DONE: Added options for changing speeds. They are detected from PRINCE.EXE. (Used in Hurry up Prince, for example.) DONE: In the settings menu, allow using Page Up, Page Down, Home, End. FIXED: Fixed graphical glitches with an opening gate: 1. with a loose floor above and a wall above-right. 2. with the top half of a big pillar above-right. See FIX_ABOVE_GATE in config.h . FIXED: Validate mode crashed with the error "init_scaling: SDL_CreateTexture: Invalid renderer". DONE: Rewrote all mentions of key combinations to the "Ctrl+A" style. DONE: Marked which features of SDLPoP are not in the original game. (To prevent confusions like #197) DONE: Allow Backspace and Ctrl+C during replay. DONE: During playback, display the number of ticks since start, if the timer is shown (debug cheats: T). FIXED: Fixed crashing when a MIDI music interrupted another one. FIXED: Make it possible to go through a certain closed gate on level 11 of Demo by Suave Prince. Details: https://forum.princed.org/viewtopic.php?p=32326#p32326 Testcase: doc/replays-testcases/Demo by Suave Prince level 11.p1r See FIX_COLL_FLAGS in config.h . FIXED: When the prince jumps up at the bottom of a big pillar split between two rooms, a part near the top of the screen disappears. Example: The top row in the first room of the original level 5. Details: See FIX_BIGPILLAR_JUMP_UP in config.h . DONE: Added a debug cheat to quickload but keep the currently loaded level. (Shift+F9) Motivation: https://forum.princed.org/viewtopic.php?p=32556#p32556 FIXED: Fixed spiked/chomped/bumped guards teleporting into the wrong room. (if fixes are enabled) Details: https://github.com/NagyD/SDLPoP/pull/237 FIXED: Quicksave during feather fall mode. (if fixes are enabled) Details: https://github.com/NagyD/SDLPoP/pull/236 FIXED: Prevent the prince from entering a glitched room when he falls into a wall or he is revived near a wall. Details: doc/replays-testcases/Original level 2 falling into wall.txt Testcase: doc/replays-testcases/Original level 2 falling into wall.p1r See FIX_ENTERING_GLITCHED_ROOMS in config.h . FIXED: Optimized OPL mixing (MIDI music). Details: https://github.com/NagyD/SDLPoP/pull/238 "More importantly: when run on a Raspberry Pi Zero, the music went from unusable to perfect," FIXED: Fixed the prince sliding through closed gates when you are using the caped prince graphics. Details: See FIX_CAPED_PRINCE_SLIDING_THROUGH_GATE in config.h . DONE: Added a compilation-time flag to disable all fixes for vanilla execution. Details: https://github.com/NagyD/SDLPoP/pull/239 FIXED: If the prince dies on level 14, don't return to the intro after the level was restarted. Details: See FIX_LEVEL_14_RESTARTING in config.h . DONE: Waste an RNG cycle in loose_shake() to match DOS PoP. DONE: In new replays, use deprecation_number = 2. On playback, waste the RNG cycle only if deprecation_number >= 2. Older replays have deprecation_number <= 1, and we don't waste the RNG cycle when playing them back. DONE: When backing offscreen (to the left) from the first guard on level 7 (among others), simulate the glitch from DOS PoP, which causes the prince to fall through the floor. Details: See https://github.com/NagyD/SDLPoP/issues/229 FIXED: On Windows, use Unicode/UTF-8 for stat(). So SDLPoP can load levels from mod folders when a replay file restarts the level or advances to the next level. DONE: Added a more visible error message when a mod referenced by a replay file cannot be found in the mods folder. DONE: Allow guard skill customizations in SDLPoP.ini. DONE: Made FIX_DOORTOP_DISABLING_GUARD configurable.
This commit is contained in:
parent
4d1bd4e572
commit
81d54ad809
4 changed files with 14 additions and 41 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.4 2020/11/24 14:30:31 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2021/07/21 09:19:51 yhardy Exp $
|
||||
|
||||
DISTNAME= sdlpop-1.21
|
||||
DISTNAME= sdlpop-1.22
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=NagyD/}
|
||||
GITHUB_PROJECT= SDLPoP
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2019/11/02 14:35:37 nia Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2021/07/21 09:19:51 yhardy Exp $
|
||||
bin/prince
|
||||
share/applications/prince.desktop
|
||||
share/doc/sdlpop/ChangeLog.txt
|
||||
|
@ -1029,31 +1029,5 @@ share/sdlpop/data/font/res1129.png
|
|||
share/sdlpop/data/font/res1130.png
|
||||
share/sdlpop/data/font/res1131.png
|
||||
share/sdlpop/data/icon.png
|
||||
share/sdlpop/data/levels-original/res2000.bin
|
||||
share/sdlpop/data/levels-original/res2001.bin
|
||||
share/sdlpop/data/levels-original/res2002.bin
|
||||
share/sdlpop/data/levels-original/res2003.bin
|
||||
share/sdlpop/data/levels-original/res2004.bin
|
||||
share/sdlpop/data/levels-original/res2005.bin
|
||||
share/sdlpop/data/levels-original/res2006.bin
|
||||
share/sdlpop/data/levels-original/res2007.bin
|
||||
share/sdlpop/data/levels-original/res2008.bin
|
||||
share/sdlpop/data/levels-original/res2009.bin
|
||||
share/sdlpop/data/levels-original/res2010.bin
|
||||
share/sdlpop/data/levels-original/res2011.bin
|
||||
share/sdlpop/data/levels-original/res2012.bin
|
||||
share/sdlpop/data/levels-original/res2013.bin
|
||||
share/sdlpop/data/levels-original/res2014.bin
|
||||
share/sdlpop/data/levels-original/res2015.bin
|
||||
share/sdlpop/data/levels-test/01-micro-room-change
|
||||
share/sdlpop/data/levels-test/01-weird-room-change
|
||||
share/sdlpop/data/levels-test/02-bigpillar-climb
|
||||
share/sdlpop/data/levels-test/02-guard-following
|
||||
share/sdlpop/data/levels-test/02-random-broken
|
||||
share/sdlpop/data/levels-test/02-walls
|
||||
share/sdlpop/data/levels-test/04-through-tapestry
|
||||
share/sdlpop/data/levels-test/05-stacked-gates
|
||||
share/sdlpop/data/levels-test/07-jump
|
||||
share/sdlpop/data/levels-test/12-shadow
|
||||
share/sdlpop/data/light.png
|
||||
share/sdlpop/data/music/names.txt
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.2 2020/11/24 14:30:31 nia Exp $
|
||||
$NetBSD: distinfo,v 1.3 2021/07/21 09:19:51 yhardy Exp $
|
||||
|
||||
SHA1 (sdlpop-1.21.tar.gz) = 67992d991cf0f8708a71ee30df7eca04be86057b
|
||||
RMD160 (sdlpop-1.21.tar.gz) = 651809d533f468bf33e7994c905cd2b82cb39dc0
|
||||
SHA512 (sdlpop-1.21.tar.gz) = 64aa5156122ef5363ae6d61e204141ebd2359f9d230f7411a579ec6e90de93e95a7d7836252464b6730a0b85d84ab1570a6050739ada7d9e60f2f966d92afcca
|
||||
Size (sdlpop-1.21.tar.gz) = 627853 bytes
|
||||
SHA1 (sdlpop-1.22.tar.gz) = 3b7ef7b0a887705f9d981536db544d0ec3e81534
|
||||
RMD160 (sdlpop-1.22.tar.gz) = 8b14edb801e5cfdd6dd48bf803dc5ebb73adbbd8
|
||||
SHA512 (sdlpop-1.22.tar.gz) = d25777066c7293742a61aa75bb7be2fc20bad6a2ca8f46918978396a53a25cca532f238d1f8d679021ecb353aadeec9a199791045ffc2b90ae7ee45a3e1041da
|
||||
Size (sdlpop-1.22.tar.gz) = 633128 bytes
|
||||
SHA1 (patch-options.c) = 26625a4ac6e2113d12b0169f2f69db0455912293
|
||||
SHA1 (patch-seg009.c) = 0ac07e6e004cb3fd4061c72b4bc3358456f0131c
|
||||
SHA1 (patch-src_Makefile) = 68ed7dbe90ff231a1e2e00b10fb3691b042445eb
|
||||
SHA1 (patch-seg009.c) = 9353396d934e9913745c8c9e49473d9b84563266
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: patch-seg009.c,v 1.1 2019/11/02 14:35:37 nia Exp $
|
||||
$NetBSD: patch-seg009.c,v 1.2 2021/07/21 09:19:51 yhardy Exp $
|
||||
|
||||
Use installed data path.
|
||||
Disable rumble/haptic support.
|
||||
|
||||
--- src/seg009.c.orig 2018-03-17 16:33:14.000000000 +0000
|
||||
--- src/seg009.c.orig 2021-07-05 06:42:34.000000000 +0000
|
||||
+++ src/seg009.c
|
||||
@@ -34,8 +34,8 @@ void sdlperror(const char* header) {
|
||||
@@ -37,8 +37,8 @@ void sdlperror(const char* header) {
|
||||
//quit(1);
|
||||
}
|
||||
|
||||
|
@ -16,12 +16,12 @@ Disable rumble/haptic support.
|
|||
|
||||
void find_exe_dir() {
|
||||
if (found_exe_dir) return;
|
||||
@@ -2108,7 +2108,7 @@ void __pascal far set_gr_mode(byte grmod
|
||||
@@ -2436,7 +2436,7 @@ void __pascal far set_gr_mode(byte grmod
|
||||
SDL_SetHint(SDL_HINT_WINDOWS_DISABLE_THREAD_NAMING, "1");
|
||||
#endif
|
||||
if (SDL_Init(SDL_INIT_VIDEO | SDL_INIT_TIMER | SDL_INIT_NOPARACHUTE |
|
||||
- SDL_INIT_GAMECONTROLLER | SDL_INIT_HAPTIC ) != 0) {
|
||||
+ SDL_INIT_GAMECONTROLLER ) != 0) {
|
||||
sdlperror("SDL_Init");
|
||||
sdlperror("set_gr_mode: SDL_Init");
|
||||
quit(1);
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue