luakit: update to 2.3.1

## [2.3.1]

### Added

- Added command `:userscripts-reload` to reload lua scripts.
- The tabgroup plugin is now included in luakit (:tabmenu).
- Allow configuration of shortcuts that should be passed through (https://github.com/luakit/luakit/pull/921).
- Added scalable SVG desktop icon version.

### Changed

- Allow functions to be bound to more than one key (https://github.com/luakit/luakit/issues/913).

### Fixed

- No more `gdk_keymap_get_default()` compiler warning.
- Fixed an issue where links were hinted, but then could be followed.
- Fixed the paging on the the bookmarks page.
- Fixed build on Solaris.
- Fixed relocation errors on Sparc64.
- Fixed proxymenu to show default entries when proxymenu file is not present.
- The command mode cursor is now drawn in the user-specified foreground color.
This commit is contained in:
nia 2022-11-15 22:48:32 +00:00
parent f00a640199
commit 81ea832fa6
4 changed files with 19 additions and 15 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.14 2022/08/11 05:09:23 gutteridge Exp $
# $NetBSD: Makefile,v 1.15 2022/11/15 22:48:32 nia Exp $
DISTNAME= luakit-2.3
PKGREVISION= 5
DISTNAME= luakit-2.3.1
CATEGORIES= www lua
MASTER_SITES= ${MASTER_SITE_GITHUB:=luakit/}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2021/03/15 11:17:18 nia Exp $
@comment $NetBSD: PLIST,v 1.3 2022/11/15 22:48:32 nia Exp $
bin/luakit
lib/luakit/luakit.so
man/man1/luakit.1
@ -80,6 +80,7 @@ share/doc/luakit/modules/lousy.widget.ssl.html
share/doc/luakit/modules/lousy.widget.tab.html
share/doc/luakit/modules/lousy.widget.tabi.html
share/doc/luakit/modules/lousy.widget.tablist.html
share/doc/luakit/modules/lousy.widget.tgname.html
share/doc/luakit/modules/lousy.widget.uri.html
share/doc/luakit/modules/lousy.widget.zoom.html
share/doc/luakit/modules/luakit.html
@ -102,6 +103,7 @@ share/doc/luakit/modules/settings_chrome.html
share/doc/luakit/modules/soup.html
share/doc/luakit/modules/styles.html
share/doc/luakit/modules/tab_favicons.html
share/doc/luakit/modules/tabgroups.html
share/doc/luakit/modules/tabhistory.html
share/doc/luakit/modules/tabmenu.html
share/doc/luakit/modules/taborder.html
@ -183,6 +185,7 @@ share/luakit/lib/lousy/widget/ssl.lua
share/luakit/lib/lousy/widget/tab.lua
share/luakit/lib/lousy/widget/tabi.lua
share/luakit/lib/lousy/widget/tablist.lua
share/luakit/lib/lousy/widget/tgname.lua
share/luakit/lib/lousy/widget/uri.lua
share/luakit/lib/lousy/widget/zoom.lua
share/luakit/lib/markdown.lua
@ -202,6 +205,7 @@ share/luakit/lib/settings.lua
share/luakit/lib/settings_chrome.lua
share/luakit/lib/styles.lua
share/luakit/lib/tab_favicons.lua
share/luakit/lib/tabgroups.lua
share/luakit/lib/tabhistory.lua
share/luakit/lib/tabmenu.lua
share/luakit/lib/taborder.lua
@ -229,3 +233,4 @@ share/luakit/resources/icons/tab-icon-private@2x.png
share/luakit/resources/icons/tab-icon-security-error.png
share/luakit/resources/icons/tab-icon-security-error@2x.png
share/pixmaps/luakit.png
share/pixmaps/luakit.svg

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.5 2021/10/26 11:29:38 nia Exp $
$NetBSD: distinfo,v 1.6 2022/11/15 22:48:32 nia Exp $
BLAKE2s (luakit-2.3.tar.gz) = 3928eec7f5ac0313e0b3187ed71ddb750428d97d2bfd165cb564a8abbb0d25ca
SHA512 (luakit-2.3.tar.gz) = f41121e1c47c020d90fe69f858b8c348f5c3ad752891abf2b94e5b44eebe3d5c8c315342c9aa4c53bbaef548f6ef2a1d0c522d877f0a20516734755967c0bb5c
Size (luakit-2.3.tar.gz) = 497471 bytes
SHA1 (patch-Makefile) = 8510a1de1c99244ce1f8cb925439921381692f3d
BLAKE2s (luakit-2.3.1.tar.gz) = e036c47070de587024aa69df4b98f3d1b5bb9833385be2b409bc5444f3ea1d5e
SHA512 (luakit-2.3.1.tar.gz) = 73d389f7e5a11f88905957c11aab085c9d33a2d0b276e22b89ae689cabe9cff0a18a003d23548fbc4378a695379cdb223a313328372c84bb74da605855e4a9e3
Size (luakit-2.3.1.tar.gz) = 506988 bytes
SHA1 (patch-Makefile) = f4a25f2ea39c9a94cb5fbdb7b02f81c22a6e0a32

View file

@ -1,17 +1,17 @@
$NetBSD: patch-Makefile,v 1.1 2020/08/09 17:25:37 nia Exp $
$NetBSD: patch-Makefile,v 1.2 2022/11/15 22:48:32 nia Exp $
Install config files to examples.
--- Makefile.orig 2018-11-16 08:12:24.000000000 +0000
--- Makefile.orig 2022-08-30 15:17:46.000000000 +0000
+++ Makefile
@@ -108,8 +108,8 @@ install: all
install -m644 luakit.so $(DESTDIR)$(PREFIX)/lib/luakit/luakit.so
@@ -110,8 +110,8 @@ install: all
install -m644 luakit.so $(DESTDIR)$(LIBDIR)/luakit.so
install -d $(DESTDIR)$(PREFIX)/bin
install luakit $(DESTDIR)$(PREFIX)/bin/luakit
- install -d $(DESTDIR)$(XDGPREFIX)/luakit/
- install -m644 config/*.lua $(DESTDIR)$(XDGPREFIX)/luakit/
+ install -d $(DESTDIR)$(PREFIX)/share/examples/luakit/
+ install -m644 config/*.lua $(DESTDIR)$(PREFIX)/share/examples/luakit/
+ install -m644 config/*.lua $(DESTDIR)$(PREFIX)/share/examples/luakit
install -d $(DESTDIR)$(PIXMAPDIR)
install -m644 extras/luakit.png $(DESTDIR)$(PIXMAPDIR)
install -d $(DESTDIR)$(APPDIR)
install -m644 extras/luakit.svg $(DESTDIR)$(PIXMAPDIR)