Fix detection of non-mime messages when the charset is not enclosed

in double quotes.  Without this fix text/plain messages authored on
Mozilla will always get displayed using showmimeproc (mhl).
This commit is contained in:
kim 2002-10-30 16:57:02 +00:00
parent 01b245d92c
commit 82283c04e1
3 changed files with 20 additions and 3 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.48 2002/10/15 10:47:00 agc Exp $
# $NetBSD: Makefile,v 1.49 2002/10/30 16:57:02 kim Exp $
# FreeBSD Id: Makefile,v 1.2 1997/08/04 06:51:28 markm Exp
#
DISTNAME= nmh-1.0.4
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= mail
MASTER_SITES= ftp://ftp.mhost.com/pub/nmh/ \
ftp://ftp.gw.com/pub/unix/mail/mh/nmh/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2002/10/15 10:47:00 agc Exp $
$NetBSD: distinfo,v 1.6 2002/10/30 16:57:02 kim Exp $
SHA1 (nmh-1.0.4.tar.gz) = 71441a884d898db2fd9184a92e663682536425f5
Size (nmh-1.0.4.tar.gz) = 683215 bytes
@ -6,3 +6,4 @@ SHA1 (patch-ca) = 43aaf15dc5d07de03ff912894d7128d03eb1889d
SHA1 (patch-cb) = 6e498988c08e393fdd4e8e27f2ff6ce457e2c803
SHA1 (patch-cd) = 13901025ef3a1b7fc07d0c13f8e1aef3e9bee2d6
SHA1 (patch-ce) = b93b07c3ee82e6ab8599f362e14ad2dbe1955325
SHA1 (patch-ci) = 98f1c80281656d05c460bdb237de3efbf80b9e32

16
mail/nmh/patches/patch-ci Normal file
View file

@ -0,0 +1,16 @@
$NetBSD: patch-ci,v 1.1 2002/10/30 16:57:03 kim Exp $
Fix detection of non-mime messages when the charset is not enclosed
in double quotes.
--- uip/show.c.orig Sun Sep 12 09:50:12 1999
+++ uip/show.c Wed Oct 30 11:42:42 2002
@@ -470,7 +470,7 @@
*bp = '\0';
} else {
for (bp = dp; *bp; bp++)
- if (isspace (*bp)) {
+ if (!istoken (*bp)) {
*bp = '\0';
break;
}