Update eggdrop to 1.6.18.

While here, fixes PR 30307, ipv6 option isn't supported since version 1.6.16.

  1.6.18 (09 July 2006)
    * Look for Tcl in /lib64 and /usr/lib64.
    * Patch by: Kuja

    + RC1 released on April 3rd, 2006.

    * Fixed a type conversion problem in snprintf.c causing Eggdrop to not
      compile on OSF1.
    * Found by: Joker - Patch by: Wcc

    - Detect NetBSD Tcl in /usr/pkg/lib and /usr/pkg/include.
    * Found by: mish - Patch by: Wcc

    - Fixed possibility of referencing a NULL pointer in rembot().
    - Added a missing param cast for dcc_table.timeout.
    - Fixed a memleak / other nasty stuff when MODES_PER_LINE_MAX != 6.
    - Fixed putlog() of an uninitialized (and incorrect) variable in
      dcc_telnet_hostresolved().
    * Patch by: lordares

    - Valgrind doesn't bitch about init_uptime() now.
    * Patch by: Wcc

    - Dns.mod should compile on Mac OS X now. Thanks to Netscrape @ EFNet for
      testing.
    * Found by: various - Patch by: Wcc

    - Corrected nat-ip setting documentation.
    * Found by: BarkerJr - Patch by: Wcc

    - Don't allow realname to be blank or whitespace.
    * Found by: Jesse M - Patch by: BarkerJr / Wcc

    - Fixed an error in channel get. You can now, correctly, do a channel
      get #channel stopnethack-mode.
    * Found by: Chris Northwood - Patch by: Wcc

    - The pushmode command should work properly for bans now.
    * Patch by: thommey

    - Apparently we broke lastbind.
    * Found by: bUrN - Patch by: thommey

    - Request topic on channel reset.
    * Found by: De Kus - Patch by: Darko

    - Fixed a situation where noshare could be set to 1 and never
      restored.
    * Patch by: lordares

    - Fixed a socklist leak in net.c.
    * Patch by: lordares

    - Hopefully fixed dns lockups.
    * Found by: various - Patch by: Sven Trenkel

    - Fixed remote note bug in add_note() that was introduced in 1.6.17.
      Fixes Bugzilla Bug # 433 "Remote Notes Always Say User is Offline"
    * Found by: alex323 - Patch by: Tothwolf

    - Completely rewrote check_tcl_bind().
    - Added inline check_bind_flags() for flag checking for check_tcl_bind().
    - Added inline check_bind_match() for match checking for check_tcl_bind().
    - Rewrote trigger_bind() and made it inline for check_tcl_bind().
    - Fixed pointless calling of nmalloc() and nfree() for ContextNote
      in trigger_bind() when DEBUG_CONTEXT isn't defined.
    - Moved findidx() from tcl.c to dccutil.c.
    - Moved findanyidx() from tclhash.c to dccutil.c.
    - Moved CHECKVALIDITY from tclhash.h to tclegg.h.
    - Added CHECKVALIDITY checks to builtin_dcc() and builtin_fil().
    - Moved CMD_LEAVE from cmdt.h to tclegg.h.
    - Changed NULL to CMD_LEAVE for partyline quit in cmds.c.
    - Renamed BIND_EXEC_BRK to BIND_QUIT.
    - Fixed misc typos.
    * Patch by: Tothwolf

    - Added support to MSGM, PUBM, NOTC, and WALL binds to support bound
      procs returning 1 to prevent logging of the trigger message text.
      Fixes Bugzilla Bug # 334 "msgm bind return values"
    - Added BIND_STACKRET bit mask and support for stacked bind return values
      to check_tcl_bind(). This allows check_tcl_bind() to check if any
      stacked bound procs return 1 while allowing all matching stacked binds
      to be processed. Previously if BIND_WANTRET was used to check the
      return value of stacked binds, only the first match would be triggered.
    - Modified irc.mod gotmsg() function to trigger PUBM binds before
      triggering PUB binds. MSGM and MSG binds already worked this way.
    - Modified irc.mod gotmsg() function to allow a message to trigger both
      PUBM and PUB binds. Previously if a message triggered a PUB bind, any
      PUBM binds that might match the message text would not be triggered.
      Fixes Bugzilla Bug # 351 "bind pub hogs pubm"
    - Added exclusive-binds setting and code to gotmsg() functions to
      allow MSGM and PUBM binds to be exclusive of MSG and PUB binds.
    - Fixed logging for WALL bind. It had been broken since it was
      originally implemented in eggdrop-hayes. Wallops messages were always
      logged regardless of the return value of a bound proc. Returning '1'
      from a bound proc now causes Eggdrop to not log the Wallops message.
    * Patch by: Tothwolf

    - Check for Tcl 8.5 before older versions.
    * Patch by: Tothwolf

    - Use flagrec_eq() instead of flagrec_ok() in help_subst()
      since lower flags are automatically added now.
    * Patch by: Tothwolf

    - Check for bot's nick and user@host earlier in detect_flood()
      and detect_chan_flood().
    * Patch by: Tothwolf

    - Allow wildcard matching and stacking for note binds.
    * Patch by: Tothwolf

    - Use CHANMETA to define valid channel prefixes in gotmsg().
    * Found by: zathras3 at hotmail.com - Patch by: Wcc

    - Fix for problems created when loading long user-defined channel setting
      names from the channel file.
    * Patch by: Stream

    - Help file update related to sharing.
    * Patch by: Shawn888, slennox

    - Fix for randint() on Solaris / SunOS.
    * Patch by: Mikael Hedberg

    - Updated Copyright Dates.
    * Patch by: Paladin

    - Fixed 3 invalid reads in notes.c.
    * Patch by: rush at winkey.oompah.org

    - Corrected a few of the error messages in neterror().
    * Found by: Steven Nikkel - Patch by: Wcc

    - Corrected the order of our search paths for Tcl. This should help stop
      version mismatches between the headers and libraries.
    * Patch by: CoderX2
This commit is contained in:
obache 2007-10-18 09:15:33 +00:00
parent d350f3ddb1
commit 8236cb3e47
9 changed files with 83 additions and 99 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.27 2007/09/07 22:12:10 jlam Exp $ # $NetBSD: Makefile,v 1.28 2007/10/18 09:15:33 obache Exp $
DISTNAME= eggdrop1.6.17 DISTNAME= eggdrop1.6.18
PKGNAME= eggdrop-1.6.17 PKGNAME= eggdrop-1.6.18
PKGREVISION= 1
CATEGORIES= chat CATEGORIES= chat
MASTER_SITES= ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/ MASTER_SITES= ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/
EXTRACT_SUFX= .tar.bz2 EXTRACT_SUFX= .tar.bz2
@ -15,18 +14,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q} CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ENV+= TCLLIB="${PREFIX}/lib" TCLINC="${PREFIX}/include" CONFIGURE_ENV+= TCLLIB="${PREFIX}/lib" TCLINC="${PREFIX}/include"
PKG_OPTIONS_VAR= PKG_OPTIONS.eggdrop
PKG_SUPPORTED_OPTIONS= inet6
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Minet6)
CONFIGURE_ARGS+= --enable-ipv6
PLIST_SUBST+= NOIPV6="@comment "
.else
PLIST_SUBST+= NOIPV6=
.endif
EGDIR= ${PREFIX}/share/examples/eggdrop EGDIR= ${PREFIX}/share/examples/eggdrop
CONF_FILES= ${EGDIR}/eggdrop.conf ${PKG_SYSCONFDIR}/eggdrop.conf CONF_FILES= ${EGDIR}/eggdrop.conf ${PKG_SYSCONFDIR}/eggdrop.conf
@ -45,9 +32,9 @@ do-install-program:
${INSTALL_MAN} ${WRKSRC}/doc/man1/eggdrop.1 ${PREFIX}/${PKGMANDIR}/man1/ ${INSTALL_MAN} ${WRKSRC}/doc/man1/eggdrop.1 ${PREFIX}/${PKGMANDIR}/man1/
${INSTALL_DATA_DIR} ${EGDIR} ${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/eggdrop.conf.dist.new ${EGDIR}/eggdrop.conf ${INSTALL_DATA} ${WRKSRC}/eggdrop.conf.dist.new ${EGDIR}/eggdrop.conf
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/html/eggdrop ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/eggdrop/html
cd ${WRKSRC}/doc/html && ${INSTALL_DATA} *.html \ cd ${WRKSRC}/doc/html && ${INSTALL_DATA} *.html \
${PREFIX}/share/doc/html/eggdrop ${PREFIX}/share/doc/eggdrop/html
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/eggdrop ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/eggdrop
cd ${WRKSRC}/doc && ${INSTALL_DATA} BANS BOTNET FIRST-SCRIPT MODULES \ cd ${WRKSRC}/doc && ${INSTALL_DATA} BANS BOTNET FIRST-SCRIPT MODULES \
PARTYLINE USERS TRICKS TEXT-SUBSTITUTIONS tcl-commands.doc \ PARTYLINE USERS TRICKS TEXT-SUBSTITUTIONS tcl-commands.doc \
@ -81,12 +68,9 @@ do-install: do-install-modules
do-install-modules: do-install-modules:
${INSTALL_DATA_DIR} ${PREFIX}/lib/eggdrop ${INSTALL_DATA_DIR} ${PREFIX}/lib/eggdrop
cd ${WRKSRC} && ${INSTALL_DATA} assoc.so blowfish.so channels.so \ cd ${WRKSRC} && ${INSTALL_DATA} assoc.so blowfish.so channels.so \
compress.so console.so ctcp.so filesys.so irc.so notes.so \ compress.so console.so ctcp.so dns.so filesys.so irc.so notes.so \
seen.so server.so share.so transfer.so uptime.so wire.so \ seen.so server.so share.so transfer.so uptime.so wire.so \
${PREFIX}/lib/eggdrop ${PREFIX}/lib/eggdrop
.if empty(PKG_OPTIONS:Minet6)
cd ${WRKSRC} && ${INSTALL_DATA} dns.so ${PREFIX}/lib/eggdrop
.endif
cd ${WRKSRC}/src/mod && ${FIND} . -name "*.lang" -exec ${INSTALL_DATA} "{}" \ cd ${WRKSRC}/src/mod && ${FIND} . -name "*.lang" -exec ${INSTALL_DATA} "{}" \
${PREFIX}/share/eggdrop/language ";" ${PREFIX}/share/eggdrop/language ";"
.endif .endif

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2005/03/04 21:05:04 adrianp Exp $ @comment $NetBSD: PLIST,v 1.9 2007/10/18 09:15:33 obache Exp $
bin/eggdrop bin/eggdrop
${NOPIC}lib/eggdrop/assoc.so ${NOPIC}lib/eggdrop/assoc.so
${NOPIC}lib/eggdrop/blowfish.so ${NOPIC}lib/eggdrop/blowfish.so
@ -6,7 +6,7 @@ ${NOPIC}lib/eggdrop/channels.so
${NOPIC}lib/eggdrop/compress.so ${NOPIC}lib/eggdrop/compress.so
${NOPIC}lib/eggdrop/console.so ${NOPIC}lib/eggdrop/console.so
${NOPIC}lib/eggdrop/ctcp.so ${NOPIC}lib/eggdrop/ctcp.so
${NOIPV6}${NOPIC}lib/eggdrop/dns.so ${NOPIC}lib/eggdrop/dns.so
${NOPIC}lib/eggdrop/filesys.so ${NOPIC}lib/eggdrop/filesys.so
${NOPIC}lib/eggdrop/irc.so ${NOPIC}lib/eggdrop/irc.so
${NOPIC}lib/eggdrop/notes.so ${NOPIC}lib/eggdrop/notes.so
@ -26,43 +26,43 @@ share/doc/eggdrop/TEXT-SUBSTITUTIONS
share/doc/eggdrop/TRICKS share/doc/eggdrop/TRICKS
share/doc/eggdrop/USERS share/doc/eggdrop/USERS
share/doc/eggdrop/tcl-commands.doc share/doc/eggdrop/tcl-commands.doc
share/doc/html/eggdrop/about.html share/doc/eggdrop/html/about.html
share/doc/html/eggdrop/app-problems.html share/doc/eggdrop/html/app-problems.html
share/doc/html/eggdrop/app-textsub.html share/doc/eggdrop/html/app-textsub.html
share/doc/html/eggdrop/app-tricks.html share/doc/eggdrop/html/app-tricks.html
share/doc/html/eggdrop/app-weird.html share/doc/eggdrop/html/app-weird.html
share/doc/html/eggdrop/authors.html share/doc/eggdrop/html/authors.html
share/doc/html/eggdrop/bans.html share/doc/eggdrop/html/bans.html
share/doc/html/eggdrop/botnet.html share/doc/eggdrop/html/botnet.html
share/doc/html/eggdrop/compiling.html share/doc/eggdrop/html/compiling.html
share/doc/html/eggdrop/egg-core.html share/doc/eggdrop/html/egg-core.html
share/doc/html/eggdrop/faqs.html share/doc/eggdrop/html/faqs.html
share/doc/html/eggdrop/features.html share/doc/eggdrop/html/features.html
share/doc/html/eggdrop/index.html share/doc/eggdrop/html/index.html
share/doc/html/eggdrop/install.html share/doc/eggdrop/html/install.html
share/doc/html/eggdrop/mod-assoc.html share/doc/eggdrop/html/mod-assoc.html
share/doc/html/eggdrop/mod-blowfish.html share/doc/eggdrop/html/mod-blowfish.html
share/doc/html/eggdrop/mod-channels.html share/doc/eggdrop/html/mod-channels.html
share/doc/html/eggdrop/mod-compress.html share/doc/eggdrop/html/mod-compress.html
share/doc/html/eggdrop/mod-console.html share/doc/eggdrop/html/mod-console.html
share/doc/html/eggdrop/mod-ctcp.html share/doc/eggdrop/html/mod-ctcp.html
share/doc/html/eggdrop/mod-dns.html share/doc/eggdrop/html/mod-dns.html
share/doc/html/eggdrop/mod-filesys.html share/doc/eggdrop/html/mod-filesys.html
share/doc/html/eggdrop/mod-irc.html share/doc/eggdrop/html/mod-irc.html
share/doc/html/eggdrop/mod-notes.html share/doc/eggdrop/html/mod-notes.html
share/doc/html/eggdrop/mod-seen.html share/doc/eggdrop/html/mod-seen.html
share/doc/html/eggdrop/mod-server.html share/doc/eggdrop/html/mod-server.html
share/doc/html/eggdrop/mod-share.html share/doc/eggdrop/html/mod-share.html
share/doc/html/eggdrop/mod-uptime.html share/doc/eggdrop/html/mod-uptime.html
share/doc/html/eggdrop/mod-wire.html share/doc/eggdrop/html/mod-wire.html
share/doc/html/eggdrop/mod-woobie.html share/doc/eggdrop/html/mod-woobie.html
share/doc/html/eggdrop/news.html share/doc/eggdrop/html/news.html
share/doc/html/eggdrop/party.html share/doc/eggdrop/html/party.html
share/doc/html/eggdrop/patch-howto.html share/doc/eggdrop/html/patch-howto.html
share/doc/html/eggdrop/readme.html share/doc/eggdrop/html/readme.html
share/doc/html/eggdrop/starting.html share/doc/eggdrop/html/starting.html
share/doc/html/eggdrop/tcl-commands.html share/doc/eggdrop/html/tcl-commands.html
share/doc/html/eggdrop/users.html share/doc/eggdrop/html/users.html
share/eggdrop/help/cmds1.help share/eggdrop/help/cmds1.help
share/eggdrop/help/cmds2.help share/eggdrop/help/cmds2.help
share/eggdrop/help/core.help share/eggdrop/help/core.help
@ -125,6 +125,6 @@ share/examples/eggdrop/eggdrop.conf
@dirrm share/eggdrop/help/msg @dirrm share/eggdrop/help/msg
@dirrm share/eggdrop/help @dirrm share/eggdrop/help
@dirrm share/eggdrop @dirrm share/eggdrop
@dirrm share/doc/html/eggdrop @dirrm share/doc/eggdrop/html
@dirrm share/doc/eggdrop @dirrm share/doc/eggdrop
${NOPIC}@dirrm lib/eggdrop ${NOPIC}@dirrm lib/eggdrop

View file

@ -1,17 +1,17 @@
$NetBSD: distinfo,v 1.11 2007/05/22 16:47:04 lkundrak Exp $ $NetBSD: distinfo,v 1.12 2007/10/18 09:15:33 obache Exp $
SHA1 (eggdrop1.6.17.tar.bz2) = 0e8a0b5506dde4a99f2be9f0700d6da65f54357f SHA1 (eggdrop1.6.18.tar.bz2) = a5c27578324ad718e224248dc54dfd268df9f71e
RMD160 (eggdrop1.6.17.tar.bz2) = 206d6d055b8efa66fde4a79c4cb3eacc4418ff01 RMD160 (eggdrop1.6.18.tar.bz2) = 06480616c23bff2b1209e03b5e25b55818c4b195
Size (eggdrop1.6.17.tar.bz2) = 805376 bytes Size (eggdrop1.6.18.tar.bz2) = 783676 bytes
SHA1 (patch-aa) = 9bb4623118081cd7a0a0a17edea3611e2d62d713 SHA1 (patch-aa) = 86b4795f28893d52e98bdea1b177e67d7cde05d6
SHA1 (patch-ab) = ac7aa4b3cb32e53b7e6abe828191afe153a1bbb1 SHA1 (patch-ab) = ac7aa4b3cb32e53b7e6abe828191afe153a1bbb1
SHA1 (patch-ac) = c71d67618a5b53a3de2f3041ed8fa098a89e4471 SHA1 (patch-ac) = c71d67618a5b53a3de2f3041ed8fa098a89e4471
SHA1 (patch-ad) = eaa3d342f47e0f3060dd29b6d64ef1f984eda6a8 SHA1 (patch-ad) = b3a8014bd664a22ec8c62d006ee02884df616a35
SHA1 (patch-ae) = bdbb616282b7dc643182a35c606401850b33fdca SHA1 (patch-ae) = bdbb616282b7dc643182a35c606401850b33fdca
SHA1 (patch-af) = 8f314d65d1a396b85e17400ee046f2ad4324a690 SHA1 (patch-af) = 8f314d65d1a396b85e17400ee046f2ad4324a690
SHA1 (patch-ag) = 61a030dc33de4f78cb19653035bebf7661f57c50 SHA1 (patch-ag) = 2bade3c0aee6f1b9777ea8bb75ccf5871c4bc1fd
SHA1 (patch-ah) = a5360c748e16cbc3d6ae4f2968799e96007971f1 SHA1 (patch-ah) = a5360c748e16cbc3d6ae4f2968799e96007971f1
SHA1 (patch-ai) = ee0cfe95a1aa9a883fd95db0fbc0cef60deb8e3a SHA1 (patch-ai) = 77743bdf5fe790826159ffbb9246132f74a5fe38
SHA1 (patch-ak) = 92f269a3f382a9f917d7e58c2cee5bb1d500ab6d SHA1 (patch-ak) = 92f269a3f382a9f917d7e58c2cee5bb1d500ab6d
SHA1 (patch-al) = 744ef092d0a25d4a267a968f139468361bda4f7d SHA1 (patch-al) = 0b0438be382d9d9e0115235fd469bcded6679e3b
SHA1 (patch-am) = 19df141bab53fb1079f76fe6d880a44778c50c68 SHA1 (patch-am) = c55fa35a544d50f56a7d179ad23fdcbde3518328

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.4 2005/12/01 20:42:42 joerg Exp $ $NetBSD: patch-aa,v 1.5 2007/10/18 09:15:33 obache Exp $
--- configure.orig 2004-08-22 22:34:02.000000000 +0000 --- configure.orig 2006-07-09 23:13:54.000000000 +0000
+++ configure +++ configure
@@ -4924,7 +4924,7 @@ _ACEOF @@ -4924,7 +4924,7 @@ _ACEOF
@ -11,9 +11,9 @@ $NetBSD: patch-aa,v 1.4 2005/12/01 20:42:42 joerg Exp $
# FreeBSD/OpenBSD/NetBSD all support dlopen() and have had plenty of # FreeBSD/OpenBSD/NetBSD all support dlopen() and have had plenty of
# testing with Eggdrop. # testing with Eggdrop.
WEIRD_OS="no" WEIRD_OS="no"
@@ -5303,10 +5303,16 @@ _ACEOF @@ -5306,10 +5306,16 @@ _ACEOF
SHLIB_CC="$CC -PIC" # Solaris defines (2^31)-1 as the limit for random() rather than RAND_MAX.
fi RANDMAX="0x7FFFFFFF"
;; ;;
- *BSD) - *BSD)
+ *BSD | DragonFly) + *BSD | DragonFly)
@ -22,10 +22,10 @@ $NetBSD: patch-aa,v 1.4 2005/12/01 20:42:42 joerg Exp $
- SHLIB_LD="ld -Bshareable -x" - SHLIB_LD="ld -Bshareable -x"
+ if [ `echo __ELF__ | $CC -E - | grep -v '#'` = 1 ]; then + if [ `echo __ELF__ | $CC -E - | grep -v '#'` = 1 ]; then
+ SHLIB_LD="ld -shared -x" + SHLIB_LD="ld -shared -x"
+ BEL_MOD_LD="$CC -Wl,-E $LDFLAGS" + BEL_MOD_LD="$CC -Wl,-E $LDFLAGS"
+ else + else
+ SHLIB_LD="ld -Bshareable -x" + SHLIB_LD="ld -Bshareable -x"
+ BEL_MOD_LD="$CC $LDFLAGS" + BEL_MOD_LD="$CC $LDFLAGS"
+ fi + fi
;; ;;
Darwin) Darwin)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.2 2004/12/03 12:15:54 adam Exp $ $NetBSD: patch-ad,v 1.3 2007/10/18 09:15:34 obache Exp $
--- src/mod/filesys.mod/filesys.c.orig 2004-07-02 21:02:02.000000000 +0000 --- src/mod/filesys.mod/filesys.c.orig 2006-05-29 01:56:08.000000000 +0000
+++ src/mod/filesys.mod/filesys.c +++ src/mod/filesys.mod/filesys.c
@@ -461,7 +461,7 @@ static int do_dcc_send(int idx, char *di @@ -464,7 +464,7 @@ static int do_dcc_send(int idx, char *di
if (at_limit(nick)) { if (at_limit(nick)) {
char xxx[1024]; char xxx[1024];

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ag,v 1.6 2004/12/03 12:15:54 adam Exp $ $NetBSD: patch-ag,v 1.7 2007/10/18 09:15:34 obache Exp $
--- Makefile.in.orig 2004-07-25 11:17:33.000000000 +0000 --- Makefile.in.orig 2004-08-28 06:43:21.000000000 +0000
+++ Makefile.in +++ Makefile.in
@@ -38,7 +38,7 @@ SHLIB_CC = @SHLIB_CC@ @@ -38,7 +38,7 @@ SHLIB_CC = @SHLIB_CC@
# Linker # Linker
@ -55,4 +55,4 @@ $NetBSD: patch-ag,v 1.6 2004/12/03 12:15:54 adam Exp $
+'TCLLIB=$(TCLLIB)' 'TCLLIBFN=$(TCLLIBFN)' 'XREQS=$(XREQS)' 'XLDFLAGS=$(XLDFLAGS)' 'XLIBS=$(XLIBS)' \ +'TCLLIB=$(TCLLIB)' 'TCLLIBFN=$(TCLLIBFN)' 'XREQS=$(XREQS)' 'XLDFLAGS=$(XLDFLAGS)' 'XLIBS=$(XLIBS)' \
'EGGEXEC=$(EGGEXEC)' 'EGGBUILD=(static debug version)' 'MODOBJS=mod/*.o' 'EGGEXEC=$(EGGEXEC)' 'EGGBUILD=(static debug version)' 'MODOBJS=mod/*.o'
MAKE_DEPEND = $(MAKE) 'MAKE=$(MAKE)' 'CC=$(CC)' 'LD=$(LD)' \ MAKE_DEPEND = $(MAKE) 'MAKE=$(MAKE)' 'CC=$(CC)'

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ai,v 1.3 2004/12/03 12:15:54 adam Exp $ $NetBSD: patch-ai,v 1.4 2007/10/18 09:15:34 obache Exp $
--- src/mod/share.mod/share.c.orig 2004-07-02 21:02:02.000000000 +0000 --- src/mod/share.mod/share.c.orig 2006-03-28 02:35:51.000000000 +0000
+++ src/mod/share.mod/share.c +++ src/mod/share.mod/share.c
@@ -1120,7 +1120,8 @@ static void share_ufsend(int idx, char * @@ -1122,7 +1122,8 @@ static void share_ufsend(int idx, char *
int i, sock; int i, sock;
FILE *f; FILE *f;
@ -12,7 +12,7 @@ $NetBSD: patch-ai,v 1.3 2004/12/03 12:15:54 adam Exp $
if (!(b_status(idx) & STAT_SHARE)) { if (!(b_status(idx) & STAT_SHARE)) {
dprintf(idx, "s e You didn't ask; you just started sending.\n"); dprintf(idx, "s e You didn't ask; you just started sending.\n");
dprintf(idx, "s e Ask before sending the userfile.\n"); dprintf(idx, "s e Ask before sending the userfile.\n");
@@ -1889,8 +1890,8 @@ static void start_sending_users(int idx) @@ -1891,8 +1892,8 @@ static void start_sending_users(int idx)
struct chanuserrec *ch; struct chanuserrec *ch;
struct chanset_t *cst; struct chanset_t *cst;

View file

@ -1,16 +1,16 @@
$NetBSD: patch-al,v 1.1 2007/05/22 16:47:04 lkundrak Exp $ $NetBSD: patch-al,v 1.2 2007/10/18 09:15:34 obache Exp $
Fix for http://www.eggheads.org/bugzilla/show_bug.cgi?id=462 Fix for http://www.eggheads.org/bugzilla/show_bug.cgi?id=462
--- src/mod/irc.mod/chan.c.orig 2007-05-22 18:29:41.000000000 +0200 --- src/mod/irc.mod/chan.c.orig 2006-03-28 02:35:51.000000000 +0000
+++ src/mod/irc.mod/chan.c +++ src/mod/irc.mod/chan.c
@@ -2204,7 +2204,8 @@ static int gotmsg(char *from, char *msg) @@ -2211,7 +2211,8 @@ static int gotmsg(char *from, char *msg)
if (!chan) return 0; /* Unknown channel; don't process. */
return 0; /* Private msg to an unknown channel?? */
fixcolon(msg); fixcolon(msg);
- strcpy(uhost, from); - strcpy(uhost, from);
+ strncpy(uhost, from, UHOSTMAX); + strncpy(uhost, from, UHOSTMAX);
+ uhost[UHOSTMAX] = '\0'; + uhost[UHOSTMAX] = '\0';
nick = splitnick(&uhost); nick = splitnick(&uhost);
ignoring = match_ignore(from);
/* Only check if flood-ctcp is active */ /* Only check if flood-ctcp is active */
if (flud_ctcp_thr && detect_avalanche(msg)) {

View file

@ -1,10 +1,10 @@
$NetBSD: patch-am,v 1.1 2007/05/22 16:47:05 lkundrak Exp $ $NetBSD: patch-am,v 1.2 2007/10/18 09:15:34 obache Exp $
Fix for http://www.eggheads.org/bugzilla/show_bug.cgi?id=462 Fix for http://www.eggheads.org/bugzilla/show_bug.cgi?id=462
--- src/mod/server.mod/servmsg.c.orig 2007-05-22 18:29:49.000000000 +0200 --- src/mod/server.mod/servmsg.c.orig 2006-03-28 02:35:51.000000000 +0000
+++ src/mod/server.mod/servmsg.c +++ src/mod/server.mod/servmsg.c
@@ -424,7 +424,8 @@ static int gotmsg(char *from, char *msg) @@ -461,7 +461,8 @@ static int gotmsg(char *from, char *msg)
to = newsplit(&msg); to = newsplit(&msg);
fixcolon(msg); fixcolon(msg);
/* Only check if flood-ctcp is active */ /* Only check if flood-ctcp is active */