poppler: remove workaround for old netbsd and dragonflybsd.
With C++14 being required to build this, you have to have most of C99 to build this package. So not having fmax/fmin isn't possible.
This commit is contained in:
parent
e48390b205
commit
827cf2e410
2 changed files with 1 additions and 23 deletions
|
@ -1,8 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.133 2018/12/10 10:28:08 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.134 2018/12/31 06:18:20 maya Exp $
|
||||
|
||||
SHA1 (poppler-0.72.0.tar.xz) = 34d3035eef26bf54cf847925a5b69bd0bf75c672
|
||||
RMD160 (poppler-0.72.0.tar.xz) = 73d6f98c1248a517db9b6244bd2cbdc89c67f5b5
|
||||
SHA512 (poppler-0.72.0.tar.xz) = 57dc98ff3e433cb8c7e3c31016c080e09586410622d70fb2fe1aa36c2a55017508dd5b5b253cfe987b86f9197bdd34345e038c89f542003cf021900c86614145
|
||||
Size (poppler-0.72.0.tar.xz) = 1492912 bytes
|
||||
SHA1 (patch-aq) = da845661ef7f7aca3072dbeebde0444b4d8f01aa
|
||||
SHA1 (patch-poppler_CMap.cc) = d37745ea4cbeae76ad43c4ac74e942531f7b7dd8
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-aq,v 1.7 2014/07/22 12:13:28 wiz Exp $
|
||||
|
||||
Add workaround for lack of fmax/fmin on NetBSD<6 and DragonFly before 200204.
|
||||
|
||||
--- poppler/TextOutputDev.cc.orig Mon Jan 24 19:06:00 2011
|
||||
+++ poppler/TextOutputDev.cc
|
||||
@@ -64,6 +64,14 @@
|
||||
#include "ICSupport.h"
|
||||
#endif
|
||||
|
||||
+#if defined(__DragonFly__) || defined(__NetBSD__)
|
||||
+#include <sys/param.h>
|
||||
+#if !(defined(__DragonFly__) && __DragonFly_version >= 200204) && !(defined(__NetBSD__) && (__NetBSD_Version__ >= 599002100 || (__NetBSD_Version__ >= 501000000 && __NetBSD_Version__ < 599000000)))
|
||||
+static double fmax(double x, double y) { if (isnan(x)) return y; if (isnan(y)) return x; return (x > y ? x : y);}
|
||||
+static double fmin(double x, double y) { if (isnan(x)) return y; if (isnan(y)) return x; return (x < y ? x : y);}
|
||||
+#endif
|
||||
+#endif
|
||||
+
|
||||
//------------------------------------------------------------------------
|
||||
// parameters
|
||||
//------------------------------------------------------------------------
|
Loading…
Reference in a new issue