One small step for GNOME, one giant leap for KDE:
Update "gnome-libs" package to version 1.0.5.
This commit is contained in:
parent
f757fa72c8
commit
82ad5e3634
5 changed files with 45 additions and 173 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.19 1999/03/22 22:43:42 agc Exp $
|
||||
# $NetBSD: Makefile,v 1.20 1999/04/04 20:22:11 tron Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gnome-libs-1.0.3
|
||||
DISTNAME= gnome-libs-1.0.5
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= ftp://ftp.gnome.org/pub/GNOME/gnome-1.0/sources/ \
|
||||
ftp://ftp.jimpick.com/pub/mirrors/gnome/gnome-1.0/sources/ \
|
||||
|
@ -10,7 +10,7 @@ MASTER_SITES= ftp://ftp.gnome.org/pub/GNOME/gnome-1.0/sources/ \
|
|||
MAINTAINER= tron@netbsd.org
|
||||
HOMEPAGE= http://www.gnome.org/
|
||||
|
||||
DEPENDS+= ORBit-0.4.0:../../corba/ORBit
|
||||
DEPENDS+= ORBit-0.4.2:../../corba/ORBit
|
||||
DEPENDS+= imlib-1.9.4:../../graphics/imlib
|
||||
DEPENDS+= xpm-3.4k:../../graphics/xpm
|
||||
|
||||
|
@ -32,6 +32,11 @@ LOCALSTATEDIR= /var/gnome
|
|||
|
||||
PLIST_SRC= ${WRKDIR}/PLIST
|
||||
|
||||
# Someone should show the GNOME people how to use CVS and how to define
|
||||
# dependences in makefiles.
|
||||
post-extract:
|
||||
@find ${WRKDIR} -name "*.idl" -type f | xargs ${TOUCH}
|
||||
|
||||
pre-build:
|
||||
(cd ${WRKSRC}/support; ${GMAKE} gnomesupport.h)
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.6 1999/03/16 22:10:32 tron Exp $
|
||||
$NetBSD: md5,v 1.7 1999/04/04 20:22:11 tron Exp $
|
||||
|
||||
MD5 (gnome-libs-1.0.3.tar.gz) = 5df86d279d58d366e5c7654661baab9b
|
||||
MD5 (gnome-libs-1.0.5.tar.gz) = 3f80097a5e1f4bee83a96718a0e6d230
|
||||
|
|
|
@ -1,24 +1,24 @@
|
|||
$NetBSD: patch-ag,v 1.3 1999/03/16 22:10:32 tron Exp $
|
||||
$NetBSD: patch-ag,v 1.4 1999/04/04 20:22:12 tron Exp $
|
||||
|
||||
--- devel-docs/gnome/Makefile.in.orig Sat Mar 13 02:17:47 1999
|
||||
+++ devel-docs/gnome/Makefile.in Tue Mar 16 00:38:16 1999
|
||||
@@ -156,7 +156,7 @@
|
||||
# The directory containing the source code (if it contains documentation).
|
||||
DOC_SOURCE_DIR = $(GNOME_LIBS_DIR)/libgnome
|
||||
|
||||
-HTML_DIR = $(datadir)/gnome/html
|
||||
+HTML_DIR = $(datadir)/doc/gnome-libs/html
|
||||
|
||||
TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)
|
||||
|
||||
@@ -323,8 +323,8 @@
|
||||
|
||||
install-data-local:
|
||||
install -d -m 0755 $(TARGET_DIR)
|
||||
- -install -m 0644 html/*.html $(TARGET_DIR)
|
||||
- -install -m 0644 html/index.sgml $(TARGET_DIR)
|
||||
+ -${INSTALL_DATA} html/*.html $(TARGET_DIR)
|
||||
+ -${INSTALL_DATA} html/index.sgml $(TARGET_DIR)
|
||||
-gtkdoc-fixxref --module=$(DOC_MODULE) --html-dir=$(HTML_DIR)
|
||||
|
||||
dist-hook:
|
||||
--- zvt/gnome-utmp.c.orig Thu Mar 25 18:23:01 1999
|
||||
+++ zvt/gnome-utmp.c Sun Apr 4 21:45:54 1999
|
||||
@@ -176,7 +176,9 @@
|
||||
}
|
||||
#else
|
||||
{
|
||||
+#if defined(HAVE_GETUTENT)
|
||||
setutent();
|
||||
+#endif
|
||||
pututline (&put);
|
||||
}
|
||||
#endif
|
||||
@@ -256,7 +258,9 @@
|
||||
}
|
||||
#else
|
||||
{
|
||||
+#if defined(HAVE_GETUTENT)
|
||||
setutent();
|
||||
+#endif
|
||||
pututline (ut);
|
||||
}
|
||||
#endif
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ai,v 1.1 1999/03/16 22:10:32 tron Exp $
|
||||
$NetBSD: patch-ai,v 1.2 1999/04/04 20:22:12 tron Exp $
|
||||
|
||||
--- devel-docs/gnomeui/Makefile.in.orig Sat Mar 13 02:17:49 1999
|
||||
+++ devel-docs/gnomeui/Makefile.in Mon Mar 15 23:55:05 1999
|
||||
|
@ -11,27 +11,3 @@ $NetBSD: patch-ai,v 1.1 1999/03/16 22:10:32 tron Exp $
|
|||
|
||||
TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)
|
||||
|
||||
@@ -300,10 +300,10 @@
|
||||
cp $(srcdir)/html/book1.html gnomeui.html
|
||||
|
||||
html/book1.html: sgml/gnomeui-doc.bottom
|
||||
- make html
|
||||
+ ${MAKE} html
|
||||
|
||||
sgml/gnomeui-doc.bottom: $(tmpl_sources)
|
||||
- make sgml
|
||||
+ ${MAKE} sgml
|
||||
|
||||
scan:
|
||||
-CFLAGS=$(CFLAGS) LDFLAGS=$(LDFLAGS) gtkdoc-scanobj --module=$(DOC_MODULE)
|
||||
@@ -327,8 +327,8 @@
|
||||
|
||||
install-data-local:
|
||||
install -d -m 0755 $(TARGET_DIR)
|
||||
- -install -m 0644 html/*.html $(TARGET_DIR)
|
||||
- -install -m 0644 html/index.sgml $(TARGET_DIR)
|
||||
+ -${INSTALL_DATA} html/*.html $(TARGET_DIR)
|
||||
+ -${INSTALL_DATA} html/index.sgml $(TARGET_DIR)
|
||||
-gtkdoc-fixxref --module=$(DOC_MODULE) --html-dir=$(HTML_DIR)
|
||||
|
||||
dist-hook:
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.10 1999/03/16 22:10:32 tron Exp $
|
||||
@comment $NetBSD: PLIST,v 1.11 1999/04/04 20:22:12 tron Exp $
|
||||
bin/dns-helper
|
||||
bin/gconfigger
|
||||
bin/gnome-bug
|
||||
|
@ -146,6 +146,8 @@ include/libgnomeui/gnome-popup-menu.h
|
|||
include/libgnomeui/gnome-winhints.h
|
||||
include/libgnorba/gnorba.h
|
||||
include/libgnorba/gnome-factory.h
|
||||
include/libgnorba/GnomeObject.h
|
||||
include/libgnorba/Table.h
|
||||
include/gtk-xmhtml/miniparse.h
|
||||
include/gtk-xmhtml/HTML.h
|
||||
include/gtk-xmhtml/XmHTML.h
|
||||
|
@ -168,15 +170,15 @@ lib/libgnome.a
|
|||
lib/libgnomesupport.a
|
||||
lib/libgnomesupport.so.0.0
|
||||
lib/libgnomeui.a
|
||||
lib/libgnomeui.so.39.1
|
||||
lib/libgnomeui.so.40.1
|
||||
lib/libgnorba.a
|
||||
lib/libgnorba.so.28.4
|
||||
lib/libgnorba.so.28.5
|
||||
lib/libgnorbagtk.a
|
||||
lib/libgnorbagtk.so.0.0
|
||||
lib/libgtkxmhtml.a
|
||||
lib/libgtkxmhtml.so.1.1
|
||||
lib/libzvt.a
|
||||
lib/libzvt.so.3.3
|
||||
lib/libzvt.so.4.1
|
||||
share/locale/de/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/fr/LC_MESSAGES/gnome-libs.mo
|
||||
share/locale/nl/LC_MESSAGES/gnome-libs.mo
|
||||
|
@ -197,130 +199,21 @@ share/locale/ru/LC_MESSAGES/gnome-libs.mo
|
|||
share/locale/hu/LC_MESSAGES/gnome-libs.mo
|
||||
sbin/gnome-pty-helper
|
||||
share/aclocal/libart.m4
|
||||
share/doc/gnome-libs/gnome-doc.el
|
||||
share/doc/gnome-libs/gnome-doc
|
||||
share/doc/gnome-libs/mkstub
|
||||
share/doc/gnome-libs/README.gtkcauldron
|
||||
share/doc/gnome-libs/README.gtkcauldron_for_python
|
||||
share/doc/gnome-libs/adding-file-manager-new-items.txt
|
||||
share/doc/gnome-libs/session-management.txt
|
||||
share/doc/gnome-libs/adding-sounds.txt
|
||||
share/doc/gnome-libs/api-comment-style.txt
|
||||
share/doc/gnome-libs/gnome-doc.el
|
||||
share/doc/gnome-libs/gnome-doc
|
||||
share/doc/gnome-libs/gtk_dialog_cauldron.3
|
||||
share/doc/gnome-libs/mime-type-handling.txt
|
||||
share/doc/gnome-libs/mkstub
|
||||
share/doc/gnome-libs/suggestions.txt
|
||||
share/doc/gnome-libs/html/gnome.html
|
||||
share/doc/gnome-libs/html/gnome-decl.txt
|
||||
share/doc/gnome-libs/html/gnome-sections.txt
|
||||
share/doc/gnome-libs/session-management.txt
|
||||
share/doc/gnome-libs/mime-type-handling.txt
|
||||
share/doc/gnome-libs/html/gnome-dev-info.html
|
||||
share/doc/gnome-libs/html/gnome/book1.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-config.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-defs.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-dentry.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-exec.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-fileconvert.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-help.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-history.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-i18n.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-metadata.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-mime-info.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-mime.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-paper.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-popt.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-regex.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-remote.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-score.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-sound.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-triggers.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-url.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-gnome-util.html
|
||||
share/doc/gnome-libs/html/gnome/gnome-libgnome.html
|
||||
share/doc/gnome-libs/html/gnome/libgnome.html
|
||||
share/doc/gnome-libs/html/gnomeui.html
|
||||
share/doc/gnome-libs/html/gnomeui.hierarchy
|
||||
share/doc/gnome-libs/html/gnomeui.types
|
||||
share/doc/gnome-libs/html/gnomeui-scan.c
|
||||
share/doc/gnome-libs/html/gnomeui-decl.txt
|
||||
share/doc/gnome-libs/html/gnomeui-sections.txt
|
||||
share/doc/gnome-libs/html/gnomeui/book1.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnome-objects.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeabout.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeanimator.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeapp.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeappbar.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecalculator.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvas.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvasellipse.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvasgroup.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvasimage.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvasitem.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvasline.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvaspolygon.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvasre.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvasrect.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvastext.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecanvaswidget.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeclient.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomecolorpicker.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomedateedit.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomedentryedit.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomedialog.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomedock.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomedockband.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomedockitem.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomedocklayout.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeentry.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomefileentry.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomefontpicker.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomefontselector.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeguru.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomehref.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeiconentry.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeiconlist.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeiconselection.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeicontextitem.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeless.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomemdi.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomemdichild.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomemdigenericchild.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomemessagebox.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomenumberentry.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomepaperselector.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomepixmap.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomepixmapentry.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeprocbar.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomepropertybox.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomescores.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomespell.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomestock.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-app-helper.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-app-util.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-canvas-util.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-dialog-util.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-dns.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-geometry.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-ice.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-icon-text.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-init.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-mdi-session.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-popup-help.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-popup-menu.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-preferences.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-properties.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-property-entries.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-startup.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-types.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-uidefs.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gnome-winhints.html
|
||||
share/doc/gnome-libs/html/gnomeui/gnomeui-gtkcauldron.html
|
||||
share/doc/gnome-libs/html/gnomeui/gtkclock.html
|
||||
share/doc/gnome-libs/html/gnomeui/gtkdial.html
|
||||
share/doc/gnome-libs/html/gnomeui/gtkpixmapmenuitem.html
|
||||
share/doc/gnome-libs/html/gnomeui/gtkted.html
|
||||
share/doc/gnome-libs/html/gnomeui/libgnomeui.html
|
||||
share/idl/GnomeObject.idl
|
||||
share/idl/Table.idl
|
||||
share/idl/base.idl
|
||||
share/idl/gnome-editor.idl
|
||||
share/idl/gnome-factory.idl
|
||||
share/idl/name-service.idl
|
||||
|
@ -350,8 +243,6 @@ share/type-convert/postscript.convert
|
|||
@dirrm include/zvt
|
||||
@dirrm lib/gnome-libs/include
|
||||
@dirrm lib/gnome-libs
|
||||
@dirrm share/doc/gnome-libs/html/gnomeui
|
||||
@dirrm share/doc/gnome-libs/html/gnome
|
||||
@dirrm share/doc/gnome-libs/html
|
||||
@dirrm share/doc/gnome-libs
|
||||
@dirrm share/idl
|
||||
|
|
Loading…
Reference in a new issue