Fix errno.

This commit is contained in:
joerg 2005-12-08 17:36:56 +00:00
parent 01399d9580
commit 82b7232a70
5 changed files with 47 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.4 2005/12/01 20:19:57 wiz Exp $
$NetBSD: distinfo,v 1.5 2005/12/08 17:36:56 joerg Exp $
SHA1 (pgp263is.tar.gz) = 031e061ba1d62d7db35f1f854c489867e88f421d
RMD160 (pgp263is.tar.gz) = b1cba2be918cecc8b9062272d43626c8876fa7f4
@ -9,3 +9,4 @@ SHA1 (patch-ac) = 32e69f1335c3aa7b974dc7fa4100d1f9ebf358ec
SHA1 (patch-ad) = 93f72f3e4f91f478429da8fda4671e171eb167ac
SHA1 (patch-ae) = 307dddd61ef0ee3257a11822fc7bd423c5fd784f
SHA1 (patch-af) = 33802b9f8d875293ea8e5e58a1e1eafd8cde7afe
SHA1 (patch-ag) = 377b17bc3783737c492708de57d6f4259e358a66

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ag,v 1.1 2005/12/08 17:36:56 joerg Exp $
--- fileio.c.orig 2005-12-08 17:33:01.000000000 +0000
+++ fileio.c
@@ -37,7 +37,6 @@
#ifdef _BSD
#include <sys/param.h>
#endif
-extern int errno;
#endif /* UNIX */
#ifdef VMS
#include <file.h>

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.4 2005/02/24 13:10:12 agc Exp $
$NetBSD: distinfo,v 1.5 2005/12/08 17:41:16 joerg Exp $
SHA1 (rid-1.11.tgz) = 14ccad3ae413a1bed19ad5f063f8e563b9ddbbfb
RMD160 (rid-1.11.tgz) = c39ffa2dfc7245022c3db1523909893983a99517
Size (rid-1.11.tgz) = 122317 bytes
SHA1 (patch-aa) = 8840f22028d1535c54a6dc84caeb1960cb93a5de
SHA1 (patch-ab) = 863908c0ec660d3976e977888b95061cac63fe41
SHA1 (patch-ab) = e6cf3017ad2d390f2e58d5739b1819dbb5ad1ae8
SHA1 (patch-ac) = d151390e6306102dd3e6d2121473d727b5953f43

View file

@ -1,8 +1,16 @@
$NetBSD: patch-ab,v 1.1 2004/06/27 12:21:21 grant Exp $
$NetBSD: patch-ab,v 1.2 2005/12/08 17:41:16 joerg Exp $
--- pinger.c.orig 2000-02-25 15:33:24.000000000 +1100
--- pinger.c.orig 2000-02-25 04:33:24.000000000 +0000
+++ pinger.c
@@ -141,7 +141,7 @@ void process_alive(int num_hosts)
@@ -23,7 +23,6 @@ extern fd_set RawFD;
extern u_long NumToPing;
extern u_long TO;
extern pid_t PidSender;
-extern int errno;
/*
@@ -141,7 +140,7 @@ void process_alive(int num_hosts)
}
/* Standard checksum routine */

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ac,v 1.1 2005/12/08 17:41:16 joerg Exp $
--- grammer.y.orig 2005-12-08 17:37:54.000000000 +0000
+++ grammer.y
@@ -1,4 +1,5 @@
%{
+#include <errno.h>
#include <stdio.h>
#include <strings.h>
#include "netconfig.h"
@@ -20,8 +21,6 @@ char *data;
/* Name of current ddos we're working on */
char ddos_name[BUFSIZE];
-
-extern int errno;
%}
%union {