creduce: updated to 2.8.0
2.8.0: No news is good news.
This commit is contained in:
parent
8c2d7b37e0
commit
82c7aff8a2
3 changed files with 10 additions and 52 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.5 2018/03/31 20:09:10 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2018/08/07 11:14:20 adam Exp $
|
||||
|
||||
DISTNAME= creduce-2.7.0
|
||||
DISTNAME= creduce-2.8.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://embed.cs.utah.edu/creduce/
|
||||
|
||||
|
@ -9,10 +9,10 @@ HOMEPAGE= https://embed.cs.utah.edu/creduce/
|
|||
COMMENT= Tool for automatic reduction of C/C++ files triggering bugs
|
||||
LICENSE= 2-clause-bsd
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
USE_TOOLS+= flex perl:run gmake
|
||||
USE_LANGUAGES= c c++11
|
||||
USE_TOOLS+= flex perl:run gmake
|
||||
GNU_CONFIGURE= yes
|
||||
TEST_TARGET= check
|
||||
|
||||
DEPENDS+= p5-Exporter-Lite-[0-9]*:../../devel/p5-Exporter-Lite
|
||||
DEPENDS+= p5-File-Which-[0-9]*:../../devel/p5-File-Which
|
||||
|
@ -21,7 +21,5 @@ DEPENDS+= p5-Term-ReadKey-[0-9]*:../../devel/p5-Term-ReadKey
|
|||
DEPENDS+= p5-Sys-CPU-[0-9]*:../../sysutils/p5-Sys-CPU
|
||||
DEPENDS+= p5-Regexp-Common-[0-9]*:../../textproc/p5-Regexp-Common
|
||||
|
||||
TEST_TARGET= check
|
||||
|
||||
.include "../../lang/clang/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2018/03/31 20:09:10 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.5 2018/08/07 11:14:20 adam Exp $
|
||||
|
||||
SHA1 (creduce-2.7.0.tar.gz) = 45f473364f5e98b612e4244be648ce2cc45dd178
|
||||
RMD160 (creduce-2.7.0.tar.gz) = 8c4cf6231983bf22790bab0a0cf5443924673ca3
|
||||
SHA512 (creduce-2.7.0.tar.gz) = 0ded47fdb4303d84619d63fbedd7bc12141b4857679dda8438683199dbdc98b985f848e797b9dc25a31dda591ee54bcb94580285890b23495fcf151aa3636226
|
||||
Size (creduce-2.7.0.tar.gz) = 768832 bytes
|
||||
SHA1 (creduce-2.8.0.tar.gz) = 4f9ed5c7766f247884ce5c17fa10710372d48d39
|
||||
RMD160 (creduce-2.8.0.tar.gz) = fd9ed41cbb8464ee95bc94ec9ccc50b22303bd9a
|
||||
SHA512 (creduce-2.8.0.tar.gz) = 9d616dc421d0e932656ab0220ebfe1a4f20a08d46bf4ee004ef96a693ff37caeadf96c769262574a9789ac52c2bb4586e2b8602f7d44b627229b8eb45f5af0ea
|
||||
Size (creduce-2.8.0.tar.gz) = 774668 bytes
|
||||
SHA1 (patch-clang__delta_Makefile.am) = 6eac9443bb954c9fb54a922d6da909cf0a45d25d
|
||||
SHA1 (patch-clang__delta_Makefile.in) = c650aab0534268a67615d9360934534ea1d36b90
|
||||
SHA1 (patch-clang__delta_TransformationManager.cpp) = e1fd91a3d473300c10f23d8974fc1a0828cc9e18
|
||||
|
|
|
@ -1,39 +0,0 @@
|
|||
$NetBSD: patch-clang__delta_TransformationManager.cpp,v 1.2 2018/03/31 20:09:10 joerg Exp $
|
||||
|
||||
--- clang_delta/TransformationManager.cpp.orig 2018-03-31 19:32:59.198705133 +0000
|
||||
+++ clang_delta/TransformationManager.cpp
|
||||
@@ -99,18 +99,18 @@ bool TransformationManager::initializeCo
|
||||
}
|
||||
llvm::Triple T(TargetOpts.Triple);
|
||||
CompilerInvocation &Invocation = ClangInstance->getInvocation();
|
||||
- InputKind IK = FrontendOptions::getInputKindForExtension(
|
||||
- StringRef(SrcFileName).rsplit('.').second);
|
||||
- if ((IK == IK_C) || (IK == IK_PreprocessedC)) {
|
||||
- Invocation.setLangDefaults(ClangInstance->getLangOpts(), IK_C, T, PPOpts);
|
||||
+ InputKind::Language IK = FrontendOptions::getInputKindForExtension(
|
||||
+ StringRef(SrcFileName).rsplit('.').second).getLanguage();
|
||||
+ if (IK == InputKind::C) {
|
||||
+ Invocation.setLangDefaults(ClangInstance->getLangOpts(), InputKind::C, T, PPOpts);
|
||||
}
|
||||
- else if ((IK == IK_CXX) || (IK == IK_PreprocessedCXX)) {
|
||||
+ else if (IK == InputKind::CXX) {
|
||||
// ISSUE: it might cause some problems when building AST
|
||||
// for a function which has a non-declared callee, e.g.,
|
||||
// It results an empty AST for the caller.
|
||||
- Invocation.setLangDefaults(ClangInstance->getLangOpts(), IK_CXX, T, PPOpts);
|
||||
+ Invocation.setLangDefaults(ClangInstance->getLangOpts(), InputKind::CXX, T, PPOpts);
|
||||
}
|
||||
- else if(IK == IK_OpenCL) {
|
||||
+ else if(IK == InputKind::OpenCL) {
|
||||
//Commandline parameters
|
||||
std::vector<const char*> Args;
|
||||
Args.push_back("-x");
|
||||
@@ -135,7 +135,7 @@ bool TransformationManager::initializeCo
|
||||
&Args[0], &Args[0] + Args.size(),
|
||||
ClangInstance->getDiagnostics());
|
||||
Invocation.setLangDefaults(ClangInstance->getLangOpts(),
|
||||
- IK_OpenCL, T, PPOpts);
|
||||
+ InputKind::OpenCL, T, PPOpts);
|
||||
}
|
||||
else {
|
||||
ErrorMsg = "Unsupported file type!";
|
Loading…
Reference in a new issue