Update to 3.35
Changelog: The NSS team has released Network Security Services (NSS) 3.35, which is a minor release. Summary of the major changes included in this release: - The default database storage format has been changed to SQL, using filenames cert9.db, key4.db, pkcs11.txt. - TLS 1.3 support has been updated to draft -23, along with additional significant changes. - Support for TLS compression was removed. - Added formally verified implementations of non-vectorized Chacha20 and non-vectorized Poly1305 64-bit. - When creating encrypted PKCS#7 or PKCS#12 data, NSS uses a higher iteration count for stronger security. - The CA trust list was updated to version 2.22.
This commit is contained in:
parent
6996634510
commit
82fca04ce7
4 changed files with 7 additions and 54 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.145 2018/01/22 11:43:14 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.146 2018/01/24 16:23:52 ryoon Exp $
|
||||
|
||||
DISTNAME= nss-${NSS_RELEASE:S/.0$//}
|
||||
NSS_RELEASE= 3.34.1
|
||||
PKGREVISION= 1
|
||||
NSS_RELEASE= 3.35.0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_ALL:=security/nss/releases/NSS_${NSS_DIST_DIR_VERSION:S/_0$//}_RTM/src/}
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.80 2018/01/22 11:43:14 jperkin Exp $
|
||||
$NetBSD: distinfo,v 1.81 2018/01/24 16:23:52 ryoon Exp $
|
||||
|
||||
SHA1 (nss-3.34.1.tar.gz) = 13bf0f2b6c6b39f3a85c54991a92f92a418c7822
|
||||
RMD160 (nss-3.34.1.tar.gz) = 100206175425b11dd409166af4458a11d8569bf2
|
||||
SHA512 (nss-3.34.1.tar.gz) = 6cc4826df4202e865e903a2ed05b49f708a047347b7b4d58f9b83ed097115a128239c4596a033ddeb9ee3fbfe6345a024e11eacb6149bce2d71fbe82c0a41c63
|
||||
Size (nss-3.34.1.tar.gz) = 9562876 bytes
|
||||
SHA1 (nss-3.35.tar.gz) = 72fb5bd2fc56113fec0d8867a1030bb0dfa108ac
|
||||
RMD160 (nss-3.35.tar.gz) = fdd93a1d787f6223b91b4fcb339cf3cf1204a9ef
|
||||
SHA512 (nss-3.35.tar.gz) = 8d466f4602427d278b6aa28af0e6bdb99326fc40c94ac6d517d1cbe7ce6b9332dadba52ea092762fac2fd6e72f17cb880cf81e1cf86bf6b4f7913a755419626d
|
||||
Size (nss-3.35.tar.gz) = 9620041 bytes
|
||||
SHA1 (patch-am) = bab47640c0d25629f43578e7b788859418b27ecd
|
||||
SHA1 (patch-an) = 4ab22f2a575676b5b640bc9a760b83eb05c75e69
|
||||
SHA1 (patch-md) = 8547c9414332c02221b96719dea1e09cb741f4d1
|
||||
|
@ -16,6 +16,4 @@ SHA1 (patch-mn) = 5b79783e48249044be1a904a6cfd20ba175b5fd4
|
|||
SHA1 (patch-nss_cmd_platlibs.mk) = 7dadcb72acf15714c61ae74b21c5baf45bc51d4c
|
||||
SHA1 (patch-nss_coreconf_OpenBSD.mk) = fccc17845c28f5b1268c96eb4e952e32dd530d1d
|
||||
SHA1 (patch-nss_coreconf_command.mk) = 008f7670f164bf19555a7691f5a59fc8bf687078
|
||||
SHA1 (patch-nss_lib_freebl_config.mk) = 5d374317b75c7db968a126f616bb396a012f675d
|
||||
SHA1 (patch-nss_lib_freebl_verified_kremlib.h) = a50ba4e027635b4342cf67d168c3a75ecefeb7b9
|
||||
SHA1 (patch-security_nss_cmd_shlibsign_sign.sh) = 7948b7b502a4c148ee185836dde8a84d3aa388af
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-nss_lib_freebl_config.mk,v 1.2 2017/09/26 10:59:40 ryoon Exp $
|
||||
|
||||
Do not override the installation path of NSPR libraries.
|
||||
|
||||
--- nss/lib/freebl/config.mk.orig 2017-09-20 06:47:27.000000000 +0000
|
||||
+++ nss/lib/freebl/config.mk
|
||||
@@ -96,7 +96,6 @@ endif
|
||||
|
||||
ifeq ($(OS_ARCH), Darwin)
|
||||
CFLAGS += -std=gnu99
|
||||
-EXTRA_SHARED_LIBS += -dylib_file @executable_path/libplc4.dylib:$(DIST)/lib/libplc4.dylib -dylib_file @executable_path/libplds4.dylib:$(DIST)/lib/libplds4.dylib
|
||||
endif
|
||||
|
||||
endif
|
|
@ -1,30 +0,0 @@
|
|||
$NetBSD: patch-nss_lib_freebl_verified_kremlib.h,v 1.1 2017/10/19 15:28:45 jperkin Exp $
|
||||
|
||||
Support SunOS byteswap macros.
|
||||
|
||||
--- nss/lib/freebl/verified/kremlib.h.orig 2017-09-20 06:47:27.000000000 +0000
|
||||
+++ nss/lib/freebl/verified/kremlib.h
|
||||
@@ -100,6 +100,23 @@ typedef void *Prims_pos, *Prims_nat, *Pr
|
||||
#define htobe32(x) OSSwapHostToBigInt32(x)
|
||||
#define be32toh(x) OSSwapBigToHostInt32(x)
|
||||
|
||||
+#elif defined(__sun__)
|
||||
+#include <sys/byteorder.h>
|
||||
+#define htole64(x) LE_64(x)
|
||||
+#define le64toh(x) LE_IN64(x)
|
||||
+#define htobe64(x) BE_64(x)
|
||||
+#define be64toh(x) BE_IN64(x)
|
||||
+
|
||||
+#define htole16(x) LE_16(x)
|
||||
+#define le16toh(x) LE_IN16(x)
|
||||
+#define htobe16(x) BE_16(x)
|
||||
+#define be16toh(x) BE_IN16(x)
|
||||
+
|
||||
+#define htole32(x) LE_32(x)
|
||||
+#define le32toh(x) LE_IN32(x)
|
||||
+#define htobe32(x) BE_32(x)
|
||||
+#define be32toh(x) BE_IN32(x)
|
||||
+
|
||||
// ... for Windows
|
||||
#elif (defined(_WIN16) || defined(_WIN32) || defined(_WIN64)) && \
|
||||
!defined(__WINDOWS__)
|
Loading…
Reference in a new issue