Fix build on DragonFly using Matt Dillon's patch.
http://apollo.backplane.com/DFlyMisc/pkgsrc-devel-m4.patch
This commit is contained in:
parent
b5ae86a07f
commit
834aebecd6
4 changed files with 59 additions and 1 deletions
|
@ -1,6 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.22 2008/04/13 00:51:59 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.23 2008/04/29 13:54:55 wiz Exp $
|
||||
|
||||
SHA1 (m4-1.4.11.tar.gz) = 4d6b7f6344faee39f55af397c25f3e7ad13b6fcb
|
||||
RMD160 (m4-1.4.11.tar.gz) = 3689d9681cf9d2effbf87a3202cea68a75ebcec2
|
||||
Size (m4-1.4.11.tar.gz) = 1168840 bytes
|
||||
SHA1 (patch-aa) = 31aed81ffd1ea40d688ff89786fa72d95a13d422
|
||||
SHA1 (patch-ab) = 6f51d8220aeb5232e87788db259df6d8d94c3653
|
||||
SHA1 (patch-ac) = 5e1d6388d05b3ee6ea9e5b0a56ce5fbde310d538
|
||||
SHA1 (patch-ad) = 20eaea03b78ef94ed39931e7a54dd44ce40a29ff
|
||||
|
|
13
devel/m4/patches/patch-ab
Normal file
13
devel/m4/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.7 2008/04/29 13:54:55 wiz Exp $
|
||||
|
||||
--- lib/freadahead.c.orig 2008-03-10 19:11:22 -0700
|
||||
+++ lib/freadahead.c 2008-04-14 17:38:46 -0700
|
||||
@@ -78,6 +78,8 @@
|
||||
+ (fp->_Mode & 0x4000 /* _MBYTE */
|
||||
? (fp->_Back + sizeof (fp->_Back)) - fp->_Rback
|
||||
: 0);
|
||||
+#elif defined __DragonFly__ /* DragonFly */
|
||||
+ return __sreadahead(fp);
|
||||
#else
|
||||
#error "Please port gnulib freadahead.c to your platform! Look at the definition of fflush, fread, ungetc on your system, then report this to bug-gnulib."
|
||||
#endif
|
13
devel/m4/patches/patch-ac
Normal file
13
devel/m4/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.8 2008/04/29 13:54:55 wiz Exp $
|
||||
|
||||
--- lib/freading.c.orig 2007-11-10 15:24:02 -0800
|
||||
+++ lib/freading.c 2008-04-14 17:41:47 -0700
|
||||
@@ -42,6 +42,8 @@
|
||||
#elif defined __QNX__ /* QNX */
|
||||
return ((fp->_Mode & 0x2 /* _MOPENW */) == 0
|
||||
|| (fp->_Mode & 0x1000 /* _MREAD */) != 0);
|
||||
+#elif defined __DragonFly__ /* DragonFly */
|
||||
+ return ((((struct __FILE_public *)fp)->_flags & __SRD) != 0);
|
||||
#else
|
||||
#error "Please port gnulib freading.c to your platform!"
|
||||
#endif
|
29
devel/m4/patches/patch-ad
Normal file
29
devel/m4/patches/patch-ad
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-ad,v 1.4 2008/04/29 13:54:55 wiz Exp $
|
||||
|
||||
--- lib/fseeko.c.orig 2007-12-17 21:18:34 -0800
|
||||
+++ lib/fseeko.c 2008-04-14 20:27:44 -0700
|
||||
@@ -23,6 +23,18 @@
|
||||
/* Get off_t and lseek. */
|
||||
#include <unistd.h>
|
||||
|
||||
+#ifdef __DragonFly__
|
||||
+
|
||||
+#undef fseeko
|
||||
+
|
||||
+int
|
||||
+rpl_fseeko (FILE *fp, off_t offset, int whence)
|
||||
+{
|
||||
+ return(fseeko(fp, offset, whence));
|
||||
+}
|
||||
+
|
||||
+#else
|
||||
+
|
||||
#undef fseeko
|
||||
#if !HAVE_FSEEKO
|
||||
# undef fseek
|
||||
@@ -121,3 +133,5 @@
|
||||
else
|
||||
return fseeko (fp, offset, whence);
|
||||
}
|
||||
+
|
||||
+#endif
|
Loading…
Reference in a new issue