Add a patch from libxslt CVS:
* libxslt/transform.c: fixed problem with entity handling within xsltCopyAttrListNoOverwrite (#352907) http://bugzilla.gnome.org/show_bug.cgi?id=352907
This commit is contained in:
parent
d637fc3354
commit
835c3d9d73
3 changed files with 22 additions and 2 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.70 2006/11/05 17:06:43 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.71 2006/11/21 23:55:05 recht Exp $
|
||||
|
||||
DISTNAME= libxslt-1.1.18
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://xmlsoft.org/libxslt/
|
||||
#MASTER_SITES= ${MASTER_SITE_GNOME:=sources/libxslt/1.1/}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.41 2006/10/30 21:03:21 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.42 2006/11/21 23:55:05 recht Exp $
|
||||
|
||||
SHA1 (libxslt-1.1.18.tar.gz) = 49aef9520e72b70a9026efa030fad828da0f7b22
|
||||
RMD160 (libxslt-1.1.18.tar.gz) = 14241203635a1d83ff3e72efd623177e6dc2aa2f
|
||||
|
@ -7,3 +7,4 @@ SHA1 (patch-aa) = 3e745804f7f3900eaf88dc6d7ea831b81b0ff765
|
|||
SHA1 (patch-ab) = 70216897fc4c91d148eeece637df53a0f2555f1c
|
||||
SHA1 (patch-ac) = eed53c657171b5af321470c3f3e9ba222b8d4367
|
||||
SHA1 (patch-ad) = 8353ad7cc928cb386e57e0bc65f8ebc2c90a1323
|
||||
SHA1 (patch-ae) = 4e5a545a8c0e1de3e32c79266b0605fa57bbe6bf
|
||||
|
|
18
textproc/libxslt/patches/patch-ae
Normal file
18
textproc/libxslt/patches/patch-ae
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-ae,v 1.1 2006/11/21 23:55:05 recht Exp $
|
||||
|
||||
--- libxslt/transform.c.orig 2006-08-16 17:33:08.000000000 +0200
|
||||
+++ libxslt/transform.c
|
||||
@@ -1074,8 +1074,12 @@ xsltCopyAttrListNoOverwrite(xsltTransfor
|
||||
} else
|
||||
copyNs = NULL;
|
||||
}
|
||||
+ /*
|
||||
+ * If attribute has a value, we need to copy it (watching out
|
||||
+ * for possible entities)
|
||||
+ */
|
||||
if (attr->children)
|
||||
- value = xmlNodeListGetString(attr->doc, attr->children, 1);
|
||||
+ value = xmlNodeListGetString(attr->doc, attr->children, 0);
|
||||
/*
|
||||
* REVISIT: I think xmlNewDocProp() is the only attr function
|
||||
* which does not eval if the attr is of type ID. This is good,
|
Loading…
Reference in a new issue