Fix use of NUL compared against pointers, including a real bug due to

missing indices. Bump revision.
This commit is contained in:
joerg 2013-07-18 12:01:29 +00:00
parent 7758b74e70
commit 836166a765
3 changed files with 26 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.3 2013/05/09 13:50:14 joerg Exp $
# $NetBSD: Makefile,v 1.4 2013/07/18 12:01:29 joerg Exp $
#
DISTNAME= glog-0.3.3
PKGNAME= google-${DISTNAME}
PKGREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://google-glog.googlecode.com/files/

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2013/05/09 13:50:14 joerg Exp $
$NetBSD: distinfo,v 1.3 2013/07/18 12:01:29 joerg Exp $
SHA1 (glog-0.3.3.tar.gz) = ed40c26ecffc5ad47c618684415799ebaaa30d65
RMD160 (glog-0.3.3.tar.gz) = 27fb1bd4156f6715b84d59293d96d1cadc79ea7a
Size (glog-0.3.3.tar.gz) = 509676 bytes
SHA1 (patch-src_demangle.cc) = a5c0ed2b5069894a52735cc691fd12997c77a8cd
SHA1 (patch-src_glog_stl__logging.h.in) = c86472e0f87ca99e91a5ecdb8c33affdb6679c26

View file

@ -0,0 +1,22 @@
$NetBSD: patch-src_demangle.cc,v 1.1 2013/07/18 12:01:29 joerg Exp $
--- src/demangle.cc.orig 2012-01-12 08:40:58.000000000 +0000
+++ src/demangle.cc
@@ -167,7 +167,7 @@ static size_t StrLen(const char *str) {
// Returns true if "str" has at least "n" characters remaining.
static bool AtLeastNumCharsRemaining(const char *str, int n) {
for (int i = 0; i < n; ++i) {
- if (str == '\0') {
+ if (str[i] == '\0') {
return false;
}
}
@@ -223,7 +223,7 @@ static bool ParseTwoCharToken(State *sta
// Returns true and advances "mangled_cur" if we find any character in
// "char_class" at "mangled_cur" position.
static bool ParseCharClass(State *state, const char *char_class) {
- if (state->mangled_cur == '\0') {
+ if (state->mangled_cur == NULL) {
return false;
}
const char *p = char_class;