Add otf2bdf-3.1. Blurb:
This program converts OpenType fonts to BDF fonts using the FreeType 2 renderer. BDF fonts can be edited using the author's "gdbfed" editor, also found in the pkgsrc "fonts" category.
This commit is contained in:
parent
fbc590818b
commit
838f31f194
5 changed files with 85 additions and 0 deletions
3
fonts/otf2bdf/DESCR
Normal file
3
fonts/otf2bdf/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
This program converts OpenType fonts to BDF fonts using the FreeType 2
|
||||
renderer. BDF fonts can be edited using the author's "gdbfed" editor,
|
||||
also found in the pkgsrc "fonts" category.
|
27
fonts/otf2bdf/Makefile
Normal file
27
fonts/otf2bdf/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2008/08/14 01:47:29 bjs Exp $
|
||||
#
|
||||
|
||||
DISTNAME= otf2bdf-3.1
|
||||
CATEGORIES= fonts
|
||||
MASTER_SITES= http://www.math.nmsu.edu/~mleisher/Software/otf2bdf/
|
||||
EXTRACT_SUFX= .tbz2
|
||||
|
||||
MAINTAINER= bjs@NetBSD.org
|
||||
HOMEPAGE= http://www.math.nmsu.edu/~mleisher/Software/otf2bdf/
|
||||
COMMENT= OpenType to BDF font converter
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
|
||||
EGFILES= ${EGFILES_CMD:sh}
|
||||
EGFILES_CMD= ls ${WRKSRC}/maps/*
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}
|
||||
${EGFILES:@.f.@${INSTALL_DATA} ${.f.} ${DESTDIR}${EGDIR}${.newline}@}
|
||||
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
10
fonts/otf2bdf/PLIST
Normal file
10
fonts/otf2bdf/PLIST
Normal file
|
@ -0,0 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2008/08/14 01:47:29 bjs Exp $
|
||||
bin/otf2bdf
|
||||
man/man1/otf2bdf.1
|
||||
share/examples/otf2bdf/iso8859.1
|
||||
share/examples/otf2bdf/iso8859.2
|
||||
share/examples/otf2bdf/iso8859.3
|
||||
share/examples/otf2bdf/iso8859.5
|
||||
share/examples/otf2bdf/koi8.r
|
||||
share/examples/otf2bdf/windows.1251
|
||||
@dirrm share/examples/otf2bdf
|
6
fonts/otf2bdf/distinfo
Normal file
6
fonts/otf2bdf/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/08/14 01:47:29 bjs Exp $
|
||||
|
||||
SHA1 (otf2bdf-3.1.tbz2) = 22d884ed16bf9ea7487e86306051f1de3b3c37a1
|
||||
RMD160 (otf2bdf-3.1.tbz2) = 7bceefa6dfb411e0a206eaf42a42bf4b6e0d3e2e
|
||||
Size (otf2bdf-3.1.tbz2) = 49991 bytes
|
||||
SHA1 (patch-aa) = 0c92e8b911aa644b8717f66d2e6476a32166d8e9
|
39
fonts/otf2bdf/patches/patch-aa
Normal file
39
fonts/otf2bdf/patches/patch-aa
Normal file
|
@ -0,0 +1,39 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2008/08/14 01:47:29 bjs Exp $
|
||||
|
||||
--- Makefile.in.orig 2008-05-21 18:18:18.000000000 -0400
|
||||
+++ Makefile.in
|
||||
@@ -45,7 +45,8 @@ mandir = @mandir@
|
||||
all: otf2bdf
|
||||
|
||||
otf2bdf: $(OBJS)
|
||||
- $(CC) $(STATIC) $(LDFLAGS) -o otf2bdf $(OBJS) $(LIBS)
|
||||
+ $(LIBTOOL) --mode=link \
|
||||
+ $(CC) $(LDFLAGS) -o otf2bdf $(OBJS:.o=.lo) $(LIBS)
|
||||
|
||||
clean:
|
||||
$(RM) -f *.o *BAK *CKP *~ a.out core
|
||||
@@ -57,15 +58,18 @@ distclean: clean
|
||||
$(RM) -f otf2bdf config.* Makefile
|
||||
|
||||
.c.o:
|
||||
- $(CC) $(CFLAGS) $(INCS) -c $< -o $@
|
||||
+ $(LIBTOOL) --mode=compile --tag=CC \
|
||||
+ $(CC) $(CFLAGS) $(INCS) -prefer-pic -c $<
|
||||
|
||||
install: otf2bdf
|
||||
- $(MKINSTALLDIRS) $(bindir) $(mandir)/man1
|
||||
- $(CP) otf2bdf $(bindir)/otf2bdf
|
||||
- $(CP) otf2bdf.man $(mandir)/man1/otf2bdf.1
|
||||
+ $(BSD_INSTALL_PROGRAM_DIR) $(DESTDIR)$(bindir)
|
||||
+ $(BSD_INSTALL_MAN_DIR) $(DESTDIR)$(mandir)/man1
|
||||
+ $(LIBTOOL) --mode=install \
|
||||
+ $(BSD_INSTALL_PROGRAM) otf2bdf $(DESTDIR)$(bindir)/otf2bdf
|
||||
+ $(BSD_INSTALL_MAN) otf2bdf.man $(DESTDIR)$(mandir)/man1/otf2bdf.1
|
||||
|
||||
uninstall:
|
||||
- $(RM) -f $(bindir)/otf2bdf
|
||||
- $(RM) -f $(mandir)/man1/otf2bdf.1
|
||||
+ $(RM) -f $(DESTDIR)$(bindir)/otf2bdf
|
||||
+ $(RM) -f $(DESTDIR)$(mandir)/man1/otf2bdf.1
|
||||
|
||||
# end of Makefile
|
Loading…
Reference in a new issue