Changes 1.2.0:
* Fix: When starting GS or AI, always use the settings of the game, not the new-game settings * Fix: Provide translated comments in the desktop file without language name postfix * Fix: Cloning orders of aircraft with limited range failed
This commit is contained in:
parent
f8cfae2d29
commit
839c2b436b
10 changed files with 128 additions and 52 deletions
|
@ -1,13 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/12/08 17:49:40 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2012/04/28 06:56:43 adam Exp $
|
||||
|
||||
DISTNAME= openttd-data-0.3.1
|
||||
DISTNAME= openttd-data-0.4.4
|
||||
CATEGORIES= games x11
|
||||
MASTER_SITES= http://binaries.openttd.org/extra/
|
||||
DISTFILES= opengfx-${PKGVERSION_NOREV}-all.zip
|
||||
DISTFILES+= openmsx-${PKGVERSION_NOREV}-all.zip
|
||||
DISTFILES+= openmsx-0.3.1-all.zip
|
||||
DISTFILES+= opensfx-0.2.3-all.zip
|
||||
SITES.opengfx-0.3.1-all.zip= ${MASTER_SITES:Q}/opengfx/${PKGVERSION_NOREV}/
|
||||
SITES.openmsx-0.3.1-all.zip= ${MASTER_SITES:Q}/openmsx/${PKGVERSION_NOREV}/
|
||||
SITES.opengfx-0.4.4-all.zip= ${MASTER_SITES:Q}/opengfx/${PKGVERSION_NOREV}/
|
||||
SITES.openmsx-0.3.1-all.zip= ${MASTER_SITES:Q}/openmsx/0.3.1/
|
||||
SITES.opensfx-0.2.3-all.zip= ${MASTER_SITES:Q}/opensfx/0.2.3/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
|
@ -28,9 +28,9 @@ do-install:
|
|||
${DESTDIR}${PREFIX}/share/openttd/data
|
||||
${INSTALL_DATA} ${WRKDIR}/opengfx-${PKGVERSION_NOREV}/*.obg \
|
||||
${DESTDIR}${PREFIX}/share/openttd/data
|
||||
${INSTALL_DATA} ${WRKDIR}/openmsx-${PKGVERSION_NOREV}/*.mid \
|
||||
${INSTALL_DATA} ${WRKDIR}/openmsx-0.3.1/*.mid \
|
||||
${DESTDIR}${PREFIX}/share/openttd/gm
|
||||
${INSTALL_DATA} ${WRKDIR}/openmsx-${PKGVERSION_NOREV}/*.obm \
|
||||
${INSTALL_DATA} ${WRKDIR}/openmsx-0.3.1/*.obm \
|
||||
${DESTDIR}${PREFIX}/share/openttd/gm
|
||||
${INSTALL_DATA} ${WRKDIR}/opensfx-0.2.3/*.cat \
|
||||
${DESTDIR}${PREFIX}/share/openttd/data
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/12/08 17:49:40 adam Exp $
|
||||
$NetBSD: distinfo,v 1.2 2012/04/28 06:56:43 adam Exp $
|
||||
|
||||
SHA1 (opengfx-0.3.1-all.zip) = 5376e89b5ccd3fa8a61e0a1814824202bb789fb7
|
||||
RMD160 (opengfx-0.3.1-all.zip) = 512ba0c3977534e4a4ca37b9402339168ed50e4a
|
||||
Size (opengfx-0.3.1-all.zip) = 3387182 bytes
|
||||
SHA1 (opengfx-0.4.4-all.zip) = c68cdbb1ee8980a44feff320288e466d06efcd19
|
||||
RMD160 (opengfx-0.4.4-all.zip) = 6b98dee11682588da9877a65754f117fae4dc7e9
|
||||
Size (opengfx-0.4.4-all.zip) = 3470306 bytes
|
||||
SHA1 (openmsx-0.3.1-all.zip) = e9c4203923bb9c974ac67886bd00b7090658b961
|
||||
RMD160 (openmsx-0.3.1-all.zip) = 8eff246e89e44f63ca480e9acef94a1da5fa81d2
|
||||
Size (openmsx-0.3.1-all.zip) = 136981 bytes
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.42 2012/04/27 12:31:48 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.43 2012/04/28 06:56:42 adam Exp $
|
||||
|
||||
DISTNAME= openttd-1.0.5-source
|
||||
DISTNAME= openttd-1.2.0-source
|
||||
PKGNAME= ${DISTNAME:S/-source//}
|
||||
PKGREVISION= 5
|
||||
CATEGORIES= games x11
|
||||
MASTER_SITES= http://binaries.openttd.org/releases/${PKGVERSION_NOREV}/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
EXTRACT_SUFX= .tar.xz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.openttd.org/
|
||||
|
@ -31,7 +30,8 @@ CONFIGURE_ARGS+= --man-dir=${PKGMANDIR}/man6
|
|||
CONFIGURE_ARGS+= --menu-dir=share/applications
|
||||
CONFIGURE_ARGS+= --personal-dir=.openttd
|
||||
CONFIGURE_ARGS+= --shared-dir=${VARBASE}/games/openttd
|
||||
CONFIGURE_ARGS+= --with-lzo2=${BUILDLINK_PREFIX.lzo}/lib/liblzo2.so
|
||||
# Hack: built-in xz does not provide liblzma.pc, needed to configure
|
||||
PREFER_PKGSRC+= xz
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
@ -40,6 +40,7 @@ CONFIGURE_ARGS+= --os=FREEBSD
|
|||
.endif
|
||||
|
||||
.if (${OPSYS} == "Darwin")
|
||||
CONFIGURE_ARGS+= --disable-cocoa-quickdraw
|
||||
CONFIGURE_ARGS+= --with-cocoa
|
||||
CONFIGURE_ARGS+= --without-application-bundle
|
||||
CONFIGURE_ARGS+= --without-osx-sysroot
|
||||
|
@ -48,6 +49,7 @@ CONFIGURE_ARGS+= --without-osx-sysroot
|
|||
.endif
|
||||
|
||||
.include "../../archivers/lzo/buildlink3.mk"
|
||||
.include "../../archivers/xz/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../fonts/fontconfig/buildlink3.mk"
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.16 2010/12/08 17:47:50 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.17 2012/04/28 06:56:42 adam Exp $
|
||||
bin/openttd
|
||||
man/man6/openttd.6
|
||||
share/applications/openttd.desktop
|
||||
|
@ -7,9 +7,6 @@ share/doc/openttd/COPYING
|
|||
share/doc/openttd/changelog.txt
|
||||
share/doc/openttd/known-bugs.txt
|
||||
share/doc/openttd/multiplayer.txt
|
||||
share/doc/openttd/obg_format.txt
|
||||
share/doc/openttd/obm_format.txt
|
||||
share/doc/openttd/obs_format.txt
|
||||
share/doc/openttd/readme.txt
|
||||
share/icons/hicolor/128x128/apps/openttd.png
|
||||
share/icons/hicolor/16x16/apps/openttd.png
|
||||
|
@ -19,17 +16,18 @@ share/icons/hicolor/48x48/apps/openttd.png
|
|||
share/icons/hicolor/64x64/apps/openttd.png
|
||||
share/openttd/ai/compat_0.7.nut
|
||||
share/openttd/ai/compat_1.0.nut
|
||||
share/openttd/data/no_sound.obs
|
||||
share/openttd/data/openttdd.grf
|
||||
share/openttd/data/openttdw.grf
|
||||
share/openttd/data/opntitle.dat
|
||||
share/openttd/data/orig_dos.obg
|
||||
share/openttd/data/orig_dos.obs
|
||||
share/openttd/data/orig_dos_de.obg
|
||||
share/openttd/data/orig_win.obg
|
||||
share/openttd/data/orig_win.obs
|
||||
share/openttd/gm/no_music.obm
|
||||
share/openttd/gm/orig_win.obm
|
||||
share/openttd/ai/compat_1.1.nut
|
||||
share/openttd/ai/compat_1.2.nut
|
||||
share/openttd/baseset/no_music.obm
|
||||
share/openttd/baseset/no_sound.obs
|
||||
share/openttd/baseset/openttd.grf
|
||||
share/openttd/baseset/opntitle.dat
|
||||
share/openttd/baseset/orig_dos.obg
|
||||
share/openttd/baseset/orig_dos.obs
|
||||
share/openttd/baseset/orig_dos_de.obg
|
||||
share/openttd/baseset/orig_win.obg
|
||||
share/openttd/baseset/orig_win.obm
|
||||
share/openttd/baseset/orig_win.obs
|
||||
share/openttd/lang/afrikaans.lng
|
||||
share/openttd/lang/arabic_egypt.lng
|
||||
share/openttd/lang/belarusian.lng
|
||||
|
@ -41,6 +39,7 @@ share/openttd/lang/czech.lng
|
|||
share/openttd/lang/danish.lng
|
||||
share/openttd/lang/dutch.lng
|
||||
share/openttd/lang/english.lng
|
||||
share/openttd/lang/english_AU.lng
|
||||
share/openttd/lang/english_US.lng
|
||||
share/openttd/lang/esperanto.lng
|
||||
share/openttd/lang/estonian.lng
|
||||
|
|
|
@ -1,7 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.16 2010/12/08 17:47:50 adam Exp $
|
||||
$NetBSD: distinfo,v 1.17 2012/04/28 06:56:42 adam Exp $
|
||||
|
||||
SHA1 (openttd-1.0.5-source.tar.bz2) = 2e0cfa2d6e4c4bc1235a60de39961728bb727eb8
|
||||
RMD160 (openttd-1.0.5-source.tar.bz2) = 8d723e8efeb6de9860b62cf835fa3db09a7848cd
|
||||
Size (openttd-1.0.5-source.tar.bz2) = 5684796 bytes
|
||||
SHA1 (patch-aa) = ad42a8eac1268b00641715c825d505b480e9a234
|
||||
SHA1 (patch-ab) = 40ff3d0b0837ca5660ff136b60e8531e1f0a1cc0
|
||||
SHA1 (openttd-1.2.0-source.tar.xz) = 9bb090bbe352ceee22c1ed7818bf4ac8e560379f
|
||||
RMD160 (openttd-1.2.0-source.tar.xz) = 0b3279b6fc9c4f370baa27e9949c165a52d795f3
|
||||
Size (openttd-1.2.0-source.tar.xz) = 5707216 bytes
|
||||
SHA1 (patch-Makefile.setting.in) = d7d2e502e032207f8c169f78c67515eea43c2986
|
||||
SHA1 (patch-Makefile.src.in) = 8b695a1ef030189c2716add7af3fd18298bc1bc7
|
||||
SHA1 (patch-aa) = a77c366fba4a5b8fb8c81e3735e410a85e8f5a13
|
||||
SHA1 (patch-ab) = f1f24847499b57ccfe68625193e69f293410eca8
|
||||
SHA1 (patch-src_string.cpp) = c694d4a44b5cfd766b0f962210b524674b01dfea
|
||||
|
|
23
games/openttd/patches/patch-Makefile.setting.in
Normal file
23
games/openttd/patches/patch-Makefile.setting.in
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-Makefile.setting.in,v 1.1 2012/04/28 06:56:43 adam Exp $
|
||||
|
||||
--- Makefile.setting.in.orig 2012-04-15 11:55:05.000000000 +0000
|
||||
+++ Makefile.setting.in
|
||||
@@ -9,13 +9,16 @@ SETTINGSGEN = !!SETTINGSGEN!!
|
||||
ENDIAN_CHECK = !!ENDIAN_CHECK!!
|
||||
SRC_DIR = !!SRC_DIR!!
|
||||
CXX_BUILD = !!CXX_BUILD!!
|
||||
-CFLAGS_BUILD = !!CFLAGS_BUILD!!
|
||||
-LDFLAGS_BUILD = !!LDFLAGS_BUILD!!
|
||||
+CFLAGS_BUILD = !!CFLAGS!! !!CFLAGS_BUILD!!
|
||||
+LDFLAGS_BUILD = !!LDFLAGS!! !!LDFLAGS_BUILD!! !!LIBS!!
|
||||
STAGE = !!STAGE!!
|
||||
SETTING_OBJS_DIR = !!SETTING_OBJS_DIR!!
|
||||
|
||||
ENDIAN_TARGETS := endian_host.h endian_target.h $(ENDIAN_CHECK)
|
||||
|
||||
+# Make sure endian_host.h is reachable as if it was in the src/ dir
|
||||
+CFLAGS_BUILD += -I $(SETTING_OBJS_DIR)
|
||||
+
|
||||
# Check if we want to show what we are doing
|
||||
ifdef VERBOSE
|
||||
Q =
|
20
games/openttd/patches/patch-Makefile.src.in
Normal file
20
games/openttd/patches/patch-Makefile.src.in
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-Makefile.src.in,v 1.1 2012/04/28 06:56:43 adam Exp $
|
||||
|
||||
--- Makefile.src.in.orig 2012-04-27 16:50:24.000000000 +0000
|
||||
+++ Makefile.src.in
|
||||
@@ -12,12 +12,12 @@ CXX_BUILD = !!CXX_BUILD!!
|
||||
WINDRES = !!WINDRES!!
|
||||
STRIP = !!STRIP!!
|
||||
CFLAGS = !!CFLAGS!!
|
||||
-CFLAGS_BUILD = !!CFLAGS_BUILD!!
|
||||
+CFLAGS_BUILD = !!CFLAGS!! !!CFLAGS_BUILD!!
|
||||
CXXFLAGS = !!CXXFLAGS!!
|
||||
-CXXFLAGS_BUILD = !!CXXFLAGS_BUILD!!
|
||||
+CXXFLAGS_BUILD = !!CXXFLAGS!! !!CXXFLAGS_BUILD!!
|
||||
LIBS = !!LIBS!!
|
||||
LDFLAGS = !!LDFLAGS!!
|
||||
-LDFLAGS_BUILD = !!LDFLAGS_BUILD!!
|
||||
+LDFLAGS_BUILD = !!LDFLAGS!! !!LDFLAGS_BUILD!! !!LIBS!!
|
||||
ROOT_DIR = !!ROOT_DIR!!
|
||||
BIN_DIR = !!BIN_DIR!!
|
||||
LANG_DIR = !!LANG_DIR!!
|
|
@ -1,22 +1,35 @@
|
|||
$NetBSD: patch-aa,v 1.9 2010/12/08 17:47:50 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.10 2012/04/28 06:56:43 adam Exp $
|
||||
|
||||
--- config.lib.orig 2010-11-20 20:25:53.000000000 +0000
|
||||
Compile 'strip' test with CFLAGS, so -isysroot can be passed on OSX.
|
||||
Correct library detection on NetBSD.
|
||||
Fix version checking of ICU 49 and above.
|
||||
|
||||
--- config.lib.orig 2012-04-15 11:55:05.000000000 +0000
|
||||
+++ config.lib
|
||||
@@ -1241,7 +1241,7 @@ make_cflags_and_ldflags() {
|
||||
OBJS_SUBDIR="release"
|
||||
if [ "$os" = "OSX" ]; then
|
||||
# these compilerflags makes the app run as fast as possible without making the app unstable. It works on G3 or newer
|
||||
- CFLAGS="-O3 -funroll-loops -fsched-interblock -falign-loops=16 -falign-jumps=16 -falign-functions=16 -falign-jumps-max-skip=15 -falign-loops-max-skip=15 -mdynamic-no-pic $CFLAGS"
|
||||
+ CFLAGS="-mdynamic-no-pic $CFLAGS"
|
||||
else
|
||||
if [ "$os" = "MORPHOS" ]; then
|
||||
CFLAGS="-I/gg/os-include -noixemul -fstrict-aliasing -fexpensive-optimizations -mcpu=604 -fno-inline -mstring -mmultiple $CFLAGS"
|
||||
@@ -2304,7 +2304,7 @@ detect_library() {
|
||||
@@ -2001,7 +2001,7 @@ check_strip() {
|
||||
elif [ "$os" = "OSX" ]; then
|
||||
# Most targets have -V in strip, to see if they exists... OSX doesn't.. so execute something
|
||||
echo "int main(int argc, char *argv[]) { }" > strip.test.c
|
||||
- $cxx_host strip.test.c -o strip.test
|
||||
+ $cc_host $CFLAGS strip.test.c -o strip.test
|
||||
check_compiler "host strip" "strip" "$host" "$strip" "$STRIP" "strip" "strip" "3" "strip.test"
|
||||
rm -f strip.test.c strip.test
|
||||
else
|
||||
@@ -2533,7 +2533,7 @@ detect_library() {
|
||||
if [ -z "$res" ]; then
|
||||
log 2 " trying /usr/local/include/$4$5... no"
|
||||
log 2 " trying /opt/local/include/$4$5... no"
|
||||
fi
|
||||
- if [ -z "$res" ] && [ "$os" = "NETBSD" ]; then
|
||||
+ if [ -z "$res" ]; then
|
||||
eval "$2=`ls -1 /usr/pkg/include/$4*.h 2>/dev/null | egrep \"\/$5\$\"`"
|
||||
eval "res=\$$2"
|
||||
if [ -z "$res" ]; then
|
||||
@@ -2864,7 +2864,7 @@ detect_icu() {
|
||||
|
||||
version=`$icu_config --version 2>/dev/null`
|
||||
ret=$?
|
||||
- shortversion=`echo $version | cut -c 1,3`
|
||||
+ shortversion=`echo $version | cut -c 1,2`
|
||||
log 2 "executing $icu_config --version"
|
||||
log 2 " returned $version"
|
||||
log 2 " exit code $ret"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ab,v 1.6 2010/12/08 17:47:50 adam Exp $
|
||||
$NetBSD: patch-ab,v 1.7 2012/04/28 06:56:43 adam Exp $
|
||||
|
||||
--- Makefile.lang.in.orig 2010-02-05 16:20:04.000000000 +0000
|
||||
+++ Makefile.lang.in
|
||||
|
@ -9,7 +9,7 @@ $NetBSD: patch-ab,v 1.6 2010/12/08 17:47:50 adam Exp $
|
|||
-CFLAGS_BUILD = !!CFLAGS_BUILD!!
|
||||
-LDFLAGS_BUILD = !!LDFLAGS_BUILD!!
|
||||
+CFLAGS_BUILD = !!CFLAGS!! !!CFLAGS_BUILD!!
|
||||
+LDFLAGS_BUILD = !!LDFLAGS!! !!LDFLAGS_BUILD!!
|
||||
+LDFLAGS_BUILD = !!LDFLAGS!! !!LDFLAGS_BUILD!! !!LIBS!!
|
||||
STRGEN_FLAGS = !!STRGEN_FLAGS!!
|
||||
STAGE = !!STAGE!!
|
||||
LANG_SUPPRESS = !!LANG_SUPPRESS!!
|
||||
|
|
16
games/openttd/patches/patch-src_string.cpp
Normal file
16
games/openttd/patches/patch-src_string.cpp
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-src_string.cpp,v 1.1 2012/04/28 06:56:43 adam Exp $
|
||||
|
||||
Define Collator when building strgen.
|
||||
|
||||
--- src/string.cpp.orig 2012-04-27 16:01:34.000000000 +0000
|
||||
+++ src/string.cpp
|
||||
@@ -29,6 +29,9 @@
|
||||
#include <unicode/ustring.h>
|
||||
#include "language.h"
|
||||
#include "gfx_func.h"
|
||||
+#if defined(STRGEN) || defined(SETTINGSGEN)
|
||||
+Collator *_current_collator = NULL;
|
||||
+#endif
|
||||
#endif /* WITH_ICU */
|
||||
|
||||
/**
|
Loading…
Reference in a new issue