Fix C99 vs GNU89 inline mess. Annotate that AMD64 grows stack downwards
This commit is contained in:
parent
b164a2fb3e
commit
83f1f8054d
3 changed files with 26 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.54 2011/04/22 13:41:58 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.55 2011/08/20 15:35:23 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= librep-0.91.0
|
||||
|
@ -27,6 +27,12 @@ CONFIGURE_ARGS+= --with-readline
|
|||
CONFIGURE_ARGS+= --with-gmp
|
||||
CONFIGURE_ARGS+= --enable-static
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${MACHINE_ARCH} == "x86_64"
|
||||
CONFIGURE_ARGS+= --with-stack-direction=-1
|
||||
.endif
|
||||
|
||||
REPLACE_INTERPRETER+= rep
|
||||
REPLACE.rep.old= .*/bin/rep
|
||||
REPLACE.rep.new= ${PREFIX}/bin/rep
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.17 2011/01/23 23:54:22 tnn Exp $
|
||||
$NetBSD: distinfo,v 1.18 2011/08/20 15:35:23 joerg Exp $
|
||||
|
||||
SHA1 (librep-0.91.0.tar.bz2) = d680baf1bff0c8e8db13017ea9400624cff147ba
|
||||
RMD160 (librep-0.91.0.tar.bz2) = e0dcfab13ac4616d95a8a36659d1a7df3e6a8a78
|
||||
Size (librep-0.91.0.tar.bz2) = 640558 bytes
|
||||
SHA1 (patch-aa) = 8c467655c9ce81abd89f25db1a8450f0185eb757
|
||||
SHA1 (patch-src-repint.h) = 2b21616604579278cfbfabf7903f959141908712
|
||||
|
|
17
lang/librep/patches/patch-src-repint.h
Normal file
17
lang/librep/patches/patch-src-repint.h
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-src-repint.h,v 1.1 2011/08/20 15:35:24 joerg Exp $
|
||||
|
||||
--- src/repint.h.orig 2011-08-19 14:37:20.000000000 +0000
|
||||
+++ src/repint.h
|
||||
@@ -243,8 +243,10 @@ typedef struct rep_cons_block_struct {
|
||||
call when the heap needs to grow. */
|
||||
|
||||
#if defined __GNUC__ && defined __OPTIMIZE__
|
||||
-extern __inline__ repv inline_Fcons (repv x, repv y);
|
||||
-extern __inline__ repv
|
||||
+#if !defined(__GNUC_STDC_INLINE__) || !__GNUC_STDC_INLINE__
|
||||
+extern
|
||||
+#endif
|
||||
+__inline__ repv
|
||||
inline_Fcons (repv x, repv y)
|
||||
{
|
||||
rep_cons *c = rep_cons_freelist;
|
Loading…
Reference in a new issue