- Restore dynamic package list handling removed in revision 1.121 because
the current code doesn't work properly with "make package". - Fix various problems reported by "pkglint".
This commit is contained in:
parent
8c63712ff9
commit
8448d4a61d
4 changed files with 38 additions and 28 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.136 2006/03/14 01:14:30 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.137 2006/04/11 13:26:01 tron Exp $
|
||||
|
||||
DISTNAME= mutt-1.4.2.1i
|
||||
PKGNAME= ${DISTNAME:C/i$//}
|
||||
|
@ -37,9 +37,33 @@ CONFIGURE_ARGS+= --without-wc-funcs
|
|||
CONFIGURE_ENV+= ac_cv_header_inttypes_h=no
|
||||
.endif
|
||||
|
||||
SUBST_CLASSES+= gpg
|
||||
SUBST_MESSAGE.gpg= Fixing path to GnuPG binary.
|
||||
SUBST_STAGE.gpg= post-patch
|
||||
SUBST_FILES.gpg= contrib/gpg.rc
|
||||
SUBST_SED.gpg= -e "s,/usr/bin/gpg,gpg,g"
|
||||
|
||||
SUBST_CLASSES+= docdir
|
||||
SUBST_MESSAGE.docdir= Fixing path to documentation directory.
|
||||
SUBST_STAGE.docdir= post-patch
|
||||
SUBST_FILES.docdir= doc/mutt.man
|
||||
SUBST_SED.docdir= -e "s,/usr/local/doc/mutt/,${DOCDIR}/,g"
|
||||
|
||||
SUBST_CLASSES+= confdir
|
||||
SUBST_MESSAGE.confdir= Fixing path do configuration directory.
|
||||
SUBST_STAGE.confdir= post-patch
|
||||
SUBST_FILES.confdir= doc/mutt.man
|
||||
SUBST_SED.confdir= -e "s,/etc/,${PKG_SYSCONFDIR}/,g"
|
||||
|
||||
SUBST_CLASSES+= prefix
|
||||
SUBST_MESSAGE.prefix= Fixing installation directory.
|
||||
SUBST_STAGE.prefix= post-patch
|
||||
SUBST_FILES.prefix= doc/mutt.man
|
||||
SUBST_SED.prefix= -e "s,/usr/local/,${PREFIX}/,g"
|
||||
|
||||
.if ${OPSYS} == "Interix"
|
||||
SUBST_CLASSES+= mgroup
|
||||
SUBST_MESSAGE.mgroup= "Configuring mail group."
|
||||
SUBST_MESSAGE.mgroup= Configuring mail group.
|
||||
SUBST_STAGE.mgroup= post-patch
|
||||
SUBST_FILES.mgroup= configure
|
||||
SUBST_SED.mgroup= -e "s,DOTLOCK_GROUP='mail',DOTLOCK_GROUP='+Administrators',"
|
||||
|
@ -64,31 +88,12 @@ CONF_FILES= ${EGDIR}/Muttrc ${PKG_SYSCONFDIR}/Muttrc
|
|||
CONF_FILES+= ${EGDIR}/mime.types ${PKG_SYSCONFDIR}/mime.types
|
||||
FILES_SUBST+= DOCDIR=${DOCDIR:Q}
|
||||
|
||||
.if exists(${WRKSRC}/mutt_dotlock)
|
||||
PLIST_SUBST+= MUTT_DOTLOCK=
|
||||
.else
|
||||
PLIST_SUBST+= MUTT_DOTLOCK="@comment "
|
||||
.endif
|
||||
INSTALL_MAKE_FLAGS= ${MAKE_FLAGS} sysconfdir=${EGDIR}
|
||||
INSTALL_MAKE_FLAGS+= ${MAKE_FLAGS} sysconfdir=${EGDIR:Q}
|
||||
PLIST_SRC= ${WRKDIR}/PLIST
|
||||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
|
||||
# Fix some absolute paths in installed files.
|
||||
post-build:
|
||||
for file in ${WRKSRC}/contrib/gpg.rc; do \
|
||||
${MV} -f $$file $$file.save; \
|
||||
${SED} -e "s,/usr/bin/gpg,gpg,g" \
|
||||
$$file.save > $$file; \
|
||||
done
|
||||
for file in ${WRKSRC}/doc/mutt.man; do \
|
||||
${MV} -f $$file $$file.save; \
|
||||
${SED} -e "s,/etc/,${PKG_SYSCONFDIR}/,g" \
|
||||
-e "s,/usr/local/doc/mutt/,${DOCDIR}/,g" \
|
||||
-e "s,/usr/local/,${PREFIX}/,g" \
|
||||
$$file.save > $$file; \
|
||||
done
|
||||
|
||||
# Pre-create some directories and symlinks used during the installation
|
||||
# process.
|
||||
#
|
||||
|
@ -98,9 +103,13 @@ pre-install:
|
|||
${RM} -f ${DOCDIR}/samples
|
||||
${LN} -sf ${EGDIR} ${DOCDIR}/samples
|
||||
|
||||
.if (${PKG_INSTALLATION_TYPE} == "pkgviews")
|
||||
post-install:
|
||||
.if (${PKG_INSTALLATION_TYPE} == "pkgviews")
|
||||
${MV} ${PREFIX}/man/man5/mutt-mbox.5 ${PREFIX}/man/man5/mbox.5
|
||||
.endif
|
||||
@${CP} ${PKGDIR}/PLIST ${PLIST_SRC}
|
||||
@if [ -f ${PREFIX}/bin/mutt_dotlock ]; then \
|
||||
${ECHO} "bin/mutt_dotlock" >> ${PLIST_SRC}; \
|
||||
fi
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.8 2005/09/22 15:24:42 tron Exp $
|
||||
@comment $NetBSD: PLIST,v 1.9 2006/04/11 13:26:01 tron Exp $
|
||||
bin/flea
|
||||
bin/mutt
|
||||
bin/muttbug
|
||||
${MUTT_DOTLOCK}bin/mutt_dotlock
|
||||
bin/pgpewrap
|
||||
bin/pgpring
|
||||
man/man1/flea.1
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.28 2006/02/07 00:00:51 minskim Exp $
|
||||
$NetBSD: distinfo,v 1.29 2006/04/11 13:26:01 tron Exp $
|
||||
|
||||
SHA1 (mutt-1.4.2.1i.tar.gz) = 10fae2eef5a671d1ea6e17acd6e64cd1f37c3961
|
||||
RMD160 (mutt-1.4.2.1i.tar.gz) = 314536f77e0494dc6e4a5d57c681de791c8ce0fc
|
||||
|
@ -12,5 +12,5 @@ SHA1 (patch-ah) = 04549728683b4250a26f6d6c7a212b8d505014d2
|
|||
SHA1 (patch-ai) = 317b736d6b9a896e1ee185cce37a1c2184c02cde
|
||||
SHA1 (patch-aj) = a0ee2bc9a7b9e743e313101899de3d991a9d2cad
|
||||
SHA1 (patch-ak) = 689305356812d04bd3b490c436ed898a4b308136
|
||||
SHA1 (patch-al) = d05f5a1606bf8a7669db198a0f85f95eb17f74b4
|
||||
SHA1 (patch-al) = d03611108f76c33e87ac89a6e7eefc012297df86
|
||||
SHA1 (patch-am) = faa80ebf308eddfcbbe5aeab2f52d2d356d540cf
|
||||
|
|
|
@ -1,3 +1,5 @@
|
|||
$NetBSD: patch-al,v 1.8 2006/04/11 13:26:01 tron Exp $
|
||||
|
||||
--- pop_lib.c.orig 2005-12-26 06:28:37.000000000 -0800
|
||||
+++ pop_lib.c 2005-12-26 06:28:40.000000000 -0800
|
||||
@@ -155,8 +155,10 @@
|
||||
|
|
Loading…
Reference in a new issue