Upgrade figlet to version 2.2.1.

Provided in PR 17641 by Norm (norm@sandbox.org.uk)

FIGlet 2.2.1 is a minor revision of FIGlet 2.2.  The files
README, Makefile, figfont.txt, figlet.c and figlet.6 have been
changed to reflect changes in documentation, official contact
details etc. FTP-NOTE merged into README. FAQ and CHANGES
added to the distribution.

All other files are identical with the 2.2 release.

These changes were made by Christiaan Keet <keet@plig.net>
This commit is contained in:
agc 2002-07-19 08:00:47 +00:00
parent 1d6646a4d4
commit 844a2a597b
3 changed files with 23 additions and 30 deletions

View file

@ -1,15 +1,14 @@
# $NetBSD: Makefile,v 1.7 2001/02/17 18:09:02 wiz Exp $
# $NetBSD: Makefile,v 1.8 2002/07/19 08:00:47 agc Exp $
# FreeBSD Id: Makefile,v 1.6 1997/06/29 09:56:32 obrien Exp
#
DISTNAME= figlet22
PKGNAME= figlet-2.2
DISTNAME= figlet221
PKGNAME= figlet-2.2.1
CATEGORIES= misc
MASTER_SITES= ftp://ftp.nicoh.com/pub/figlet/program/unix/ \
ftp://ftp.wwa.com/pub/Scarecrow/Figlet/Unix/
MASTER_SITES= ftp://ftp.figlet.org/pub/figlet/program/unix/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://st-www.cs.uiuc.edu/users/chai/figlet.html
HOMEPAGE= http://www.figlet.org/
COMMENT= Banner like program, prints strings in fancy ASCII art characters
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.3 2001/04/27 10:06:12 abs Exp $
$NetBSD: distinfo,v 1.4 2002/07/19 08:00:47 agc Exp $
SHA1 (figlet22.tar.gz) = 8e8a91e4f827551eed128bb53172e63b18eba303
Size (figlet22.tar.gz) = 165091 bytes
SHA1 (patch-aa) = c5eeea229195a43c964c04445206977f8af1211b
SHA1 (figlet221.tar.gz) = f11ee2e158959bed59410e4eb2c2bd3da597dbf1
Size (figlet221.tar.gz) = 172219 bytes
SHA1 (patch-aa) = a71d5b7bd8e296b7e17bb94b7156dee3bbf98b55

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.3 2001/04/27 10:06:13 abs Exp $
$NetBSD: patch-aa,v 1.4 2002/07/19 08:00:48 agc Exp $
--- Makefile.orig Tue Feb 18 23:02:28 1997
+++ Makefile
@@ -10,18 +10,18 @@
--- Makefile.orig Sat Jul 13 11:24:16 2002
+++ Makefile Fri Jul 19 08:54:54 2002
@@ -12,18 +12,18 @@
# for changing this is if sh is not in the same place.
SHELL = /bin/sh
CC = gcc
@ -10,31 +10,25 @@ $NetBSD: patch-aa,v 1.3 2001/04/27 10:06:13 abs Exp $
+#CFLAGS = -g
# Where the executables should be put
-DESTDIR = /usr/games
+DESTDIR = $(PREFIX)/bin
-DESTDIR = /usr/local/bin
+DESTDIR = ${PREFIX}/bin
# Where the man page should be put
-MANDIR = /usr/man/man6
+MANDIR = $(PREFIX)/man/man6
-MANDIR = /usr/local/man/man6
+MANDIR = ${PREFIX}/man/man6
# Where figlet will search first for fonts (the ".flf" files).
-DEFAULTFONTDIR = $(DESTDIR)/lib/figlet.dir
+#DEFAULTFONTDIR = $(DESTDIR)/lib/figlet.dir
# Use this definition if you can't put things in /usr/games
-DEFAULTFONTDIR = /usr/local/share/figlet
+DEFAULTFONTDIR = ${PREFIX}/share/figlet
# Use this definition if you can't put things in /usr/local/share/figlet
-DEFAULTFONTDIR = fonts
+DEFAULTFONTDIR = $(PREFIX)/share/figlet
+#DEFAULTFONTDIR = fonts
# The filename of the font to be used if no other is specified
# (standard.flf is recommended, but any other can be used).
@@ -50,9 +50,12 @@
rm -f *.o figlet chkfont
install: figlet chkfont
- mkdir $(DEFAULTFONTDIR)
+ mkdir -p $(DEFAULTFONTDIR)
+ strip figlet
@@ -55,6 +55,7 @@
mkdir -p $(DEFAULTFONTDIR)
cp figlet $(DESTDIR)
+ strip chkfont
cp chkfont $(DESTDIR)
+ chmod 555 figlist showfigfonts
cp figlist $(DESTDIR)