Update to 0.17.1

Submitted by Terin Stock terinjokes AT gmail com
Closes PR pkg/50875

Reviewed by wiz@

2013-08-30: StGit-0.17.1 released
Fix dirty index errors when resolving conflicts.

Test suite improvements.

Print tracebacks to stderr.

Run test suite in parallel.

Fix --authdate date parsing.
This commit is contained in:
sevan 2016-03-18 23:13:26 +00:00
parent 4fa2b9ca52
commit 8473f5dbb1
7 changed files with 181 additions and 121 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.28 2015/12/05 21:25:40 adam Exp $
# $NetBSD: Makefile,v 1.29 2016/03/18 23:13:26 sevan Exp $
DISTNAME= stgit-0.14.3
PKGREVISION= 9
DISTNAME= stgit-0.17.1
PKGREVISION= 10
CATEGORIES= devel
MASTER_SITES= http://homepage.ntlworld.com/cmarinas/stgit/
MASTER_SITES= http://download.gna.org/stgit/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.procode.org/stgit/
@ -60,7 +60,6 @@ post-install:
${INSTALL_SCRIPT} stg-* ${DESTDIR}${PREFIX}/bin
cd ${WRKSRC}/Documentation && \
${INSTALL_MAN} *.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1 && \
${INSTALL_DATA} *.html \
${DESTDIR}${PREFIX}/share/doc/${PKGBASE}/html
${INSTALL_DATA} *.html ${DESTDIR}/${PREFIX}/share/doc/${PKGBASE}/html
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2012/04/08 20:21:48 wiz Exp $
@comment $NetBSD: PLIST,v 1.10 2016/03/18 23:13:26 sevan Exp $
bin/stg
bin/stg-cvs
bin/stg-dispatch
@ -11,22 +11,22 @@ bin/stg-show-old
bin/stg-swallow
bin/stg-unnew
bin/stg-whatchanged
${PYSITELIB}/${EGG_FILE}
${PYSITELIB}/${PKGNAME}_dirty-py2.7.egg-info
${PYSITELIB}/stgit/__init__.py
${PYSITELIB}/stgit/__init__.pyc
${PYSITELIB}/stgit/__init__.pyo
${PYSITELIB}/stgit/argparse.py
${PYSITELIB}/stgit/argparse.pyc
${PYSITELIB}/stgit/argparse.pyo
${PYSITELIB}/stgit/basedir.py
${PYSITELIB}/stgit/basedir.pyc
${PYSITELIB}/stgit/basedir.pyo
${PYSITELIB}/stgit/builtin_version.py
${PYSITELIB}/stgit/builtin_version.pyc
${PYSITELIB}/stgit/builtin_version.pyo
${PYSITELIB}/stgit/commands/__init__.py
${PYSITELIB}/stgit/commands/__init__.pyc
${PYSITELIB}/stgit/commands/__init__.pyo
${PYSITELIB}/stgit/commands/add.py
${PYSITELIB}/stgit/commands/add.pyc
${PYSITELIB}/stgit/commands/add.pyo
${PYSITELIB}/stgit/commands/applied.py
${PYSITELIB}/stgit/commands/applied.pyc
${PYSITELIB}/stgit/commands/applied.pyo
${PYSITELIB}/stgit/commands/branch.py
${PYSITELIB}/stgit/commands/branch.pyc
${PYSITELIB}/stgit/commands/branch.pyo
@ -36,15 +36,15 @@ ${PYSITELIB}/stgit/commands/clean.pyo
${PYSITELIB}/stgit/commands/clone.py
${PYSITELIB}/stgit/commands/clone.pyc
${PYSITELIB}/stgit/commands/clone.pyo
${PYSITELIB}/stgit/commands/cmdlist.py
${PYSITELIB}/stgit/commands/cmdlist.pyc
${PYSITELIB}/stgit/commands/cmdlist.pyo
${PYSITELIB}/stgit/commands/commit.py
${PYSITELIB}/stgit/commands/commit.pyc
${PYSITELIB}/stgit/commands/commit.pyo
${PYSITELIB}/stgit/commands/common.py
${PYSITELIB}/stgit/commands/common.pyc
${PYSITELIB}/stgit/commands/common.pyo
${PYSITELIB}/stgit/commands/copy.py
${PYSITELIB}/stgit/commands/copy.pyc
${PYSITELIB}/stgit/commands/copy.pyo
${PYSITELIB}/stgit/commands/delete.py
${PYSITELIB}/stgit/commands/delete.pyc
${PYSITELIB}/stgit/commands/delete.pyo
@ -90,6 +90,9 @@ ${PYSITELIB}/stgit/commands/mail.pyo
${PYSITELIB}/stgit/commands/new.py
${PYSITELIB}/stgit/commands/new.pyc
${PYSITELIB}/stgit/commands/new.pyo
${PYSITELIB}/stgit/commands/next.py
${PYSITELIB}/stgit/commands/next.pyc
${PYSITELIB}/stgit/commands/next.pyo
${PYSITELIB}/stgit/commands/patches.py
${PYSITELIB}/stgit/commands/patches.pyc
${PYSITELIB}/stgit/commands/patches.pyo
@ -99,6 +102,12 @@ ${PYSITELIB}/stgit/commands/pick.pyo
${PYSITELIB}/stgit/commands/pop.py
${PYSITELIB}/stgit/commands/pop.pyc
${PYSITELIB}/stgit/commands/pop.pyo
${PYSITELIB}/stgit/commands/prev.py
${PYSITELIB}/stgit/commands/prev.pyc
${PYSITELIB}/stgit/commands/prev.pyo
${PYSITELIB}/stgit/commands/publish.py
${PYSITELIB}/stgit/commands/publish.pyc
${PYSITELIB}/stgit/commands/publish.pyo
${PYSITELIB}/stgit/commands/pull.py
${PYSITELIB}/stgit/commands/pull.pyc
${PYSITELIB}/stgit/commands/pull.pyo
@ -108,6 +117,9 @@ ${PYSITELIB}/stgit/commands/push.pyo
${PYSITELIB}/stgit/commands/rebase.py
${PYSITELIB}/stgit/commands/rebase.pyc
${PYSITELIB}/stgit/commands/rebase.pyo
${PYSITELIB}/stgit/commands/redo.py
${PYSITELIB}/stgit/commands/redo.pyc
${PYSITELIB}/stgit/commands/redo.pyo
${PYSITELIB}/stgit/commands/refresh.py
${PYSITELIB}/stgit/commands/refresh.pyc
${PYSITELIB}/stgit/commands/refresh.pyo
@ -117,12 +129,9 @@ ${PYSITELIB}/stgit/commands/rename.pyo
${PYSITELIB}/stgit/commands/repair.py
${PYSITELIB}/stgit/commands/repair.pyc
${PYSITELIB}/stgit/commands/repair.pyo
${PYSITELIB}/stgit/commands/resolved.py
${PYSITELIB}/stgit/commands/resolved.pyc
${PYSITELIB}/stgit/commands/resolved.pyo
${PYSITELIB}/stgit/commands/rm.py
${PYSITELIB}/stgit/commands/rm.pyc
${PYSITELIB}/stgit/commands/rm.pyo
${PYSITELIB}/stgit/commands/reset.py
${PYSITELIB}/stgit/commands/reset.pyc
${PYSITELIB}/stgit/commands/reset.pyo
${PYSITELIB}/stgit/commands/series.py
${PYSITELIB}/stgit/commands/series.pyc
${PYSITELIB}/stgit/commands/series.pyo
@ -132,24 +141,27 @@ ${PYSITELIB}/stgit/commands/show.pyo
${PYSITELIB}/stgit/commands/sink.py
${PYSITELIB}/stgit/commands/sink.pyc
${PYSITELIB}/stgit/commands/sink.pyo
${PYSITELIB}/stgit/commands/status.py
${PYSITELIB}/stgit/commands/status.pyc
${PYSITELIB}/stgit/commands/status.pyo
${PYSITELIB}/stgit/commands/squash.py
${PYSITELIB}/stgit/commands/squash.pyc
${PYSITELIB}/stgit/commands/squash.pyo
${PYSITELIB}/stgit/commands/sync.py
${PYSITELIB}/stgit/commands/sync.pyc
${PYSITELIB}/stgit/commands/sync.pyo
${PYSITELIB}/stgit/commands/top.py
${PYSITELIB}/stgit/commands/top.pyc
${PYSITELIB}/stgit/commands/top.pyo
${PYSITELIB}/stgit/commands/unapplied.py
${PYSITELIB}/stgit/commands/unapplied.pyc
${PYSITELIB}/stgit/commands/unapplied.pyo
${PYSITELIB}/stgit/commands/uncommit.py
${PYSITELIB}/stgit/commands/uncommit.pyc
${PYSITELIB}/stgit/commands/uncommit.pyo
${PYSITELIB}/stgit/commands/undo.py
${PYSITELIB}/stgit/commands/undo.pyc
${PYSITELIB}/stgit/commands/undo.pyo
${PYSITELIB}/stgit/commands/unhide.py
${PYSITELIB}/stgit/commands/unhide.pyc
${PYSITELIB}/stgit/commands/unhide.pyo
${PYSITELIB}/stgit/completion.py
${PYSITELIB}/stgit/completion.pyc
${PYSITELIB}/stgit/completion.pyo
${PYSITELIB}/stgit/config.py
${PYSITELIB}/stgit/config.pyc
${PYSITELIB}/stgit/config.pyo
@ -159,9 +171,27 @@ ${PYSITELIB}/stgit/exception.pyo
${PYSITELIB}/stgit/git.py
${PYSITELIB}/stgit/git.pyc
${PYSITELIB}/stgit/git.pyo
${PYSITELIB}/stgit/gitmergeonefile.py
${PYSITELIB}/stgit/gitmergeonefile.pyc
${PYSITELIB}/stgit/gitmergeonefile.pyo
${PYSITELIB}/stgit/lib/__init__.py
${PYSITELIB}/stgit/lib/__init__.pyc
${PYSITELIB}/stgit/lib/__init__.pyo
${PYSITELIB}/stgit/lib/edit.py
${PYSITELIB}/stgit/lib/edit.pyc
${PYSITELIB}/stgit/lib/edit.pyo
${PYSITELIB}/stgit/lib/git.py
${PYSITELIB}/stgit/lib/git.pyc
${PYSITELIB}/stgit/lib/git.pyo
${PYSITELIB}/stgit/lib/log.py
${PYSITELIB}/stgit/lib/log.pyc
${PYSITELIB}/stgit/lib/log.pyo
${PYSITELIB}/stgit/lib/stack.py
${PYSITELIB}/stgit/lib/stack.pyc
${PYSITELIB}/stgit/lib/stack.pyo
${PYSITELIB}/stgit/lib/stackupgrade.py
${PYSITELIB}/stgit/lib/stackupgrade.pyc
${PYSITELIB}/stgit/lib/stackupgrade.pyo
${PYSITELIB}/stgit/lib/transaction.py
${PYSITELIB}/stgit/lib/transaction.pyc
${PYSITELIB}/stgit/lib/transaction.pyo
${PYSITELIB}/stgit/main.py
${PYSITELIB}/stgit/main.pyc
${PYSITELIB}/stgit/main.pyo
@ -184,24 +214,98 @@ ${PYSITELIB}/stgit/version.py
${PYSITELIB}/stgit/version.pyc
${PYSITELIB}/stgit/version.pyo
man/man1/stg-branch.1
man/man1/stg-clean.1
man/man1/stg-clone.1
man/man1/stg-cp.1
man/man1/stg-commit.1
man/man1/stg-delete.1
man/man1/stg-diff.1
man/man1/stg-edit.1
man/man1/stg-export.1
man/man1/stg-files.1
man/man1/stg-float.1
man/man1/stg-fold.1
man/man1/stg-goto.1
man/man1/stg-hide.1
man/man1/stg-id.1
man/man1/stg-import.1
man/man1/stg-init.1
man/man1/stg-log.1
man/man1/stg-mail.1
man/man1/stg-new.1
man/man1/stg-next.1
man/man1/stg-patches.1
man/man1/stg-pick.1
man/man1/stg-pop.1
man/man1/stg-prev.1
man/man1/stg-publish.1
man/man1/stg-pull.1
man/man1/stg-push.1
man/man1/stg-rebase.1
man/man1/stg-redo.1
man/man1/stg-refresh.1
man/man1/stg-rename.1
man/man1/stg-repair.1
man/man1/stg-reset.1
man/man1/stg-series.1
man/man1/stg-show.1
man/man1/stg-sink.1
man/man1/stg-squash.1
man/man1/stg-sync.1
man/man1/stg-top.1
man/man1/stg-uncommit.1
man/man1/stg-undo.1
man/man1/stg-unhide.1
man/man1/stg.1
share/doc/stgit/html/stg-branch.html
share/doc/stgit/html/stg-clean.html
share/doc/stgit/html/stg-clone.html
share/doc/stgit/html/stg-cp.html
share/doc/stgit/html/stg-commit.html
share/doc/stgit/html/stg-delete.html
share/doc/stgit/html/stg-diff.html
share/doc/stgit/html/stg-edit.html
share/doc/stgit/html/stg-export.html
share/doc/stgit/html/stg-files.html
share/doc/stgit/html/stg-float.html
share/doc/stgit/html/stg-fold.html
share/doc/stgit/html/stg-goto.html
share/doc/stgit/html/stg-hide.html
share/doc/stgit/html/stg-id.html
share/doc/stgit/html/stg-import.html
share/doc/stgit/html/stg-init.html
share/doc/stgit/html/stg-log.html
share/doc/stgit/html/stg-mail.html
share/doc/stgit/html/stg-new.html
share/doc/stgit/html/stg-next.html
share/doc/stgit/html/stg-patches.html
share/doc/stgit/html/stg-pick.html
share/doc/stgit/html/stg-pop.html
share/doc/stgit/html/stg-prev.html
share/doc/stgit/html/stg-publish.html
share/doc/stgit/html/stg-pull.html
share/doc/stgit/html/stg-push.html
share/doc/stgit/html/stg-rebase.html
share/doc/stgit/html/stg-redo.html
share/doc/stgit/html/stg-refresh.html
share/doc/stgit/html/stg-rename.html
share/doc/stgit/html/stg-repair.html
share/doc/stgit/html/stg-reset.html
share/doc/stgit/html/stg-series.html
share/doc/stgit/html/stg-show.html
share/doc/stgit/html/stg-sink.html
share/doc/stgit/html/stg-squash.html
share/doc/stgit/html/stg-sync.html
share/doc/stgit/html/stg-top.html
share/doc/stgit/html/stg-uncommit.html
share/doc/stgit/html/stg-undo.html
share/doc/stgit/html/stg-unhide.html
share/doc/stgit/html/stg.html
share/doc/stgit/html/tutorial.html
share/examples/stgit/gitconfig
share/stgit/completion/stgit-completion.bash
share/stgit/contrib/stgbashprompt.sh
share/stgit/contrib/stgit-completion.bash
share/stgit/examples/gitconfig
share/stgit/examples/patchdescr.tmpl
share/stgit/templates/covermail.tmpl
share/stgit/templates/mailattch.tmpl
share/stgit/templates/patchandattch.tmpl
share/stgit/templates/patchexport.tmpl
share/stgit/templates/patchmail.tmpl

View file

@ -1,10 +1,7 @@
$NetBSD: distinfo,v 1.10 2015/11/03 03:29:34 agc Exp $
$NetBSD: distinfo,v 1.11 2016/03/18 23:13:26 sevan Exp $
SHA1 (stgit-0.14.3.tar.gz) = 9ea2e859281f8fe3cbb7f2bd9fd83b9846923cbe
RMD160 (stgit-0.14.3.tar.gz) = 5ed7ab18a3f98269c3fc29e4d1dd353171add7d9
SHA512 (stgit-0.14.3.tar.gz) = 1b45d6b4799339c6882b1e5f512a21a67d3c912133c4d50ea27009fd5d241a04acbf1ff756094582386b12fb81942c94d7011a26e0f9ec6a464f9b47e5638482
Size (stgit-0.14.3.tar.gz) = 227645 bytes
SHA1 (patch-aa) = 364103963f8e74eee12dbd548b4ed48b349b662f
SHA1 (patch-ab) = 4808d98409c39cd6af33aad1b318a8df41c9cfec
SHA1 (patch-ac) = ce1df6ab709c4c4e27b96491a8fc37669c593cb0
SHA1 (patch-ad) = 71d7a3c7e71512a84231f08574713390f1db300d
SHA1 (stgit-0.17.1.tar.gz) = 5918fd983919ab70ab191868b84e917a06556cc2
RMD160 (stgit-0.17.1.tar.gz) = 74cfb72865b3c290613ca355d360b47baa1c8351
SHA512 (stgit-0.17.1.tar.gz) = 3efdfb9bc024c3a7c0d74d49e85f157d5d5209c9a2ad0ce63a07138c02fb1580e92ac4a91796e79bbd221e6884317e975f9f44e35db0b484fd916bc67cd61abe
Size (stgit-0.17.1.tar.gz) = 398466 bytes
SHA1 (patch-aa) = 83bf9651149e53ef9264a6d98d4e4e9faf3692cf

View file

@ -1,17 +1,37 @@
$NetBSD: patch-aa,v 1.1 2008/01/10 06:35:49 bjs Exp $
$NetBSD: patch-aa,v 1.2 2016/03/18 23:13:26 sevan Exp $
--- contrib/stg-gitk.orig 2007-12-11 18:54:04.000000000 -0500
+++ contrib/stg-gitk
@@ -48,10 +48,10 @@ if [ $allbranches = 1 ]; then
refdirs="$GIT_DIR/refs"
else
# default to current branch
- if [ "$branches" == "" ]; then
+ if [ "$branches" = "" ]; then
branches="$(stg branch)"
fi
- if [ "$branches" == "" ]; then
+ if [ "$branches" = "" ]; then
echo >&2 "ERROR: cannot find current branch."
exit 1
fi
Honor PYTHON settings in Documentation Makefile.
Backport of commit e22723c8ee19cf1bb4fdf68b2f1207442ab59e39
Allow ASCIIDOC_EXTRA to be overridden
--- Documentation/Makefile.orig 2009-10-26 16:09:04.000000000 +0000
+++ Documentation/Makefile
@@ -1,4 +1,4 @@
-COMMANDS = $(shell ../stg-build --commands)
+COMMANDS = $(shell $(PYTHON) ../stg-build --commands)
COMMANDS_TXT = $(patsubst %,stg-%.txt,$(COMMANDS))
MAN1_TXT= stg.txt $(COMMANDS_TXT)
@@ -19,7 +19,7 @@ man1dir=$(mandir)/man1
# DESTDIR=
ASCIIDOC=asciidoc --unsafe
-ASCIIDOC_EXTRA =
+ASCIIDOC_EXTRA ?=
INSTALL?=install
#
@@ -63,10 +63,10 @@ clean:
ALL_PY = $(shell find ../stgit -name '*.py')
$(COMMANDS_TXT): $(ALL_PY)
- ../stg-build --asciidoc $(basename $(subst stg-,,$@)) > $@
+ $(PYTHON) ../stg-build --asciidoc $(basename $(subst stg-,,$@)) > $@
command-list.txt: $(ALL_PY)
- ../stg-build --cmd-list > $@
+ $(PYTHON) ../stg-build --cmd-list > $@
%.html : %.txt
$(ASCIIDOC) -b xhtml11 -d manpage -f asciidoc.conf $(ASCIIDOC_EXTRA) $<

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ab,v 1.2 2008/04/10 12:11:34 bjs Exp $
--- setup.py.orig 2008-03-24 15:21:30.000000000 -0400
+++ setup.py
@@ -62,10 +62,8 @@ setup(name = 'stgit',
scripts = ['stg'],
packages = ['stgit', 'stgit.commands'],
data_files = [('share/stgit/templates', glob.glob('templates/*.tmpl')),
- ('share/stgit/examples', glob.glob('examples/*.tmpl')),
- ('share/stgit/examples', ['examples/gitconfig']),
- ('share/stgit/contrib', ['contrib/diffcol.sh',
- 'contrib/stgbashprompt.sh',
+ ('share/examples/stgit', ['examples/gitconfig']),
+ ('share/stgit/contrib', ['contrib/stgbashprompt.sh',
'contrib/stgit-completion.bash']),
('share/doc/stgit', glob.glob('doc/*.txt'))]
)

View file

@ -1,31 +0,0 @@
$NetBSD: patch-ac,v 1.2 2008/07/25 04:00:59 bjs Exp $
--- Documentation/Makefile.orig 2007-07-25 19:49:46.000000000 -0400
+++ Documentation/Makefile 2008-02-11 14:55:30.000000000 -0500
@@ -20,7 +20,7 @@
# DESTDIR=
ASCIIDOC=asciidoc --unsafe
-ASCIIDOC_EXTRA =
+#ASCIIDOC_EXTRA =
INSTALL?=install
#
@@ -44,9 +44,14 @@
man7: $(DOC_MAN7)
install: man
- $(INSTALL) -d -m755 $(DESTDIR)$(man1dir) $(DESTDIR)$(man7dir)
- $(INSTALL) -m644 $(DOC_MAN1) $(DESTDIR)$(man1dir)
- $(INSTALL) -m644 $(DOC_MAN7) $(DESTDIR)$(man7dir)
+ $(BSD_INSTALL_MAN_DIR) $(DESTDIR)$(man1dir)
+ $(BSD_INSTALL_MAN_DIR) $(DESTDIR)$(man7dir)
+ for fn in $(DOC_MAN1); do \
+ $(BSD_INSTALL_MAN) $$fn $(DESTDIR)$(man1dir); \
+ done
+ for fn in $(DOC_MAN7); do \
+ $(BSD_INSTALL_MAN) $$fn $(DESTDIR)$(man7dir); \
+ done
#
# Determine "include::" file references in asciidoc files.
#

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ad,v 1.1 2011/01/21 13:09:51 dmcmahill Exp $
Remove level 0 markup which is not allowed for an 'article' document.
--- Documentation/tutorial.txt.orig 2011-01-21 12:56:56.000000000 +0000
+++ Documentation/tutorial.txt 2011-01-21 12:57:06.000000000 +0000
@@ -1,4 +1,4 @@
StGIT Tutorial
-##############
+===============