make it build on DragonFly/FreeBSD, from Hasso Tepper per PR pkg/38832

This commit is contained in:
drochner 2008-06-02 16:46:42 +00:00
parent 387d487697
commit 847b66bcf7
3 changed files with 50 additions and 1 deletions

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2008/05/15 20:06:03 drochner Exp $
$NetBSD: distinfo,v 1.2 2008/06/02 16:46:42 drochner Exp $
SHA1 (PDFlib-Lite-7.0.3.tar.gz) = f63950303de23b9c13e9fdf5d6aa6ecae1ddc542
RMD160 (PDFlib-Lite-7.0.3.tar.gz) = 90f91e2ff08e0280dce63801899162411889f0b7
Size (PDFlib-Lite-7.0.3.tar.gz) = 5898798 bytes
SHA1 (patch-aa) = a01fa6d85d550f203982a17a898929a8cd94a492
SHA1 (patch-ab) = b6278ca1573225e4cd462b88064a800acd19d504

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1 2008/06/02 16:46:42 drochner Exp $
--- libs/pdflib/p_document.c.orig 2008-06-02 12:35:41 +0300
+++ libs/pdflib/p_document.c 2008-06-02 12:39:01 +0300
@@ -1358,7 +1358,11 @@ pdf__begin_document(PDF *p, const char *
#endif
doc->fp = fp;
+#ifdef __DragonFly__
+ doc->len = sizeof(struct __FILE_public);
+#else
doc->len = sizeof(FILE);
+#endif
}
else if (filename && (*filename || len > 0))
{

View file

@ -0,0 +1,31 @@
$NetBSD: patch-ab,v 1.1 2008/06/02 16:46:42 drochner Exp $
--- configure.orig 2008-06-02 13:09:29 +0300
+++ configure 2008-06-02 13:13:20 +0300
@@ -3839,7 +3839,7 @@ darwin* | rhapsody*)
esac
;;
-freebsd*)
+freebsd*|dragonfly*)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
case $host_cpu in
i*86 )
@@ -6113,7 +6113,7 @@ else
;;
# FreeBSD 3 and greater uses gcc -shared to do shared libraries.
- freebsd*)
+ freebsd*|dragonfly*)
archive_cmds='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
hardcode_libdir_flag_spec='-R$libdir'
hardcode_direct=yes
@@ -6576,7 +6576,7 @@ freebsd1*)
dynamic_linker=no
;;
-freebsd*)
+freebsd*|dragonfly*)
objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
version_type=freebsd-$objformat
case $version_type in