- Update to scanssh 2.0

- ok'ed snj@/wiz@

From the ChangeLog:
Supports open proxy detection.
High performance by using libevent.
This commit is contained in:
adrianp 2004-08-17 19:43:22 +00:00
parent 85acf5592e
commit 8488b0fc47
4 changed files with 20 additions and 16 deletions

View file

@ -1,3 +1,6 @@
scanssh scans the given addresses and networks for running SSH
servers. It will query their version number and displays the
results in a list.
ScanSSH supports scanning a list of addresses and networks for open proxies,
SSH protocol servers, Web and SMTP servers. Where possible ScanSSH, displays
the version number of the running services. ScanSSH protocol scanner supports
random selection of IP addresses from large network ranges and is useful for
gathering statistics on the deployment of SSH protocol servers in a company
or the Internet as whole.

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.12 2004/06/27 11:42:43 grant Exp $
# $NetBSD: Makefile,v 1.13 2004/08/17 19:43:22 adrianp Exp $
DISTNAME= scanssh-1.6b
DISTNAME= scanssh-2.0
CATEGORIES= security
MASTER_SITES= http://monkey.org/~provos/ \
ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/scanssh/
@ -9,9 +9,10 @@ MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://monkey.org/~provos/scanssh/
COMMENT= SSH remote version scanner
WRKSRC= ${WRKDIR}/scanssh
GNU_CONFIGURE= yes
USE_BUILDLINK3= yes
.include "../../devel/libevent/buildlink3.mk"
.include "../../net/libpcap/buildlink3.mk"
.include "../../net/libdnet/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.3 2001/12/06 11:32:47 martti Exp $
$NetBSD: distinfo,v 1.4 2004/08/17 19:43:22 adrianp Exp $
SHA1 (scanssh-1.6b.tar.gz) = 010eb75bf12717471b96c157fdad2d9e4ab27dce
Size (scanssh-1.6b.tar.gz) = 51064 bytes
SHA1 (patch-aa) = c4a6f3ea305c4f5fc795c181c3a27c091291925e
SHA1 (scanssh-2.0.tar.gz) = 596b8fd7654109863edd245f50ed14d30aa87ead
Size (scanssh-2.0.tar.gz) = 85694 bytes
SHA1 (patch-aa) = 1ddaafe6b8d65d44f8bf5a54c2d10548a6455a00

View file

@ -1,16 +1,16 @@
$NetBSD: patch-aa,v 1.1 2001/01/18 04:55:31 hubertf Exp $
$NetBSD: patch-aa,v 1.2 2004/08/17 19:43:22 adrianp Exp $
--- exclude.h.orig Wed Sep 6 19:25:43 2000
+++ exclude.h
--- exclude.h.orig Tue Mar 16 08:32:44 2004
+++ exclude.h Mon Aug 16 20:36:27 2004
@@ -28,6 +28,11 @@
#ifndef _EXCLUDE_H_
#define _EXCLUDE_H_
+#ifndef sa_family_t
+typedef int sa_family_t; /* NetBSD 1.5 needs this */
+#define sa_family_t int /* dito, taken from -current */
+typedef int sa_family_t; /* NetBSD 1.5 needs this */
+#define sa_family_t int /* ditto, taken from -current */
+#endif
+
struct exclude {
TAILQ_ENTRY (exclude) e_next;
sa_family_t e_type;