security/gsasl: Remove windows function

gss-extra.c fails compilation on DragonFly:
line 43: error: unexpected identifier or '(' before '&' token

It's on code that is only intended for a windows target. Gentoo patched
it by wrapping it in "if (defined _WIN32 || defined __WIN32__)" macro
which is effectively the same is deleting the definition completely,
which is what is being done here.
This commit is contained in:
marino 2011-11-24 09:04:18 +00:00
parent b0545da1b7
commit 8489fee2a9
3 changed files with 25 additions and 2 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.32 2011/06/01 10:05:57 adam Exp $ # $NetBSD: Makefile,v 1.33 2011/11/24 09:04:18 marino Exp $
DISTNAME= gsasl-1.6.1 DISTNAME= gsasl-1.6.1
PKGREVISION= 1
CATEGORIES= security CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU:=gsasl/} MASTER_SITES= ${MASTER_SITE_GNU:=gsasl/}

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.15 2011/06/01 10:05:57 adam Exp $ $NetBSD: distinfo,v 1.16 2011/11/24 09:04:18 marino Exp $
SHA1 (gsasl-1.6.1.tar.gz) = 5439fd32ac975c36015263fafdc79ededdd57c72 SHA1 (gsasl-1.6.1.tar.gz) = 5439fd32ac975c36015263fafdc79ededdd57c72
RMD160 (gsasl-1.6.1.tar.gz) = 510661e88a41300ad3b32dd4a6bd6236aab28c78 RMD160 (gsasl-1.6.1.tar.gz) = 510661e88a41300ad3b32dd4a6bd6236aab28c78
Size (gsasl-1.6.1.tar.gz) = 4623634 bytes Size (gsasl-1.6.1.tar.gz) = 4623634 bytes
SHA1 (patch-ac) = 8ce0f4e970a220127c1f199d7a492501ac054bc8

View file

@ -0,0 +1,21 @@
$NetBSD: patch-ac,v 1.1 2011/11/24 09:04:18 marino Exp $
--- lib/gl/gss-extra.c.orig 2010-12-14 12:57:08.000000000 +0000
+++ lib/gl/gss-extra.c
@@ -33,16 +33,6 @@
/* Get malloc, free. */
#include <stdlib.h>
-#ifndef HAVE_GSS_C_NT_HOSTBASED_SERVICE
-
-/* MIT Kerberos for Windows version 3.2.2 lacks this. */
-static gss_OID_desc tmp = {
- 10,
- (void *)"\x2a\x86\x48\x86\xf7\x12\x01\x02\x01\x04"
-};
-gss_OID GSS_C_NT_HOSTBASED_SERVICE = &tmp;
-
-#endif
#ifndef HAVE_GSS_OID_EQUAL