Update to V0.4. Changes:
Added terminal type checking, and the override (-f) switch
This commit is contained in:
parent
44fd2044dc
commit
848a3440f8
5 changed files with 42 additions and 31 deletions
|
@ -1,22 +1,24 @@
|
|||
# $NetBSD: Makefile,v 1.3 1999/01/30 23:18:58 agc Exp $
|
||||
# $NetBSD: Makefile,v 1.4 1999/08/21 04:02:44 hubertf Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xtermset-0.2
|
||||
DISTNAME= xtermset-0.4
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.cs.vu.nl/~bernsti/xtermset/src/
|
||||
MASTER_SITES= http://xtermset.netpedia.net/src/
|
||||
|
||||
MAINTAINER= hubertf@netbsd.org
|
||||
HOMEPAGE= http://www.cs.vu.nl/~bernsti/xtermset/
|
||||
HOMEPAGE= http://xtermset.netpedia.net/
|
||||
|
||||
USE_X11BASE= YES
|
||||
|
||||
post-extract:
|
||||
cd ${WRKSRC} ; gunzip xtermset.1.gz
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/xtermset
|
||||
${INSTALL_DATA} ${WRKSRC}/ctlseqs.ms ${PREFIX}/share/doc/xtermset
|
||||
nroff -ms ${WRKSRC}/ctlseqs.ms >${WRKSRC}/ctlseqs.0
|
||||
${INSTALL_DATA} ${WRKSRC}/ctlseqs.0 ${PREFIX}/share/doc/xtermset
|
||||
${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/xtermset
|
||||
${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/xtermset
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xtermset
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.2 1999/01/07 23:43:41 hubertf Exp $
|
||||
$NetBSD: md5,v 1.3 1999/08/21 04:02:44 hubertf Exp $
|
||||
|
||||
MD5 (xtermset-0.2.tar.gz) = 3675441574fe7fcbd75da28a3a73c94b
|
||||
MD5 (xtermset-0.4.tar.gz) = 12ec8aef6947510bd591268beba365a2
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1 1999/07/09 14:23:38 agc Exp $
|
||||
$NetBSD: patch-sum,v 1.2 1999/08/21 04:02:45 hubertf Exp $
|
||||
|
||||
MD5 (patch-aa) = b4785952e3a6a51f69b887ab10b8bf51
|
||||
MD5 (patch-aa) = 0707267b4271d1d5dda0a7502d869e22
|
||||
|
|
|
@ -1,22 +1,32 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/01/02 13:04:46 hubertf Exp $
|
||||
|
||||
--- Makefile.orig Fri Jan 1 20:57:16 1999
|
||||
+++ Makefile Sat Jan 2 13:36:26 1999
|
||||
@@ -1,10 +1,10 @@
|
||||
CC=gcc
|
||||
CFLAGS=-O2 -Wall
|
||||
INSTALL=/usr/bin/install -c
|
||||
-PREFIX=/usr/local
|
||||
+#PREFIX=/usr/local
|
||||
--- Makefile.orig Thu Jan 14 00:02:56 1999
|
||||
+++ Makefile Sat Aug 21 05:50:20 1999
|
||||
@@ -1,7 +1,7 @@
|
||||
CC = gcc
|
||||
-CFLAGS = -O2 -Wall
|
||||
+CFLAGS+= -O2 -Wall
|
||||
OBJS = xtermset.o
|
||||
-PREFIX = /usr/local
|
||||
+#PREFIX = /usr/local
|
||||
|
||||
all: xtermset.o
|
||||
- ${CC} -o xtermset $<
|
||||
+ ${CC} -o xtermset ${.ALLSRC}
|
||||
DOCSRC = ctlseqs.ms
|
||||
DOCOUT = ctlseqs.ps
|
||||
@@ -9,15 +9,12 @@
|
||||
|
||||
clean:
|
||||
rm -f *.o xtermset core *~
|
||||
@@ -13,4 +13,3 @@
|
||||
${INSTALL} -m 0755 xtermset ${PREFIX}/bin
|
||||
strip ${PREFIX}/bin/xtermset
|
||||
${INSTALL} -m 0644 xtermset.1 ${PREFIX}/man/man1
|
||||
- gzip ${PREFIX}/man/man1/xtermset.1
|
||||
all: xtermset
|
||||
|
||||
-xtermset: $(OBJS)
|
||||
- $(CC) $(OBJS) -o xtermset
|
||||
-
|
||||
-$(OBJS): %.o: %.c
|
||||
- $(CC) -c $(CFLAGS) $<
|
||||
+xtermset:
|
||||
+ $(CC) xtermset.c -o xtermset
|
||||
|
||||
install: xtermset
|
||||
- install -m 0755 -s xtermset $(PREFIX)/bin
|
||||
- install -m 0644 xtermset.1.gz $(PREFIX)/man/man1
|
||||
+ ${BSD_INSTALL_PROGRAM} xtermset $(PREFIX)/bin
|
||||
+ ${BSD_INSTALL_MAN} xtermset.1 $(PREFIX)/man/man1
|
||||
|
||||
doc: $(DOCSRC)
|
||||
groff -mandoc -ms -T$(DOCFMT) $(DOCSRC) > $(DOCOUT)
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/01/02 13:04:46 hubertf Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 1999/08/21 04:02:45 hubertf Exp $
|
||||
bin/xtermset
|
||||
man/man1/xtermset.1
|
||||
share/doc/xtermset/ctlseqs.ms
|
||||
share/doc/xtermset/ctlseqs.0
|
||||
share/doc/xtermset/COPYING
|
||||
share/doc/xtermset/INSTALL
|
||||
share/doc/xtermset/README
|
||||
@dirrm share/doc/xtermset
|
||||
|
|
Loading…
Reference in a new issue