Update to 0.7112

Update DEPENDS

Upstream changes:
Version 0.7112:
- Fix Makefile.PL warning
- Fix deleting of inc during release process
- Better fix for AutomatedTester warning

Version 0.7111:
- Update META.yml

Version 0.7110:
- Trying once again to fix the compile test on windows

Version 0.7109:
- Add missing URI::Escape dependency
- Check in standard tests, including one that skips the compile check on Windows

Version 0.7108:
- Add standard tests
- Fix compatibility issue with newer versions of perl, which remove "." from
  @INC. https://rt.cpan.org/Ticket/Display.html?id=121015
- Fix no_index declaration for delta.pl.
  https://rt.cpan.org/Ticket/Display.html?id=112477
This commit is contained in:
wen 2018-07-20 04:43:24 +00:00
parent b9c1e1d533
commit 84a6206296
3 changed files with 8 additions and 25 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.6 2017/06/05 14:22:18 ryoon Exp $
# $NetBSD: Makefile,v 1.7 2018/07/20 04:43:24 wen Exp $
DISTNAME= Benchmark-Timer-0.7107
DISTNAME= Benchmark-Timer-0.7112
PKGNAME= p5-${DISTNAME}
PKGREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Benchmark/}
@ -11,7 +10,7 @@ HOMEPAGE= http://search.cpan.org/dist/Benchmark-Timer/
COMMENT= Benchmarking with statistical confidence
LICENSE= gnu-gpl-v2
DEPENDS+= p5-Statistics-TTest-[0-9]*:../../math/p5-Statistics-TTest
DEPENDS+= p5-Time-HiRes-[0-9]*:../../time/p5-Time-HiRes
# for make test
BUILD_DEPENDS+= p5-URI-Escape-XS-[0-9]*:../../www/p5-URI-Escape-XS

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.4 2017/06/07 14:29:59 ryoon Exp $
$NetBSD: distinfo,v 1.5 2018/07/20 04:43:24 wen Exp $
SHA1 (Benchmark-Timer-0.7107.tar.gz) = 24132bf428edca54d86cc17f9d0ab598f6099516
RMD160 (Benchmark-Timer-0.7107.tar.gz) = 1232a7ff2b2a4cd2464c90f2276d73464943cc31
SHA512 (Benchmark-Timer-0.7107.tar.gz) = 6faa50a90173a075a4bb398212e2db77348f59a47ff483db9e1885dc7dce9636557684574a21f228c53f0c29a468e663706843840b2e59abbaaed1222f400e05
Size (Benchmark-Timer-0.7107.tar.gz) = 45734 bytes
SHA1 (patch-Makefile.PL) = 36b460c6e958cf7ce3b52025f5ef043c32ead088
SHA1 (Benchmark-Timer-0.7112.tar.gz) = 87b57e07e1845e72d8f494c97ca4b8a1d8175043
RMD160 (Benchmark-Timer-0.7112.tar.gz) = 5385115faff41480e3e2e2fac31f89fefab54b58
SHA512 (Benchmark-Timer-0.7112.tar.gz) = 6ae3ef700a777debb06cb2bbb19c34170e9bd88917c6441a44149f3b8094a5ed1690d727e3fc4e63b48e1bbcab85dd917c6f659ebfad8a8304134ea04e9262eb
Size (Benchmark-Timer-0.7112.tar.gz) = 47756 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-Makefile.PL,v 1.1 2017/06/07 14:29:59 ryoon Exp $
* Fix build with Perl 5.26.0
--- Makefile.PL.orig 2015-04-26 22:40:24.000000000 +0000
+++ Makefile.PL
@@ -5,6 +5,8 @@ use strict;
# For PRIVATE Module::Install extensions
use lib 'private-lib';
+use FindBin;
+use lib $FindBin::Bin;
use inc::Module::Install;
all_from('lib/Benchmark/Timer.pm');