Fix memory leak and pullup bug fix for http://bugs.php.net/bug.php?id=46918
Remove this patch when PHP >= 5.2.9 is released as it will contain these changes Bump PKGREVISION of php-imap
This commit is contained in:
parent
5060504439
commit
84cc8d5c1b
3 changed files with 31 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.59 2009/02/21 17:01:52 adrianp Exp $
|
||||
$NetBSD: distinfo,v 1.60 2009/02/25 08:59:47 sborrill Exp $
|
||||
|
||||
SHA1 (php-5.2.8/php-5.2.8.tar.bz2) = d285636144e0a4aa61195793634807e763c63dc3
|
||||
RMD160 (php-5.2.8/php-5.2.8.tar.bz2) = d38fe5d918c335089a027600a93d950f417a7e98
|
||||
|
@ -16,3 +16,4 @@ SHA1 (patch-an) = 8f4174627b8cb5f8bfbc59413c95f71e26b9e602
|
|||
SHA1 (patch-ap) = 5eb0e0e4244a993da93e36f8fcb5553454207fce
|
||||
SHA1 (patch-aq) = 0c9d48547da2fa80aa8357d23ad8505d1c0330df
|
||||
SHA1 (patch-ar) = 2d74ec926cc00bfbb67d16210af78c33ad9ac38d
|
||||
SHA1 (patch-as) = 7612bf91fe04d980a41dbb0ea652fd50d3b5cebb
|
||||
|
|
27
lang/php5/patches/patch-as
Normal file
27
lang/php5/patches/patch-as
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-as,v 1.4 2009/02/25 08:59:47 sborrill Exp $
|
||||
|
||||
Fix memory leak and pullup bug fix for http://bugs.php.net/bug.php?id=46918
|
||||
|
||||
Remove this patch when PHP >= 5.2.9 is released as it will contain these
|
||||
changes
|
||||
|
||||
--- ext/imap/php_imap.c.orig 2009-02-24 17:45:27.000000000 +0000
|
||||
+++ ext/imap/php_imap.c 2009-02-24 17:47:14.000000000 +0000
|
||||
@@ -2172,7 +2172,7 @@
|
||||
|
||||
/* rfc822_parse_adrlist() modifies passed string. Copy it. */
|
||||
str_copy = estrndup(Z_STRVAL_PP(str), Z_STRLEN_PP(str));
|
||||
- rfc822_parse_adrlist(&env->to, str_copy, defaulthost);
|
||||
+ rfc822_parse_adrlist(&env->to, str_copy, Z_STRVAL_PP(defaulthost));
|
||||
efree(str_copy);
|
||||
|
||||
array_init(return_value);
|
||||
@@ -2196,6 +2196,8 @@
|
||||
}
|
||||
add_next_index_object(return_value, tovals TSRMLS_CC);
|
||||
} while ((addresstmp = addresstmp->next));
|
||||
+
|
||||
+ mail_free_envelope(&env);
|
||||
}
|
||||
/* }}} */
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.17 2009/02/21 17:02:59 adrianp Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2009/02/25 08:59:47 sborrill Exp $
|
||||
|
||||
MODNAME= imap
|
||||
PKGREVISION= 4
|
||||
PKGREVISION= 5
|
||||
CATEGORIES+= mail
|
||||
COMMENT= PHP extension for IMAP (Internet Mailbox Access Protocol)
|
||||
|
||||
|
|
Loading…
Reference in a new issue