calculate the weekday displayed in metadata in a portable way,
so that it shows the correct one on NetBSD bump PKGREVISION
This commit is contained in:
parent
75c4551413
commit
84dbf5e5ee
3 changed files with 16 additions and 2 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.38 2008/12/02 11:39:30 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.39 2008/12/15 19:56:25 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= eog-2.24.2
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/eog/2.24/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.13 2008/12/02 11:39:30 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.14 2008/12/15 19:56:26 drochner Exp $
|
||||
|
||||
SHA1 (eog-2.24.2.tar.bz2) = 0fa538744fe6cea7009bde5b345c27430afeebcb
|
||||
RMD160 (eog-2.24.2.tar.bz2) = bedf11b34b51d7dce88800c1630880040407aa0d
|
||||
Size (eog-2.24.2.tar.bz2) = 2277300 bytes
|
||||
SHA1 (patch-aa) = 092880938f9c91a154f9d97a758f5a25317724c9
|
||||
|
|
12
graphics/eog/patches/patch-aa
Normal file
12
graphics/eog/patches/patch-aa
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.5 2008/12/15 19:56:26 drochner Exp $
|
||||
|
||||
--- src/eog-exif-util.c.orig 2008-10-20 18:31:54.000000000 +0200
|
||||
+++ src/eog-exif-util.c
|
||||
@@ -55,6 +55,7 @@ eog_exif_util_format_date_with_strptime
|
||||
|
||||
if (p == date + strlen (date)) {
|
||||
/* A strftime-formatted string, to display the date the image was taken. */
|
||||
+ mktime(&tm);
|
||||
dlen = strftime (tmp_date, DATE_BUF_SIZE * sizeof(gchar), _("%a, %d %B %Y %X"), &tm);
|
||||
new_date = g_strndup (tmp_date, dlen);
|
||||
}
|
Loading…
Reference in a new issue