Fix C99 inline usage.

This commit is contained in:
joerg 2012-11-01 19:29:20 +00:00
parent a42227b4fc
commit 84f3daa550
2 changed files with 19 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2007/06/12 20:56:55 joerg Exp $
$NetBSD: distinfo,v 1.7 2012/11/01 19:29:20 joerg Exp $
SHA1 (wmtime-1.0b2.tar.gz) = 2a66762d548b9f91415603e8d6a37cfacb9340ad
RMD160 (wmtime-1.0b2.tar.gz) = f267f75237c111ed336521ca175688a33f1e171a
@ -6,3 +6,4 @@ Size (wmtime-1.0b2.tar.gz) = 20680 bytes
SHA1 (patch-aa) = 8943b1da225f26110e52c00269e3e0c6a7651404
SHA1 (patch-ab) = e1e4203a219b0a0d539fc4426ec3d5424e9c3962
SHA1 (patch-ac) = 31d864557165692350436e18c1cba61b95027c2c
SHA1 (patch-wmgeneral_list.h) = d403fc3ff2986c64680f494369dc343c20b6cc20

View file

@ -0,0 +1,17 @@
$NetBSD: patch-wmgeneral_list.h,v 1.1 2012/11/01 19:29:20 joerg Exp $
--- wmgeneral/list.h.orig 2012-10-30 21:09:32.000000000 +0000
+++ wmgeneral/list.h
@@ -29,11 +29,7 @@ Boston, MA 02111-1307, USA. */
#ifndef __LIST_H_
#define __LIST_H_
-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
-# define INLINE inline
-#else
-# define INLINE
-#endif
+#define INLINE
typedef struct LinkedList {
void *head;