geoclue: Update to 2.5.6
Changes many.
This commit is contained in:
parent
3d2c919723
commit
8531b7e3bc
5 changed files with 130 additions and 104 deletions
|
@ -1,32 +1,46 @@
|
|||
# $NetBSD: Makefile,v 1.28 2020/06/02 08:22:41 adam Exp $
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.29 2020/11/04 16:46:59 nia Exp $
|
||||
|
||||
DISTNAME= geoclue-0.12.0
|
||||
PKGREVISION= 21
|
||||
DISTNAME= geoclue-2.5.6
|
||||
CATEGORIES= geography
|
||||
MASTER_SITES= http://folks.o-hand.com/jku/geoclue-releases/
|
||||
MASTER_SITES= https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/${PKGVERSION_NOREV}/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://www.freedesktop.org/wiki/Software/GeoClue
|
||||
HOMEPAGE= https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home
|
||||
COMMENT= Geoinformation service API and base providers
|
||||
LICENSE= gnu-lgpl-v2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config gmake
|
||||
TOOL_DEPENDS+= gdbus-codegen-[0-9]*:../../devel/gdbus-codegen
|
||||
TOOL_DEPENDS+= gtk-doc-[0-9]*:../../textproc/gtk-doc
|
||||
TOOL_DEPENDS+= libxslt-[0-9]*:../../textproc/libxslt
|
||||
|
||||
PKGCONFIG_OVERRIDE+= geoclue.pc.in
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
BUILDLINK_TRANSFORM+= rm:-Werror
|
||||
MESON_ARGS+= -D3g-source=false
|
||||
MESON_ARGS+= -Dcdma-source=false
|
||||
MESON_ARGS+= -Dnmea-source=false
|
||||
MESON_ARGS+= -Dmodem-gps-source=false
|
||||
MESON_ARGS+= -Ddemo-agent=false
|
||||
|
||||
# for documentation build
|
||||
BUILD_DEPENDS+= libxslt-[0-9]*:../../textproc/libxslt
|
||||
PYTHON_FOR_BUILD_ONLY= tool
|
||||
|
||||
#for test
|
||||
#.include "../../x11/gtk2/buildlink3.mk"
|
||||
PKGCONFIG_OVERRIDE_STAGE= pre-install
|
||||
PKGCONFIG_OVERRIDE+= output/meson-private/geoclue-2.0.pc
|
||||
PKGCONFIG_OVERRIDE+= output/meson-private/libgeoclue-2.0.pc
|
||||
|
||||
CONF_FILES+= share/examples/dbus-1/system.d/org.freedesktop.GeoClue2.Agent.conf \
|
||||
${PKG_SYSCONFDIR}/dbus-1/system.d/org.freedesktop.GeoClue2.Agent.conf
|
||||
CONF_FILES+= share/examples/dbus-1/system.d/org.freedesktop.GeoClue2.conf \
|
||||
${PKG_SYSCONFDIR}/dbus-1/system.d/org.freedesktop.GeoClue2.conf
|
||||
CONF_FILES+= share/examples/geoclue/geoclue.conf \
|
||||
${PKG_SYSCONFDIR}/geoclue.conf
|
||||
|
||||
.include "../../devel/meson/build.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/gobject-introspection/buildlink3.mk"
|
||||
.include "../../lang/python/tool.mk"
|
||||
.include "../../lang/vala/buildlink3.mk"
|
||||
.include "../../net/libsoup/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../textproc/json-glib/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../devel/GConf/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,87 +1,76 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/07/26 11:54:34 drochner Exp $
|
||||
include/geoclue/gc-iface-address.h
|
||||
include/geoclue/gc-iface-geoclue.h
|
||||
include/geoclue/gc-iface-geocode.h
|
||||
include/geoclue/gc-iface-position.h
|
||||
include/geoclue/gc-iface-reverse-geocode.h
|
||||
include/geoclue/gc-iface-velocity.h
|
||||
include/geoclue/gc-provider.h
|
||||
include/geoclue/gc-web-service.h
|
||||
include/geoclue/geoclue-accuracy.h
|
||||
include/geoclue/geoclue-address-details.h
|
||||
include/geoclue/geoclue-address.h
|
||||
include/geoclue/geoclue-enum-types.h
|
||||
include/geoclue/geoclue-error.h
|
||||
include/geoclue/geoclue-geocode.h
|
||||
include/geoclue/geoclue-master-client.h
|
||||
include/geoclue/geoclue-master.h
|
||||
include/geoclue/geoclue-position.h
|
||||
include/geoclue/geoclue-provider.h
|
||||
include/geoclue/geoclue-reverse-geocode.h
|
||||
include/geoclue/geoclue-types.h
|
||||
include/geoclue/geoclue-velocity.h
|
||||
lib/libgeoclue.la
|
||||
lib/pkgconfig/geoclue.pc
|
||||
libexec/geoclue-example
|
||||
libexec/geoclue-geonames
|
||||
libexec/geoclue-gsmloc
|
||||
libexec/geoclue-hostip
|
||||
libexec/geoclue-localnet
|
||||
libexec/geoclue-manual
|
||||
libexec/geoclue-master
|
||||
libexec/geoclue-nominatim
|
||||
libexec/geoclue-plazes
|
||||
libexec/geoclue-yahoo
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Master.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Example.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Geonames.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Gsmloc.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Hostip.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Localnet.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Manual.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Nominatim.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Plazes.service
|
||||
share/dbus-1/services/org.freedesktop.Geoclue.Providers.Yahoo.service
|
||||
share/geoclue-providers/geoclue-example.provider
|
||||
share/geoclue-providers/geoclue-geonames.provider
|
||||
share/geoclue-providers/geoclue-gsmloc.provider
|
||||
share/geoclue-providers/geoclue-hostip.provider
|
||||
share/geoclue-providers/geoclue-localnet.provider
|
||||
share/geoclue-providers/geoclue-manual.provider
|
||||
share/geoclue-providers/geoclue-nominatim.provider
|
||||
share/geoclue-providers/geoclue-plazes.provider
|
||||
share/geoclue-providers/geoclue-yahoo.provider
|
||||
share/gtk-doc/html/geoclue/Address.html
|
||||
share/gtk-doc/html/geoclue/Geoclue.html
|
||||
share/gtk-doc/html/geoclue/GeoclueAddress.html
|
||||
share/gtk-doc/html/geoclue/GeoclueGeocode.html
|
||||
share/gtk-doc/html/geoclue/GeoclueMaster.html
|
||||
share/gtk-doc/html/geoclue/GeoclueMasterClient.html
|
||||
share/gtk-doc/html/geoclue/GeocluePosition.html
|
||||
share/gtk-doc/html/geoclue/GeoclueProvider.html
|
||||
share/gtk-doc/html/geoclue/GeoclueReverseGeocode.html
|
||||
share/gtk-doc/html/geoclue/GeoclueVelocity.html
|
||||
share/gtk-doc/html/geoclue/Geocode.html
|
||||
share/gtk-doc/html/geoclue/Master.html
|
||||
share/gtk-doc/html/geoclue/MasterClient.html
|
||||
share/gtk-doc/html/geoclue/Position.html
|
||||
share/gtk-doc/html/geoclue/ReverseGeocode.html
|
||||
share/gtk-doc/html/geoclue/Velocity.html
|
||||
share/gtk-doc/html/geoclue/ch01.html
|
||||
share/gtk-doc/html/geoclue/geoclue-geoclue-accuracy.html
|
||||
share/gtk-doc/html/geoclue/geoclue-geoclue-address-details.html
|
||||
share/gtk-doc/html/geoclue/geoclue-geoclue-error.html
|
||||
share/gtk-doc/html/geoclue/geoclue-geoclue-types.html
|
||||
share/gtk-doc/html/geoclue/geoclue.devhelp
|
||||
@comment $NetBSD: PLIST,v 1.2 2020/11/04 16:46:59 nia Exp $
|
||||
include/libgeoclue-2.0/gclue-client.h
|
||||
include/libgeoclue-2.0/gclue-enum-types.h
|
||||
include/libgeoclue-2.0/gclue-enums.h
|
||||
include/libgeoclue-2.0/gclue-helpers.h
|
||||
include/libgeoclue-2.0/gclue-location.h
|
||||
include/libgeoclue-2.0/gclue-manager.h
|
||||
include/libgeoclue-2.0/gclue-simple.h
|
||||
include/libgeoclue-2.0/geoclue.h
|
||||
lib/girepository-1.0/Geoclue-2.0.typelib
|
||||
lib/libgeoclue-2.so
|
||||
lib/libgeoclue-2.so.0
|
||||
lib/libgeoclue-2.so.0.0.0
|
||||
lib/pkgconfig/geoclue-2.0.pc
|
||||
lib/pkgconfig/libgeoclue-2.0.pc
|
||||
libexec/geoclue
|
||||
libexec/geoclue-2.0/demos/where-am-i
|
||||
man/man5/geoclue.5
|
||||
share/applications/geoclue-where-am-i.desktop
|
||||
share/dbus-1/interfaces/org.freedesktop.GeoClue2.Agent.xml
|
||||
share/dbus-1/interfaces/org.freedesktop.GeoClue2.Client.xml
|
||||
share/dbus-1/interfaces/org.freedesktop.GeoClue2.Location.xml
|
||||
share/dbus-1/interfaces/org.freedesktop.GeoClue2.Manager.xml
|
||||
share/dbus-1/interfaces/org.freedesktop.GeoClue2.xml
|
||||
share/dbus-1/system-services/org.freedesktop.GeoClue2.service
|
||||
share/examples/dbus-1/system.d/org.freedesktop.GeoClue2.Agent.conf
|
||||
share/examples/dbus-1/system.d/org.freedesktop.GeoClue2.conf
|
||||
share/examples/geoclue/geoclue.conf
|
||||
share/gir-1.0/Geoclue-2.0.gir
|
||||
share/gtk-doc/html/geoclue/gdbus-org.freedesktop.GeoClue2.Agent.html
|
||||
share/gtk-doc/html/geoclue/gdbus-org.freedesktop.GeoClue2.Client.html
|
||||
share/gtk-doc/html/geoclue/gdbus-org.freedesktop.GeoClue2.Location.html
|
||||
share/gtk-doc/html/geoclue/gdbus-org.freedesktop.GeoClue2.Manager.html
|
||||
share/gtk-doc/html/geoclue/geoclue-gclue-enums.html
|
||||
share/gtk-doc/html/geoclue/geoclue.devhelp2
|
||||
share/gtk-doc/html/geoclue/home.png
|
||||
share/gtk-doc/html/geoclue/index.html
|
||||
share/gtk-doc/html/geoclue/index.sgml
|
||||
share/gtk-doc/html/geoclue/ix01.html
|
||||
share/gtk-doc/html/geoclue/left-insensitive.png
|
||||
share/gtk-doc/html/geoclue/left.png
|
||||
share/gtk-doc/html/geoclue/license.html
|
||||
share/gtk-doc/html/geoclue/ref-agent-dbus.html
|
||||
share/gtk-doc/html/geoclue/ref-dbus.html
|
||||
share/gtk-doc/html/geoclue/right-insensitive.png
|
||||
share/gtk-doc/html/geoclue/right.png
|
||||
share/gtk-doc/html/geoclue/rn01.html
|
||||
share/gtk-doc/html/geoclue/rn02.html
|
||||
share/gtk-doc/html/geoclue/simple-example.html
|
||||
share/gtk-doc/html/geoclue/simple-master-example.html
|
||||
share/gtk-doc/html/geoclue/style.css
|
||||
share/gtk-doc/html/geoclue/up-insensitive.png
|
||||
share/gtk-doc/html/geoclue/up.png
|
||||
share/gtk-doc/html/libgeoclue/GClueClient.html
|
||||
share/gtk-doc/html/libgeoclue/GClueClientProxy.html
|
||||
share/gtk-doc/html/libgeoclue/GClueLocation.html
|
||||
share/gtk-doc/html/libgeoclue/GClueLocationProxy.html
|
||||
share/gtk-doc/html/libgeoclue/GClueManager.html
|
||||
share/gtk-doc/html/libgeoclue/GClueManagerProxy.html
|
||||
share/gtk-doc/html/libgeoclue/GClueSimple.html
|
||||
share/gtk-doc/html/libgeoclue/annotation-glossary.html
|
||||
share/gtk-doc/html/libgeoclue/ch01.html
|
||||
share/gtk-doc/html/libgeoclue/ch02.html
|
||||
share/gtk-doc/html/libgeoclue/ch03.html
|
||||
share/gtk-doc/html/libgeoclue/ch04.html
|
||||
share/gtk-doc/html/libgeoclue/ch05.html
|
||||
share/gtk-doc/html/libgeoclue/home.png
|
||||
share/gtk-doc/html/libgeoclue/index.html
|
||||
share/gtk-doc/html/libgeoclue/ix01.html
|
||||
share/gtk-doc/html/libgeoclue/left-insensitive.png
|
||||
share/gtk-doc/html/libgeoclue/left.png
|
||||
share/gtk-doc/html/libgeoclue/libgeoclue-gclue-enums.html
|
||||
share/gtk-doc/html/libgeoclue/libgeoclue.devhelp2
|
||||
share/gtk-doc/html/libgeoclue/license.html
|
||||
share/gtk-doc/html/libgeoclue/right-insensitive.png
|
||||
share/gtk-doc/html/libgeoclue/right.png
|
||||
share/gtk-doc/html/libgeoclue/style.css
|
||||
share/gtk-doc/html/libgeoclue/up-insensitive.png
|
||||
share/gtk-doc/html/libgeoclue/up.png
|
||||
share/vala/vapi/libgeoclue-2.0.deps
|
||||
share/vala/vapi/libgeoclue-2.0.vapi
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.9 2020/06/02 08:22:41 adam Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.10 2020/11/04 16:46:59 nia Exp $
|
||||
|
||||
BUILDLINK_TREE+= geoclue
|
||||
|
||||
|
@ -10,8 +10,6 @@ BUILDLINK_ABI_DEPENDS.geoclue+= geoclue>=0.12.0nb21
|
|||
BUILDLINK_PKGSRCDIR.geoclue?= ../../geography/geoclue
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.endif # GEOCLUE_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -geoclue
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2015/11/03 00:08:42 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2020/11/04 16:46:59 nia Exp $
|
||||
|
||||
SHA1 (geoclue-0.12.0.tar.gz) = 0c7d3322ac80e5032b8dd5826ad76517f34c92fd
|
||||
RMD160 (geoclue-0.12.0.tar.gz) = f0198c5b6478df699b71c585d27d6c89d57f496a
|
||||
SHA512 (geoclue-0.12.0.tar.gz) = c65fef518fea5708067def3595a57b2e3cb4c04a3d1c367ac02c4802386a6c8420b3d20f5194896d8e0fdeee6cc6af2744cc920af1ab680a3ca197cb5a5bfab5
|
||||
Size (geoclue-0.12.0.tar.gz) = 567552 bytes
|
||||
SHA1 (geoclue-2.5.6.tar.gz) = f220871a06d195b996f16dee2b7604266fd66a7d
|
||||
RMD160 (geoclue-2.5.6.tar.gz) = c050a7655730d3a4261304d35c7a4f19e2636630
|
||||
SHA512 (geoclue-2.5.6.tar.gz) = 0d428a804408026f844768f5adb44c827d6b3cdaf75d014f233dc2a56a389783de9389e93bba4528b5849a69239e4ce3679111f2517248dff476204df886a94e
|
||||
Size (geoclue-2.5.6.tar.gz) = 114318 bytes
|
||||
SHA1 (patch-data_meson.build) = c785e3401db9f76808dbb682896352b49aaf9112
|
||||
|
|
24
geography/geoclue/patches/patch-data_meson.build
Normal file
24
geography/geoclue/patches/patch-data_meson.build
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-data_meson.build,v 1.1 2020/11/04 16:46:59 nia Exp $
|
||||
|
||||
Install config files to examples.
|
||||
|
||||
--- data/meson.build.orig 2020-02-26 13:19:24.000000000 +0000
|
||||
+++ data/meson.build
|
||||
@@ -11,7 +11,7 @@ if get_option('enable-backend')
|
||||
configure_file(output: 'geoclue.conf',
|
||||
input: 'geoclue.conf.in',
|
||||
configuration: conf,
|
||||
- install_dir: conf_dir)
|
||||
+ install_dir: join_paths(datadir, 'examples', 'geoclue'))
|
||||
|
||||
conf = configuration_data()
|
||||
conf.set('libexecdir', libexecdir)
|
||||
@@ -33,7 +33,7 @@ if get_option('enable-backend')
|
||||
# DBus Service policy file
|
||||
dbus_service_dir = get_option('dbus-sys-dir')
|
||||
if dbus_service_dir == ''
|
||||
- dbus_service_dir = join_paths(sysconfdir, 'dbus-1', 'system.d')
|
||||
+ dbus_service_dir = join_paths(datadir, 'examples', 'dbus-1', 'system.d')
|
||||
endif
|
||||
configure_file(output: 'org.freedesktop.GeoClue2.conf',
|
||||
input: 'org.freedesktop.GeoClue2.conf.in',
|
Loading…
Reference in a new issue